[SOLVED] No sound after resume, needs to reboot
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Apr 2011
    Posts
    83

    No sound after resume, needs to reboot

    Hi,
    I'm using Fedora 28 KDE and my computer has 2 soundcards, an Intel Integrated Audio and a Terratec Phase 22 PCI soundcard (ICE1724). When resuming after suspend the Terratec soundcard doesn't work. I searched for a solution but all I found was mostly for Debian based distros. The "pulseaudio -k && sudo alsa force-reload" solution works for Debian based distros but it doesn't have an equivalence in Fedora or at least I don't know how to do it and I didn't find how to do it.

    Could you give me an idea about how to solve it?

    Thank you very much in advance.

  2. #2
    Join Date
    Apr 2011
    Posts
    83

    Re: No sound after resume, needs to reboot

    I did a search on this forum and I found this thread:
    https://forums.fedoraforum.org/showt...suspend-resume
    But it doesn't work on F28:
    Code:
    sudo rmmod snd* soundcore
    rmmod: ERROR: Module snd* is not currently loaded
    rmmod: ERROR: Module soundcore is in use by: snd
    Any idea?

  3. #3
    Join Date
    Apr 2011
    Posts
    83
    Linux (Fedora) Firefox 62.0

    Re: No sound after resume, needs to reboot

    This issue seems to be around 10 years old it's weird there's no solution yet. Even it seems to be a patch which solves it but it has never been applied to Fedora.

  4. #4
    Join Date
    Apr 2011
    Posts
    83
    Linux (Fedora) Firefox 62.0

    Re: No sound after resume, needs to reboot

    This is an old thread about this issue: https://www.spinics.net/lists/alsa-devel/msg25090.html

  5. #5
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,497
    Windows NT 10.0 Chrome 70.0.3538.67

    Re: No sound after resume, needs to reboot

    well it seems from the lack of responses that nobody here has an answer for you unfortunately. you have a very unique setup which unless someone else had the same and solved it somehow we can't really help in the user forum. have you tried ask.fedoraproject.org?

  6. #6
    Join Date
    Apr 2011
    Posts
    83
    Linux (Fedora) Firefox 62.0

    Re: No sound after resume, needs to reboot

    Thank you for your reply.
    I'll try with ask.fedoraproject.org
    It's weird because the ice1724 chipset is fairly common.

  7. #7
    Join Date
    Apr 2011
    Posts
    83
    Linux (Fedora) Firefox 63.0

    Re: No sound after resume, needs to reboot

    Finally, I found a solution here:
    https://www.dell.com/community/Linux...5169011/page/2
    The script works nicely.

Similar Threads

  1. No Sound after Resume
    By JoaoMachado in forum Alpha, Beta & Snapshots Discussions (Fedora 10 Only)
    Replies: 0
    Last Post: 4th November 2008, 12:08 AM
  2. FC8: Sound hangs after suspend/resume
    By tjrob in forum Hardware & Laptops
    Replies: 4
    Last Post: 24th December 2007, 09:25 PM
  3. Fedora 7 sound appears after resume
    By dshaw7 in forum Using Fedora
    Replies: 0
    Last Post: 6th November 2007, 12:48 AM
  4. No sound after resume with FC5 on ThinkPad 600X
    By Cabbage in forum Hardware & Laptops
    Replies: 5
    Last Post: 30th August 2006, 05:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •