Fedora 28: VLC and qBittorrent would take entire workspace.
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 12 of 12
  1. #1
    Join Date
    Jan 2018
    Location
    USA
    Posts
    56

    Fedora 28: VLC and qBittorrent would take entire workspace.

    Hi there,

    I do not know why VLC and qBittorrent program is so big that they would take entire Workspace.

    Click image for larger version. 

Name:	Workspaces_002.jpg 
Views:	32 
Size:	29.7 KB 
ID:	29610

    Can you teach me how to fix it?

    Thanks.

  2. #2
    Join Date
    Jan 2018
    Location
    USA
    Posts
    56

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    Here is my OS information shown in Firefox.

    Code:
    Application Basics
    Name: Firefox
    Version: 60.0
    Build ID: 20180507144316
    User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
    OS: Linux 4.16.8-300.fc28.x86_64
    Multiprocess Windows: 1/1 (Enabled by default)
    Web Content Processes: 3/4
    Stylo: content = true (enabled by default), chrome = true (enabled by default)
    Enterprise Policies: Inactive
    Google Key: Found
    Mozilla Location Service Key: Found
    Safe Mode: false
    
    Graphics
    --------
    Features
    Compositing: Basic
    Asynchronous Pan/Zoom: wheel input enabled; scrollbar drag enabled; keyboard enabled; autoscroll enabled
    WebGL 1 Driver WSI Info: GLX 1.4 GLX_VENDOR(client): NVIDIA Corporation GLX_VENDOR(server): NVIDIA Corporation Extensions: GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_import_context GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGI_video_sync GLX_SGI_swap_control GLX_EXT_swap_control GLX_EXT_swap_control_tear GLX_EXT_texture_from_pixmap GLX_EXT_buffer_age GLX_ARB_create_context GLX_ARB_create_context_profile GLX_EXT_create_context_es_profile GLX_EXT_create_context_es2_profile GLX_ARB_create_context_no_error GLX_ARB_create_context_robustness GLX_NV_delay_before_swap GLX_EXT_stereo_tree GLX_ARB_context_flush_control GLX_NV_robustness_video_memory_purge GLX_ARB_multisample GLX_NV_float_buffer GLX_ARB_fbconfig_float GLX_EXT_framebuffer_sRGB GLX_NV_copy_image GLX_ARB_get_proc_address
    WebGL 1 Driver Renderer: NVIDIA Corporation -- GeForce GTX 750 Ti/PCIe/SSE2
    WebGL 1 Driver Version: 4.6.0 NVIDIA 390.48
    
    GPU #1
    Active: Yes
    Description: NVIDIA Corporation -- GeForce GTX 750 Ti/PCIe/SSE2
    Vendor ID: NVIDIA Corporation
    Device ID: GeForce GTX 750 Ti/PCIe/SSE2
    Driver Version: 4.6.0 NVIDIA 390.48

  3. #3
    Join Date
    Dec 2007
    Location
    Albuquerque, New Mexico USA
    Age
    65
    Posts
    161

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    Does the windows options menu appear when you right click in the area at the top of the window?
    Hope is not a plan

  4. #4
    Join Date
    Jan 2018
    Location
    USA
    Posts
    56

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    I have just right clicked on the title bar of qBittorrent, and I have seen "Minimize", "Maximize", "Move", and "Resize" options. However, the "Resize" would not help, as the window would keep staying on the same size, which is so big.

    Thanks.

  5. #5
    Join Date
    Jan 2018
    Location
    USA
    Posts
    56

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    Help is greatly appreciated, as I still do not know how to fix them. This size issue only effects VLC and qBittorrent application at the moment.

  6. #6
    Join Date
    Dec 2007
    Location
    Albuquerque, New Mexico USA
    Age
    65
    Posts
    161

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    I understand the problem, but I sure don't understand what might be happening. I don't have qBittorrent installed, but I do have VLC and it works without issue.

    I apologize that this is very basic, but I'm trying to get the fault a little better defined in my mind. Could you describe exactly what happens when you do the following:

    Right click on the title bar. Click on Maximize. Right click on the title bar again then click on "Unmaximize" (btw, that's a new one on me. I just noticed it).

    Right click in the title bar again. This time click on "resize". Move the mouse cursor to the right edge of the screen. Does the pointer change to the frame grabber shape?

    If the cursor changes, press the left mouse button and drag the cursor to the left. Release the mouse button. Does the frame move then spring back when the mouse button is released or is the frame "stuck" at full-size?
    Last edited by rbmorse; 22nd May 2018 at 04:19 AM.
    Hope is not a plan

  7. #7
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,277

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    which desktop environment are you using, it's impossible to tell from the attached image. VLC and qBittorrent are both Qt framework applications so if you are using them with the combination of GNOME (wayland? try logging into a Xorg session instead) and proprietary NVIDIA drivers you have to expect some functionality issues.

  8. #8
    Join Date
    Jan 2018
    Location
    USA
    Posts
    56

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    I am using Fedora 28 with Gnome DE. I am using XOrg on both Notebook and PC. This problem happens on both Notebook and this PC.

    sudo nano /etc/gdm/custom.conf
    # Uncoment the line below to force the login screen to use Xorg
    #WaylandEnable=false

    I think the problem started, because of the steps below, which I performed on this PC. I do not have my notebook with me at the moment. I think it is one of these steps, because this page looks different than what I have done in the past. Someone updated the site https://rpmfusion.org/Howto/NVIDIA?h...tegoryHowto%29

    sudo dnf install xorg-x11-drv-nvidia akmod-nvidia
    sudo dnf install xorg-x11-drv-nvidia-cuda
    sudo dnf update -y
    sudo grubby --update-kernel=ALL --args='nvidia-drm.modeset=1'
    sudo dnf install vulkan
    sudo dnf copr enable mati865/mutter-eglstream
    sudo dnf --disablerepo="*" --enablerepo="mati865-mutter-eglstream" reinstall mutter
    sudo dnf install xorg-x11-drv-nvidia-cuda-libs
    sudo dnf install xorg-x11-drv-nvidia-libs.i686
    sudo dnf install vdpauinfo libva-vdpau-driver libva-utils

    Now, per your questions, I perform the following on qBittorrent.
    when I Right click on the title bar. Click on Maximize. Right click on the title bar again then click on "Unmaximize"
    Both Maximize and Minimize work perfectly okay. They both behave normally.

    Right click in the title bar again. This time click on "resize". Move the mouse cursor to the right edge of the screen. Does the pointer change to the frame grabber shape?
    When I do what you mentioned, I would see the number 1170 x 332 and my mouse cursor would change to frame grabber shape. However, when I move my mouse cursor to the edge, I can resize only just a bit. It would still be really big, almost twice the size of my monitor.

    For VLC I can resize it to 473 x68 as the smallest window. Yes, it is still too big.

    Thank you so much everyone.

  9. #9
    Join Date
    Dec 2007
    Location
    Albuquerque, New Mexico USA
    Age
    65
    Posts
    161

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    If you are using the proprietary Nvidia drivers, which it seems you are (390.48), you need to remove the "#" character at the beginning of the line:

    Code:
    #WaylandEnable=false

    in /etc/gdm/custom.conf. Save and reboot.

    I'm not sure if that will fix the problem, but it's the correct setting for using the proprietary driver and might help here.
    Hope is not a plan

  10. #10
    Join Date
    Jan 2018
    Location
    USA
    Posts
    56

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    Thank you so much for your suggestion. It has not fixed the issue, but I will look further for more information.

  11. #11
    Join Date
    Jan 2018
    Location
    USA
    Posts
    56

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    Hi everyone,

    I have just received qt update through "sudo dnf update", and both VLC and qBittorrent are now fixed on my notebook. However, the latest kernel that I have just received crashed my PC I keep seeing "A start job is running for Hold unt finishes up (13 min 20s / no limit)", during boot.

    Thanks.

  12. #12
    Join Date
    Jan 2018
    Location
    USA
    Posts
    56

    Re: Fedora 28: VLC and qBittorrent would take entire workspace.

    Hi again,

    I had to use Fedora 28 Gnome in "Recovery Mode" for the past 3 days on my PC. However, upon executing "sudo dnf update" on the PC, just now, my PC is now fixed. VLC and qBittorrent is still really big, though This same problem with VLC and qBittorrent is no longer an issue on my notebook with Fedora 28 Gnome.

    Thank you.

Similar Threads

  1. Replies: 3
    Last Post: 5th December 2012, 10:11 PM
  2. Qbittorrent-2.2.0rc1 rpm's
    By leigh123linux in forum Fedora Focus
    Replies: 48
    Last Post: 4th March 2010, 11:24 PM
  3. Qbittorrent repo for F9 & F10
    By leigh123linux in forum Fedora Focus
    Replies: 31
    Last Post: 8th March 2009, 11:21 PM
  4. qbittorrent for ppc & ppc64
    By leigh123linux in forum Mac Chat
    Replies: 0
    Last Post: 10th February 2009, 11:37 PM
  5. problems compiling qbittorrent
    By fakie_flip in forum Using Fedora
    Replies: 13
    Last Post: 25th March 2008, 12:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •