FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2018
    Location
    USA
    Posts
    54

    Fedora 28: NVIDIA-Linux-x86_64-304.137 Driver.

    Hi there,

    I notice that NVIDIA-Linux-x86_64-304.137 driver looks different than in the past, as you can see from the image below.

    Click image for larger version. 

Name:	Selection_001.png 
Views:	20 
Size:	52.4 KB 
ID:	29609

    Can you let me know why "Gnome Software" would let me use Nvidia 3:390.48-2.fc28, instead of NVIDIA-Linux-x86_64-304.137? What would happen in the near future if the driver NVIDIA-Linux-x86_64-304.137 would no longer be available? Did RPM Fusion forget to apply the patch as you can see from the link below?

    https://www.if-not-true-then-false.c...-nvidia-guide/
    https://www.if-not-true-then-false.c...ched-installer
    Note 304.137 users: 304.137 on Fedora 27/26 (old kernel 4.15) and 25/24/23 – installs and boot, but doesn’t work with Gnome 3.26/3.24/3.22/3.20/3.18. Other DEs/WMs should work normally. Kernel 4.15/4.14 needs a patched version (Download NVIDIA-Linux-x86_64-304.137 with Kernel 4.14+ patch)
    Thank you.

  2. #2
    Join Date
    Apr 2018
    Location
    California
    Posts
    27

    Re: Fedora 28: NVIDIA-Linux-x86_64-304.137 Driver.

    This post is confusing. Your image clearly shows info on the 390 driver, which is much newer than the 304 driver. Is this some reason you need to use the old driver? RPM Fusion did apply the patch to the 390 driver; I've used it on both F27 & F28.

  3. #3
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,984

    Re: Fedora 28: NVIDIA-Linux-x86_64-304.137 Driver.

    zethan, have you got end of life NVIDIA hardware only supported by 304.X? If so then either switch to nouveau or carry on using 304.X drivers since installing 390.X won't actually work. Just because GNOME Software offers a package it doesn't mean you should necessarily install it to an already functioning system.

  4. #4
    Join Date
    Jan 2018
    Location
    USA
    Posts
    54

    Re: Fedora 28: NVIDIA-Linux-x86_64-304.137 Driver.

    Thanks for your help, everyone. No, I did not forget that NVIDIA-Linux-x86_64-304.137 is EOL. It is just that I have just installed it, and have just used it in Fedora 27. Now, it looks different, and I want to see your opinion what it would be like in the near future. Now, I can't play any WINE game on PlayonLinux, as It can't find OpenGL.

    Here are the steps that I have just done.

    Code:
    sudo dnf remove xorg-x11-drv-nvidia\*
    Dependencies resolved.
    ================================================================================
     Package         Arch   Version          Repository                        Size
    ================================================================================
    Removing:
     xorg-x11-drv-nvidia
                     x86_64 3:390.48-2.fc28  @rpmfusion-nonfree-nvidia-driver  22 M
     xorg-x11-drv-nvidia-cuda
                     x86_64 3:390.48-2.fc28  @rpmfusion-nonfree-nvidia-driver 863 k
     xorg-x11-drv-nvidia-cuda-libs
                     i686   3:390.48-2.fc28  @rpmfusion-nonfree-nvidia-driver  83 M
     xorg-x11-drv-nvidia-cuda-libs
                     x86_64 3:390.48-2.fc28  @rpmfusion-nonfree-nvidia-driver  84 M
     xorg-x11-drv-nvidia-kmodsrc
                     x86_64 3:390.48-2.fc28  @rpmfusion-nonfree-nvidia-driver 8.0 M
     xorg-x11-drv-nvidia-libs
                     i686   3:390.48-2.fc28  @rpmfusion-nonfree-nvidia-driver  63 M
     xorg-x11-drv-nvidia-libs
                     x86_64 3:390.48-2.fc28  @rpmfusion-nonfree-nvidia-driver  58 M
    Removing dependent packages:
     akmod-nvidia    x86_64 3:390.48-1.fc28  @rpmfusion-nonfree-nvidia-driver  62 k
     kmod-nvidia-4.16.8-300.fc28.x86_64
                     x86_64 3:390.48-1.fc28  @@commandline                     22 M
     mesa-libGLES    i686   18.0.2-1.fc28    @updates                           0  
    Removing unused dependencies:
     akmods          noarch 0.5.6-15.fc28    @fedora                           32 k
     egl-wayland     i686   1.0.3-2.20180201git6f5f7d0.fc28
                                             @fedora                           53 k
     egl-wayland     x86_64 1.0.3-2.20180201git6f5f7d0.fc28
                                             @fedora                           50 k
     elfutils-libelf-devel
                     x86_64 0.170-11.fc28    @fedora                           32 k
     kmodtool        noarch 1-29.fc28        @fedora                           17 k
     libglvnd-gles   i686   1:1.0.1-0.5.20180327git5baa1e5.fc28
                                             @fedora                           92 k
     libglvnd-opengl i686   1:1.0.1-0.5.20180327git5baa1e5.fc28
                                             @fedora                          134 k
     mesa-libGLES    x86_64 18.0.2-1.fc28    @updates                           0  
     nvidia-persistenced
                     x86_64 390.48-1.fc28    @rpmfusion-nonfree-nvidia-driver  74 k
     nvidia-settings x86_64 390.48-3.fc28    @rpmfusion-nonfree-nvidia-driver 4.7 M
     zlib-devel      x86_64 1.2.11-8.fc28    @updates                         138 k
    
    Transaction Summary
    ================================================================================
    Remove  21 Packages
    
    Freed space: 347 M
    Is this ok [y/N]: y
    Code:
    sudo dnf install xorg-x11-drv-nvidia-304xx akmod-nvidia-304xx
    Last metadata expiration check: 0:34:12 ago on Fri 18 May 2018 06:28:17 AM PDT.
    Dependencies resolved.
    ================================================================================
     Package                             Arch   Version     Repository         Size
    ================================================================================
    Installing:
     rpmfusion-nonfree-obsolete-packages noarch 28-1.fc28   rpmfusion-nonfree 8.1 k
    
    Transaction Summary
    ================================================================================
    Install  1 Package
    
    Total download size: 8.1 k
    Installed size: 150  
    Is this ok [y/N]: y
    Code:
    sudo dnf install xorg-x11-drv-nvidia-cuda
    Last metadata expiration check: 0:37:08 ago on Fri 18 May 2018 06:28:17 AM PDT.
    Error: 
     Problem: package xorg-x11-drv-nvidia-cuda-3:390.48-2.fc28.x86_64 requires nvidia-kmod >= 3:390.48, but none of the providers can be installed
      - package kmod-nvidia-3:390.48-1.fc28.x86_64 requires akmod-nvidia = 3:390.48-1.fc28, but none of the providers can be installed
      - package akmod-nvidia-3:390.48-1.fc28.x86_64 requires nvidia-kmod-common >= 3:390.48, but none of the providers can be installed
      - package xorg-x11-drv-nvidia-3:390.48-2.fc28.x86_64 conflicts with xorg-x11-drv-nvidia-304xx provided by rpmfusion-nonfree-obsolete-packages-28-1.fc28.noarch
      - problem with installed package rpmfusion-nonfree-obsolete-packages-28-1.fc28.noarch
      - conflicting requests
    (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)
    sudo grubby --update-kernel=ALL --args='nvidia-drm.modeset=1'

    Code:
    sudo dnf install vulkan
    Last metadata expiration check: 0:45:20 ago on Fri 18 May 2018 06:28:17 AM PDT.
    Package vulkan-1.1.73.0-1.fc28.x86_64 is already installed, skipping.
    Package vulkan-1.1.73.0-1.fc28.i686 is already installed, skipping.
    Code:
    sudo dnf copr enable mati865/mutter-eglstream
    Code:
    sudo dnf --disablerepo="*" --enablerepo="mati865-mutter-eglstream" reinstall mutter
    Last metadata expiration check: 0:00:00 ago on Fri 18 May 2018 07:18:01 AM PDT.
    Dependencies resolved.
    ================================================================================
     Package    Arch       Version               Repository                    Size
    ================================================================================
    Reinstalling:
     mutter     x86_64     1:3.28.2-1.fc28       mati865-mutter-eglstream     2.3 M
    Code:
    sudo dnf install xorg-x11-drv-nvidia-cuda-libs
    Dependencies resolved.
    ================================================================================
     Package           Arch   Version         Repository                       Size
    ================================================================================
    Installing:
     xorg-x11-drv-nvidia-cuda-libs
                       x86_64 3:390.48-2.fc28 rpmfusion-nonfree-nvidia-driver  23 M
    Code:
    sudo dnf install xorg-x11-drv-nvidia-libs.i686
    Dependencies resolved.
    ================================================================================
     Package            Arch   Version                             Repository  Size
    ================================================================================
    Installing:
     xorg-x11-drv-nvidia-libs
                        i686   3:390.48-2.fc28                     rpmfusion-nonfree-nvidia-driver
                                                                               16 M
    Installing dependencies:
     egl-wayland        i686   1.0.3-2.20180201git6f5f7d0.fc28     fedora      30 k
     egl-wayland        x86_64 1.0.3-2.20180201git6f5f7d0.fc28     fedora      29 k
     libglvnd-gles      i686   1:1.0.1-0.5.20180327git5baa1e5.fc28 fedora      38 k
     libglvnd-opengl    i686   1:1.0.1-0.5.20180327git5baa1e5.fc28 fedora      45 k
     mesa-libGLES       i686   18.0.2-1.fc28                       updates     28 k
     mesa-libGLES       x86_64 18.0.2-1.fc28                       updates     28 k
    Code:
    sudo dnf install vdpauinfo libva-vdpau-driver libva-utils
    Package vdpauinfo-1.0-9.fc28.x86_64 is already installed, skipping.
    Package libva-vdpau-driver-0.7.4-21.fc28.x86_64 is already installed, skipping.
    Package libva-utils-2.1.0-1.fc28.x86_64 is already installed, skipping.
    Code:
    sudo nano /etc/gdm/custom.conf
    WaylandEnable=true
    Then, I rebooted the OS. However, during the Gnome logging in, I would still need to use XOrg or my notebook would be hanging.

    I really hope my notebook would work great again with NVIDIA-Linux-x86_64-304.137. Does anyone know how to fix it? What does the following do?

    Installing:
    rpmfusion-nonfree-obsolete-packages noarch 28-1.fc28 rpmfusion-nonfree 8.1 k

Similar Threads

  1. NVidia Linux driver manual install + Fedora 21 = quiet NVidia GTX 980 fans + high res
    By Jeff72 in forum Guides & Solutions (Not For Questions)
    Replies: 6
    Last Post: 2nd April 2015, 12:48 AM
  2. Replies: 1
    Last Post: 15th November 2014, 05:02 AM
  3. LiveUSB Fedora 13 x86_64 - Nvidia driver issue
    By Vardoger in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 10th August 2010, 11:49 PM
  4. Fedora 10 x86_64 nVidia GeForce 8600m GT GPU Driver
    By Keyth13 in forum Using Fedora
    Replies: 14
    Last Post: 7th February 2009, 08:02 PM
  5. Fedora 7 x86_64 nvidia driver trouble
    By jdeslip in forum Using Fedora
    Replies: 6
    Last Post: 26th June 2007, 09:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •