Python3-Django install problems on Fedora28/Linode:
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    May 2018
    Location
    USA
    Posts
    3

    Python3-Django install problems on Fedora28/Linode:

    I've done a fresh install of Fedora 28 on a new Linode virtual machine (using Linode's Fedora 28 image) and am attempting to install the python3-django package. I get the following errors:

    $ sudo dnf install python3-django
    Last metadata expiration check: 1:40:55 ago on Tue 15 May 2018 08:18:48 PM EDT.
    Error:
    Problem: conflicting requests
    - nothing provides python-django-bash-completion = 2.0.5-1.fc28 needed by python3-django-2.0.5-1.fc28.noarch
    - nothing provides python-django-bash-completion = 2.0.4-1.fc28 needed by python3-django-2.0.4-1.fc28.noarch

    There appears to be one python-django-bash-completion package in the dnf repo, which is already installed on the system:
    Source : python-django-1.6.11.7-2.module_1595+34c51ab8.src.rpm

    Any ideas how I can install the dependency it claims to need (or otherwise fix this)?

    Thanks!
    S.M.

  2. #2
    Join Date
    May 2018
    Location
    USA
    Posts
    3

    Re: Python3-Django install problems on Fedora28/Linode:

    Following up to my own post:

    I looked around on the net and found the missing rpm, downloaded it, and installed it manually first with:

    sudo dnf --disablerepo='*' install tmp/python-django-bash-completion-2.0.5-1.fc28.noarch.rpm

    Is there something missing in the Fedora package repos for Fedora28? Or is this a peculiarity of the Linode image?

    S.M.

  3. #3
    Join Date
    Aug 2016
    Location
    Dallas
    Posts
    68

    Re: Python3-Django install problems on Fedora28/Linode:

    I'm confused, are you just trying to get Django on fedora 28? Or is the package youre mentioning something else? I've always done it in the fashion decribed in the link below.

    https://developer.fedoraproject.org/...tallation.html

  4. #4
    Join Date
    May 2018
    Location
    USA
    Posts
    3

    Re: Python3-Django install problems on Fedora28/Linode:

    The link you provided describes how to install Django using pip from the PyPI.

    Fedora provides its own Django package which you should be able to install with the following command:

    $ sudo dnf install python3-django

    This should also automatically install all dependent packages too. What I'm saying is that it instead complains about a missing dependency (python-django-bash-completion-2.0.5-1.fc28.noarch.rpm) which I had to manually download and install first.

    S.M.

Similar Threads

  1. Replies: 3
    Last Post: 16th May 2018, 10:30 AM
  2. Can't install python3.3 on Fedora 17 x86_64
    By mrfool in forum Using Fedora
    Replies: 3
    Last Post: 2nd April 2013, 09:33 PM
  3. Safe way to install Python3 on FC12?
    By tashirosgt in forum Programming & Packaging
    Replies: 2
    Last Post: 25th September 2010, 04:07 AM
  4. Feodra Desktop on Linode VPS
    By astrashe in forum Using Fedora
    Replies: 1
    Last Post: 4th June 2010, 03:26 PM
  5. Rails vs Django
    By Query in forum Programming & Packaging
    Replies: 6
    Last Post: 28th June 2009, 06:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •