Fedora 28 Join AD Domain in Air Gap
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    May 2018
    Lancaster, CA.

    Fedora 28 Join AD Domain in Air Gap

    Hello everyone, I'm having an issue (and have seen this on Fedora 27 as well) when attempting to "realm join" to an Air Gapped (no internet access) AD Domain e.g.; foo.local

    When doing so, the system errors (does not join AD) and complains of the following: "cannot update repo 'fedora': Cannot prepare internal mirrorlist: Curl error(6): Couldn't resolve host name for https://mirrors.fedoraproject.org/me...28&arch=x86_64[Could not resolve host: mirrors.fedoraproject.org]

    This occurs on first boot after a fresh install and choosing "Enterprise Login" or even if I create a local user and attempt to realm join when using the terminal...

    Does anyone know why the system is insisting on updating a mirror after joining? RHEL and Centos do not exhibit this behavior... I have no way of getting to the fedora mirrors, but would love to be able to use a fedora system on my network...

  2. #2
    Join Date
    Dec 2017

    Re: Fedora 28 Join AD Domain in Air Gap

    Without being able to definitively answer the question, here are a few back at you:
    Do you suspect the system is looking to install auxiliary packages, perhaps like automount or -utils packages of some sort? Perhaps not everything was installed correctly. Can you do a realm -v join and share the scrubbed output (have fun with the re-typing over the air gap!)?

    Have you tried just inserting a hosts or dnsmasq entry for mirrors.fedoraproject.org so it resolves to something and hopefully continues on with "no packages to update"?

Similar Threads

  1. Join a domain
    By thomazpo in forum Servers & Networking
    Replies: 1
    Last Post: 4th January 2016, 08:55 PM
  2. [SOLVED]
    join Fedora to Windows Domain
    By Obould in forum Servers & Networking
    Replies: 1
    Last Post: 2nd December 2010, 11:17 PM
  3. Join Fedora 11 into Windows domain
    By pejoni in forum Servers & Networking
    Replies: 4
    Last Post: 6th January 2010, 04:36 PM
  4. Replies: 9
    Last Post: 29th September 2009, 07:16 PM
  5. Samba as BDC on Fedora 11 and WinXP SP3 not join in domain
    By Luk_ in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 29th September 2009, 04:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts