[SOLVED] Fedora 28 - slow boot time
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    May 2018
    Location
    Austria
    Posts
    2

    Fedora 28 - slow boot time

    Good afternoon all,

    I installed Fedora 28 on my HP 17,3 " Intel Core i5-7200U, 2x 2.50GHz, 8GB DDR4 RAM, 1TB HDD, AMD Radeon 520, 2GB, HDMI notebook.

    Performing a "systemd-analyze" command via terminal leads to a total boot time (kernel, user space, graphical environment) of about 1,46 minutes.

    I used to use Debian for a long time within the same notebook and under Debian 9 the boot time was about 36 seconds.

    Performing a "systemd-analyze critical-chain" command does not help me any further at all, the only "slow" service is "libvirt" with about 6 extra seconds, the other services are rather inconspicuous.

    So is it because of Selinux that Fedora boots extremely slow in general or are there any other things to keep in mind ? Debian uses Apparmor btw. and lasts only one third compared to Fedora.

    Even a bloated Ubuntu 18.04 only needs about one minute to boot. So I am helpless.

    BTW the "kernel not configured for semaphores" - bug at shutdown known since Fedora 26 also appears.

    Thank you in advance for your help.


    Update: After performing a "dracut -fv" plus after autorelabeling systemd via "touch /. autorelabel" boot time increased and now Fedora 28 takes 1,09 minutes to boot - 37 seconds faster than before. I can live with that. The annoying "kernel not compiled for semaphores" - bug unfortunately still exists since version 26 - no one seems to be interested in solving it, sad but true.
    Last edited by marfla; 14th May 2018 at 02:05 PM.

  2. #2
    Join Date
    Jul 2017
    Location
    toronto
    Posts
    45

    Re: Fedora 28 - slow boot time

    Quote Originally Posted by marfla
    Good afternoon all,

    I installed Fedora 28 on my HP 17,3 " Intel Core i5-7200U, 2x 2.50GHz, 8GB DDR4 RAM, 1TB HDD, AMD Radeon 520, 2GB, HDMI notebook.

    Performing a "systemd-analyze" command via terminal leads to a total boot time (kernel, user space, graphical environment) of about 1,46 minutes.
    Could you post your 'systemd-analyze blame' output and perhaps 'journalctl -p 5' and 'systemctl'? Maybe someone could offer tips on your current services.

    Debian seemed to boot faster for me as well, but it didn't come with all the security protections that Fedora has.

  3. #3
    Join Date
    Dec 2013
    Location
    Den Haag
    Posts
    70

    Re: Fedora 28 - slow boot time

    tip - systemctl mask network.service and NetworkMananager-wait-online.service - these are known to stall boot times quite a bit (although in F28 booting with them before masking them did not show real stalls. I have seen wait-online to hold boots for minutes in older releases). I have yet to see the need for these 2 services, maybe you need them for apps reaching out over a network very early in bringing up your system

  4. #4
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    935

    Re: Fedora 28 - slow boot time

    Quote Originally Posted by marfla
    Update: After performing a "dracut -fv" plus after autorelabeling systemd via "touch /. autorelabel" boot time increased and now Fedora 28 takes 1,09 minutes to boot - 37 seconds faster than before. I can live with that. The annoying "kernel not compiled for semaphores" - bug unfortunately still exists since version 26 - no one seems to be interested in solving it, sad but true.
    Hi. I suffer from same similar issue. Though it improve after upgrade from Fedora 26 to 28. On 26 it was 3 & 1/2 minutes ! But on 28 it is 2 & 1/2 minutes !

    However, 2 & 1/2 minutes is still long !

    Please can you, kindly, explain more about these 2 commands ?

    1) what is the action of "dracut -fv" ?

    2) does "dracut -fv" should performed with su or without root privilege ?

    3) regarding "touch /. autorelabel" does it need root (su) or it should performed without root privilege ?

    4) does these 2 commands (or one of them) carry a risk of damaging system ?

    Best.
    Fedora 28 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

  5. #5
    Join Date
    Dec 2013
    Location
    Den Haag
    Posts
    70

    Re: Fedora 28 - slow boot time

    1) man dracut:
    -f, --force
    overwrite existing initramfs file.
    -v, --verbose
    increase verbosity level (default is info(4))
    2) dracut always requires root priv
    3) autorelabel is only applicable if you have selinux enforcing. check with command "sestatus". Also root, I guess. I run with selinux disabled
    4) probably yes.

  6. #6
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,285

    Re: Fedora 28 - slow boot time

    you could also consider removing plymouth. plymouth slows the boot process to display the splash screen instead of text output

    https://forums.fedoraforum.org/showt...85#post1742785

  7. #7
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    935

    Re: Fedora 28 - slow boot time

    Quote Originally Posted by marfla
    Good afternoon all,

    I installed Fedora 28 on my HP 17,3 " Intel Core i5-7200U, 2x 2.50GHz, 8GB DDR4 RAM, 1TB HDD, AMD Radeon 520, 2GB, HDMI notebook.

    Performing a "systemd-analyze" command via terminal leads to a total boot time (kernel, user space, graphical environment) of about 1,46 minutes.

    I used to use Debian for a long time within the same notebook and under Debian 9 the boot time was about 36 seconds.

    Performing a "systemd-analyze critical-chain" command does not help me any further at all, the only "slow" service is "libvirt" with about 6 extra seconds, the other services are rather inconspicuous.

    So is it because of Selinux that Fedora boots extremely slow in general or are there any other things to keep in mind ? Debian uses Apparmor btw. and lasts only one third compared to Fedora.

    Even a bloated Ubuntu 18.04 only needs about one minute to boot. So I am helpless.

    BTW the "kernel not configured for semaphores" - bug at shutdown known since Fedora 26 also appears.

    Thank you in advance for your help.


    Update: After performing a "dracut -fv" plus after autorelabeling systemd via "touch /. autorelabel"
    O.K I will try these but please just I like to sure the sequence of them is as following:

    1st
    sudo dracut -fv

    2nd
    sudo touch /. autorelabel

    Is this correct or I have to perform them inversely ? The word "plus after" confuse me ....... Sorry, but I'm not native English tongue & the process seem to be sensitive & should avoid any mistake in perform it.
    Fedora 28 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

Similar Threads

  1. [SOLVED]
    Slow boot time in Fedora 24 (Updated from 22)
    By hunter86bg in forum Using Fedora
    Replies: 10
    Last Post: 4th August 2016, 10:10 AM
  2. [SOLVED]
    Fedora 16 slow boot time
    By karthikp in forum Using Fedora
    Replies: 18
    Last Post: 24th March 2012, 12:14 PM
  3. Slow Boot time fedora 12
    By jcrivera in forum Using Fedora
    Replies: 6
    Last Post: 25th June 2010, 01:36 PM
  4. Fedora 11: Slow boot time
    By mattyjim in forum Using Fedora
    Replies: 10
    Last Post: 6th December 2009, 11:52 PM
  5. Fedora 9 Very Slow Boot Time
    By lovemonkey16 in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 20th November 2008, 07:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •