[SOLVED] ghdl in Fedora 28
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Nov 2008
    Posts
    84

    ghdl in Fedora 28

    Fedora 28 installed from scratch on the hard disk of fairly common hardware -- (Intel mother board, two 2TB hard disks etc.
    Did dnf upgrade, so it is up to date.
    Group installed C compiler libraries etc. and then installed ghdl.

    To test ghdl, I tried to simulate some simple vhdl designs which compile and simulate correctly on Fedora 27.
    On Fedora 28, Analysis of vhdl file goes through fine. When I try to elaborate the design using:
    ghdl -e testbench
    I get an error:

    /usr/bin/ld: cannot find -lgnat-7
    collect2: error: ld returned 1 exit status
    ghdl:error: compilation error

    Is there something missing in the ghdl disrtibution?
    I thought it had pulled in gnat as usual at the time of installation.
    Could the problem be that the library path used by ld has not been upgraded? (The problem persists after re-boot).

  2. #2
    Join Date
    Nov 2008
    Posts
    84

    Re: ghdl in Fedora 28

    Perhaps ghdl is not used by a lot of readers of this forum -- so there was no response.
    However, since I have found a work around for the problem, I shall post it here.

    The gnat library provided with ghdl on Fedora 28 is version 8. From the error message it is clear that it is looking for version 7.
    I have used a dirty work around by placing a symbolic link to libgnat-8.so called libgnat-7.so in /usr/lib64. Now ghdl can elaborate and run designs.

    Hopfully when the ghdl binary is re-compiled, this bug will go away. Obviously this package was not well tested before being put in the distribution.
    Next project: To find out how to mark this topic as solved!

  3. #3
    Join Date
    May 2018
    Location
    France
    Posts
    1

    Re: ghdl in Fedora 28

    Quote Originally Posted by Dinesh Sharma
    Perhaps ghdl is not used by a lot of readers of this forum -- so there was no response.
    However, since I have found a work around for the problem, I shall post it here.

    The gnat library provided with ghdl on Fedora 28 is version 8. From the error message it is clear that it is looking for version 7.
    I have used a dirty work around by placing a symbolic link to libgnat-8.so called libgnat-7.so in /usr/lib64. Now ghdl can elaborate and run designs.

    Hopfully when the ghdl binary is re-compiled, this bug will go away. Obviously this package was not well tested before being put in the distribution.
    Next project: To find out how to mark this topic as solved!
    Thanks for posting the solution, I was having the same problem

  4. #4
    Join Date
    Apr 2018
    Location
    Finland
    Posts
    97

    Re: ghdl in Fedora 28

    Quote Originally Posted by Dinesh Sharma
    Next project: To find out how to mark this topic as solved!
    Try thread tools. They are hidden to top right of the first post.

  5. #5
    Join Date
    Nov 2008
    Posts
    84

    Re: ghdl in Fedora 28

    Thanks keikari. The thread is now marked as solved.
    Dinesh

Similar Threads

  1. undefined reference" problem while compiling GHDL with GCC 4.6.3
    By Raguturtle in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 31st August 2012, 03:52 PM
  2. Problem Building GHDL on top of a newer GCC 4.6.3
    By Raguturtle in forum Using Fedora
    Replies: 0
    Last Post: 29th August 2012, 06:15 AM
  3. Replies: 0
    Last Post: 24th August 2012, 02:42 PM
  4. Crashes default GCC after GHDL installed on fedora 16
    By Raguturtle in forum Using Fedora
    Replies: 3
    Last Post: 7th August 2012, 04:11 PM
  5. Problem installing GHDL (GNAT, GCC)
    By Alerander in forum Using Fedora
    Replies: 0
    Last Post: 28th August 2005, 02:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •