F28: can't install kernel
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 12 of 12
  1. #1
    Join Date
    Jul 2014
    Location
    EU
    Posts
    257

    F28: can't install kernel

    Code:
    dnf update kernel kernel-modules-extra kernel-devel kernel-headers
    
    
     Problem 1: cannot install both kernel-4.16.5-300.fc28.x86_64 and kernel-4.16.5-300.fc28.x86_64
      - cannot install the best update candidate for package kernel-4.16.5-300.fc28.x86_64
      - cannot install the best update candidate for package kernel-4.16.4-200.fc27.x86_64
     Problem 2: cannot install both kernel-devel-4.16.5-300.fc28.x86_64 and kernel-devel-4.16.5-300.fc28.x86_64
      - cannot install the best update candidate for package kernel-devel-4.16.5-300.fc28.x86_64
      - cannot install the best update candidate for package kernel-devel-4.16.4-200.fc27.x86_64
     Problem 3: cannot install both kernel-modules-extra-4.16.5-300.fc28.x86_64 and kernel-modules-extra-4.16.5-300.fc28.x86_64
      - cannot install the best update candidate for package kernel-modules-extra-4.16.5-300.fc28.x86_64
      - cannot install the best update candidate for package kernel-modules-extra-4.16.4-200.fc27.x86_64

    Any idea please how to fix it ?

  2. #2
    Join Date
    May 2018
    Location
    Boston
    Posts
    2

    Re: F28: can't install kernel

    I also have this problem with the kernel package.
    Started after update from fedora 27 to fedora 28 through dnf system-upgrade.
    I always run dnf clean all before I update, so it's (probably) not a dnf cache thing.

    Message:
    Problem: cannot install both kernel-4.16.6-302.fc28.x86_64 and kernel-4.16.6-302.fc28.x86_64
    - cannot install the best update candidate for package kernel-4.16.6-302.fc28.x86_64
    - cannot install the best update candidate for package kernel-4.16.6-200.fc27.x86_64

  3. #3
    Join Date
    Apr 2018
    Location
    USA
    Posts
    21

    Re: F28: can't install kernel

    I don't know about upgrades, but my new F28 install by default will only let you keep 3 kernels. Look at /etc/dnf/dnf.conf Don't know if this would be your issue. But I am trying to delete old kernels as I only gave my boot partition 250MB and it is now 99% full.

  4. #4
    Join Date
    Sep 2009
    Posts
    2,184

    Re: F28: can't install kernel

    What do "uname -r" and "sudo dnf list installed kernel" show? My guess is you need to uninstall the fc27 kernels, but you must not be booted into one of them when you do it. You need to be careful to get the package name correct when you delete a kernel.

    Or, try using --best --allowerasing with the dnf command.

    dd_wizard

  5. #5
    Join Date
    May 2018
    Location
    Boston
    Posts
    2

    Re: F28: can't install kernel

    uname gives the kernel that is listed in the dnf error message.
    So it's already installed and loaded.
    And the dnf list command only gives fc28 kernels.
    Last edited by mfdgroote; 8th May 2018 at 04:59 PM.

  6. #6
    Join Date
    Jul 2014
    Location
    EU
    Posts
    257

    Re: F28: can't install kernel

    Quote Originally Posted by mfdgroote
    I also have this problem with the kernel package.
    Started after update from fedora 27 to fedora 28 through dnf system-upgrade.
    I always run dnf clean all before I update, so it's (probably) not a dnf cache thing.

    Message:
    Problem: cannot install both kernel-4.16.6-302.fc28.x86_64 and kernel-4.16.6-302.fc28.x86_64
    - cannot install the best update candidate for package kernel-4.16.6-302.fc28.x86_64
    - cannot install the best update candidate for package kernel-4.16.6-200.fc27.x86_64
    Thank you for info. I've upgraded from F27 to F28 using gnome-software.

  7. #7
    Join Date
    Jul 2014
    Location
    EU
    Posts
    257

    Re: F28: can't install kernel

    Quote Originally Posted by loonymike
    I don't know about upgrades, but my new F28 install by default will only let you keep 3 kernels. Look at /etc/dnf/dnf.conf Don't know if this would be your issue. But I am trying to delete old kernels as I only gave my boot partition 250MB and it is now 99% full.
    Code:
    installonly_limit=3

  8. #8
    Join Date
    Jul 2014
    Location
    EU
    Posts
    257

    Re: F28: can't install kernel

    Quote Originally Posted by dd_wizard
    What do "uname -r" and "sudo dnf list installed kernel" show? My guess is you need to uninstall the fc27 kernels, but you must not be booted into one of them when you do it. You need to be careful to get the package name correct when you delete a kernel.

    Or, try using --best --allowerasing with the dnf command.

    dd_wizard
    Code:
    $ uname -r
    4.16.5-300.fc28.x86_64
    Code:
    $ dnf list installed kernel
    Instaled packages 
    kernel.x86_64                                       4.16.4-200.fc27                                       @updates
    kernel.x86_64                                       4.16.5-200.fc27                                       @updates
    kernel.x86_64                                       4.16.5-300.fc28                                       @updates

  9. #9
    Join Date
    May 2018
    Location
    Finland
    Posts
    1

    Re: F28: can't install kernel

    Quote Originally Posted by boycottsystemd
    Code:
    installonly_limit=3
    Hi all,

    I also got the same issue. I tried to bypass it by tweaking "installonly_limit=5" which no luck.

  10. #10
    Join Date
    Mar 2015
    Location
    Perth Australia
    Posts
    4
    Linux (Fedora) Firefox 62.0

    Re: F28: can't install kernel

    Problem: cannot install both kernel-modules-extra
    I have been getting this problem since updating (via dnf) to Fedora 28.
    The error has been moving with the kernels as they get loaded.
    It is always the current version.
    There are no F27 kernels left.
    I hoped the problem would go away when that was the case or otherwise get fixed.
    This has not happened.
    It is on all my systems (4 different ones) but appears to cause no problems.

  11. #11
    Join Date
    Jul 2014
    Location
    EU
    Posts
    257
    Linux Pale Moon 28.1.0

    Re: F28: can't install kernel

    I did not encounter it on F27 (on another machine).

  12. #12
    Join Date
    Jul 2014
    Location
    EU
    Posts
    257
    Linux Pale Moon 28.1.0

    Re: F28: can't install kernel

    same problem on another machine after upgrade from F27 --> F28:

    Code:
     Problem 1: cannot install both kernel-4.18.11-200.fc28.x86_64 and kernel-4.18.11-200.fc28.x86_64
      - cannot install the best update candidate for package kernel-4.18.11-200.fc28.x86_64
      - cannot install the best update candidate for package kernel-4.18.7-100.fc27.x86_64
     Problem 2: cannot install both kernel-devel-4.18.11-200.fc28.x86_64 and kernel-devel-4.18.11-200.fc28.x86_64
      - cannot install the best update candidate for package kernel-devel-4.18.11-200.fc28.x86_64
      - cannot install the best update candidate for package kernel-devel-4.18.7-100.fc27.x86_64
     Problem 3: cannot install both kernel-modules-extra-4.18.11-200.fc28.x86_64 and kernel-modules-extra-4.18.11-200.fc28.x86_64
      - cannot install the best update candidate for package kernel-modules-extra-4.18.11-200.fc28.x86_64
      - cannot install the best update candidate for package kernel-modules-extra-4.18.7-100.fc27.x86_64

Similar Threads

  1. how to install kernel source tree of fedora 14's current kernel ?
    By kevlin in forum Installation, Upgrades and Live Media
    Replies: 13
    Last Post: 3rd July 2013, 02:12 PM
  2. Replies: 5
    Last Post: 13th June 2011, 01:38 PM
  3. Replies: 4
    Last Post: 29th April 2009, 03:16 AM
  4. Unable to install a upgraded kernel from kernel.org under fedora installation
    By srinivasbakki in forum Installation, Upgrades and Live Media
    Replies: 6
    Last Post: 7th January 2008, 02:11 PM
  5. FC4 fresh install, no SMP kernel boot, UP kernel boots OK
    By tigerplish in forum EOL (End Of Life) Versions
    Replies: 4
    Last Post: 15th August 2005, 10:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •