Error: system is not ready for upgrade [upgrading from 27 to 28]
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 9 of 9
  1. #1
    Join Date
    Jul 2013
    Location
    Athens, GREECE
    Posts
    19

    Error: system is not ready for upgrade [upgrading from 27 to 28]

    I used the command line to upgrade,
    but after downloading the 1969 packages,
    it says:

    Didn't install any keys
    Public key for libupnp-1.6.21-3.fc27.x86_64.rpm is not installed. Failing package is: libupnp-1.6.21-3.fc27.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for perl-interpreter-5.26.1-409.fc28.x86_64.rpm is not installed. Failing package is: perl-interpreter-4:5.26.1-409.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for perl-libs-5.26.1-409.fc28.x86_64.rpm is not installed. Failing package is: perl-libs-4:5.26.1-409.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for perl-macros-5.26.1-409.fc28.x86_64.rpm is not installed. Failing package is: perl-macros-4:5.26.1-409.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    The downloaded packages were saved in cache until the next successful transaction.
    You can remove cached packages by executing 'dnf clean packages'.
    Error: GPG check FAILED


    What can I do to solve this problem and be able to upgrade?????
    fedora 23 xfce

  2. #2
    Join Date
    Oct 2010
    Posts
    1

    Re: Error: system is not ready for upgrade [upgrading from 27 to 28]

    I am facing same issue. Console log below-

    warning: /var/lib/dnf/system-upgrade/fedora-f21308f6293b3270/packages/librados2-12.2.4-1.fc28.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 9db62fb1: NOKEY
    Importing GPG key 0x9DB62FB1:
    Userid : "Fedora 28 (28) <fedora-28@fedoraproject.org>"
    Fingerprint: 128C F232 A937 1991 C8A6 5695 E08E 7E62 9DB6 2FB1
    From : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Is this ok [y/N]: Importing GPG key 0x9DB62FB1:
    Userid : "Fedora 28 (28) <fedora-28@fedoraproject.org>"
    Fingerprint: 128C F232 A937 1991 C8A6 5695 E08E 7E62 9DB6 2FB1
    From : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Is this ok [y/N]: y
    Key imported successfully
    warning: /var/lib/dnf/system-upgrade/rpmfusion-free-updates-18aab6236926d6fd/packages/compat-ffmpeg28-2.8.14-1.fc28.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 09eab3f2: NOKEY
    Importing GPG key 0x09EAB3F2:
    Userid : "RPM Fusion free repository for Fedora (28) <rpmfusion-buildsys@lists.rpmfusion.org>"
    Fingerprint: 3424 9D2C B375 8B55 48E2 874F C08D 3269 09EA B3F2
    From : /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-28
    Is this ok [y/N]: y
    Key imported successfully
    warning: /var/lib/dnf/system-upgrade/rpmfusion-nonfree-fcea624146a658fc/packages/rpmfusion-nonfree-appstream-data-28-2.fc28.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 7f858107: NOKEY
    Importing GPG key 0x7F858107:
    Userid : "RPM Fusion nonfree repository for Fedora (28) <rpmfusion-buildsys@lists.rpmfusion.org>"
    Fingerprint: 3DE8 C682 E38E E9BC 0FDF EA47 FCAE 2EA8 7F85 8107
    From : /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-28
    Is this ok [y/N]: y
    Key imported successfully
    Didn't install any keys
    Public key for librbd1-12.2.4-1.fc28.x86_64.rpm is not installed. Failing package is: librbd1-1:12.2.4-1.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for libupnp-1.6.21-3.fc27.x86_64.rpm is not installed. Failing package is: libupnp-1.6.21-3.fc27.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for perl-devel-5.26.1-409.fc28.x86_64.rpm is not installed. Failing package is: perl-devel-4:5.26.1-409.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for perl-interpreter-5.26.1-409.fc28.x86_64.rpm is not installed. Failing package is: perl-interpreter-4:5.26.1-409.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for perl-libs-5.26.1-409.fc28.x86_64.rpm is not installed. Failing package is: perl-libs-4:5.26.1-409.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for perl-macros-5.26.1-409.fc28.x86_64.rpm is not installed. Failing package is: perl-macros-4:5.26.1-409.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for vim-X11-8.0.1704-1.fc28.x86_64.rpm is not installed. Failing package is: vim-X11-2:8.0.1704-1.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    Public key for vim-common-8.0.1704-1.fc28.x86_64.rpm is not installed. Failing package is: vim-common-2:8.0.1704-1.fc28.x86_64
    GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-28-x86_64
    The downloaded packages were saved in cache until the next successful transaction.
    You can remove cached packages by executing 'dnf clean packages'.
    Error: GPG check FAILED

  3. #3
    Join Date
    Jul 2013
    Location
    Athens, GREECE
    Posts
    19

    Re: Error: system is not ready for upgrade [upgrading from 27 to 28]

    Anybody who can help us with this problem???
    fedora 23 xfce

  4. #4
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,398

    Re: Error: system is not ready for upgrade [upgrading from 27 to 28]

    from the upgrade instructions page -
    Does DNF system upgrade verify the software it runs or installs during upgrade?

    Yes. The package signing keys for newer Fedora releases are sent to older Fedora releases in order to allow DNF to verify the integrity of the packages it downloads. You can disable this function with the --nogpgcheck parameter if you need to do so for any reason (not recommended, you're then opened to attacks from malicious software
    https://fedoraproject.org/wiki/DNF_s...ing_upgrade.3F

  5. #5
    Join Date
    Jul 2013
    Location
    Athens, GREECE
    Posts
    19

    Re: Error: system is not ready for upgrade [upgrading from 27 to 28]

    Dear Antikythera,
    your response was NOT helpful at all.
    My question is:
    what can I do to upgrade the system????
    fedora 23 xfce

  6. #6
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,398

    Re: Error: system is not ready for upgrade [upgrading from 27 to 28]

    Quote Originally Posted by ninos
    Dear Antikythera,
    your response was NOT helpful at all.
    My question is:
    what can I do to upgrade the system????
    my response IS is the answer to the GPG issue

  7. #7
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,786

    Re: Error: system is not ready for upgrade [upgrading from 27 to 28]

    Plus 1 for antikythera's given solution. But, to avert such a condition in the first place, prior to doing a "dnf system-upgrade.....", I always import the gpg keys relevant to the release I am upgrading to prior to doing the upgrade. Be sure your current running version is fully upgraded, especially the "fedora-release" rpm package, as it will contain the gpg keys for the next one or two releases as well as the current one.
    Code:
    cd /etc/pki/rpm-gpg
    ls | grep primary
    Then, as root, use rpm to import all the keys listed for the release you will be upgrading to.
    Code:
    # rpm --import RPM-GPG-KEY-fedora-27-primary

  8. #8
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,372

    Re: Error: system is not ready for upgrade [upgrading from 27 to 28]

    @PabloTwo

    Didn't you mean:
    "Then, as root, use rpm to import all the keys listed for the release you will be upgrading from"
    He's going from 27 to 28

  9. #9
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,786

    Re: Error: system is not ready for upgrade [upgrading from 27 to 28]

    No, I meant what I said (typed). In that case, he would be importing the release 28 keys, not the release 27 keys.
    Code:
    $ uname -r
    4.16.7-200.fc27.x86_64
    
    $ ls /etc/pki/rpm-gpg/ | grep 28-primary
    RPM-GPG-KEY-fedora-28-primary
    RPM-GPG-KEY-rpmfusion-free-fedora-28-primary
    RPM-GPG-KEY-rpmfusion-nonfree-fedora-28-primary
    The current running release gpg keys are already imported.

Similar Threads

  1. F26 Kde goes "system is not ready for upgrade"
    By giampaolo44 in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 22nd October 2017, 10:08 PM
  2. [SOLVED]
    Issues with System not ready for Upgrade
    By Firewolf in forum Installation, Upgrades and Live Media
    Replies: 13
    Last Post: 8th May 2016, 12:20 AM
  3. fedora-upgrade F17 to F18, error msg: Upgrading from version 1718 is not supported
    By mario960 in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 28th December 2013, 05:33 PM
  4. System Ready sound in F14
    By Palooka in forum Using Fedora
    Replies: 0
    Last Post: 7th February 2011, 04:23 PM
  5. OK, I'm finaly ready to upgrade to FC5!
    By fromans4 in forum EOL (End Of Life) Versions
    Replies: 3
    Last Post: 9th September 2006, 03:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •