I am posting this in case someone else finds it useful.

Hardware... Geforce 8400 GS.

For several months I have been having problems with compiz leaving all sorts of ugly artifacts all over my screen.

This seems to have started up when the 4.15 kernels came out.

I have tried all of the howto options on the compiz page.

I have even gone back and forth between noveau and nvidia proprietary.

Today I hit on a combination that seems to have fixed it.

I have nvidia proprietary installed. (340.106)

Instead of turning ON triple buffering in xorg.conf, I SPECIFICALLY turned it OFF. (Option "TripleBuffer" "false")

I then used nvidia X server settings control panel and turned OFF both "Sync to VBlank" and "Allow Flipping".

With this combination, all compiz artifacts magically disappeared.

FWIW, just in case someone else is having artifact problems with mate-compiz spin.