[SOLVED] KDE Multimedia doesn't use the preferred sound device
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2017
    Location
    Brazil
    Posts
    4

    KDE Multimedia doesn't use the preferred sound device

    Hi, I use Fedora 27 64 bits, kde spin, updates installed.
    I have an USB headset plugged all the time to my laptop and have set it as the preferred audio output and input. However every time I launch a browser (firefox or chrome) and play some audio or enter a video conference chat, kde always uses the internal output/input, then I need to manually open the device setting, go to "Applications" tab and set the output/input device for each application, that is very annoying.

    As the USB device is set as "default" all application should use it instead of the internal one, right ? See attached screenshots, they are in portuguese. In the "Advanced" tab I set the option to automatically switch all running streams, see screenshot.

    For example, the image "applications.png" shows the music player clementine uses the internal audio, then I need to click the dropdown and choose the usb device.

    pacmd correctly shows the usb headset as default

    $ pacmd dump |grep default
    load-module module-default-device-restore
    set-default-sink alsa_output.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-stereo
    set-default-source alsa_input.usb-C-Media_Electronics_Inc._USB_Audio_Device-00.analog-mono


    Thanks for taking a time to read this.

    Claudio
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	devices.png 
Views:	31 
Size:	39.6 KB 
ID:	29536   Click image for larger version. 

Name:	advanced.png 
Views:	27 
Size:	39.9 KB 
ID:	29537   Click image for larger version. 

Name:	applications.png 
Views:	27 
Size:	43.4 KB 
ID:	29538  
    Last edited by claudiomir; 16th April 2018 at 04:19 AM.

  2. #2
    Join Date
    Mar 2017
    Location
    Brazil
    Posts
    4

    Re: KDE Multimedia doesn't use the preferred sound device

    This article has useful information, where I need to call pacmd unload-module module-device-manager, then all applications uses the default device.

Similar Threads

  1. show fedora pc on multimedia device
    By Kwiksand in forum Servers & Networking
    Replies: 1
    Last Post: 16th October 2011, 01:43 PM
  2. Replies: 1
    Last Post: 23rd October 2009, 04:36 AM
  3. Setting preferred browser in gnome doesn't work. Fedora 9
    By kurtdriver in forum Using Fedora
    Replies: 12
    Last Post: 14th November 2008, 05:06 PM
  4. Multimedia keys doesn't work with multiseat
    By vojta in forum Hardware & Laptops
    Replies: 0
    Last Post: 26th February 2007, 10:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •