FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    May 2010
    Posts
    192

    Wireshark: My Fedora 27 Phones Home Automatically

    I've been tinkering with Wireshark and I've noticed that my F27 desktop installation appears to be phoning home automatically.

    I'm seeing IP traffic between my F27 workstation and an IP address that resolves to fedoraproject.org. The traffic is originating on Port 80 at my and and is going to Port 51117 at the other end. Can anyone tell me where the traffic is coming from?

    Click image for larger version. 

Name:	wireshark.jpg 
Views:	11 
Size:	56.6 KB 
ID:	29535

  2. #2
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,300

    Re: Wireshark: My Fedora 27 Phones Home Automatically

    Quote Originally Posted by bob p
    I've been tinkering with Wireshark and I've noticed that my F27 desktop installation appears to be phoning home automatically.

    I'm seeing IP traffic between my F27 workstation and an IP address that resolves to fedoraproject.org. The traffic is originating on Port 80 at my and and is going to Port 51117 at the other end. Can anyone tell me where the traffic is coming from?

    Click image for larger version. 

Name:	wireshark.jpg 
Views:	11 
Size:	56.6 KB 
ID:	29535

    probably "dnf-makecache" unit via the systemd, try looking in the repo files in /etc/yum.repos.d/*, the baseurl and mirrorlist IPs should be:

    download.fedoraproject.org
    codecs.fedoraproject.org
    mirrors.fedoraproject.org
    but you might have other non-standard ones

    The most likely thing is that it's using the default "mirrors.fedoraproject.org" IP, then getting a list of repos from that then using the one that for you is the fastest. So the actual IP you see in the wireshark is obscured a bit, you'll see the mirrors one first, then it will right away go to the actual IP it uses for the dnf cache update.

    You could just turn off dnf caching and see if the wireshark events go away:
    I think step "1" below is enough because of what the DNF page here says:
    https://dnf.readthedocs.io/en/latest...zation-service
    1) set "metadata_timer_sync=0" in /etc/dnf/dnf.conf

    But I tend to set that and 2):
    2) turn off the timer:
    "systemctl disable dnf-makecache.timer"
    "systemctl stop dnf-makecache.timer"

    Then when I do a manual "dnf check-update" I just force the latest dnf metadata with --refresh :
    "dnf check-update --refresh"

    In my book, this is more efficient than the Fedora default (3 hours), I only do a check after a day or two, the timer is doing that every three hours which seems overkill
    Last edited by marko; 15th April 2018 at 11:50 PM.

Similar Threads

  1. Replies: 1
    Last Post: 24th February 2016, 08:28 PM
  2. Replies: 5
    Last Post: 16th February 2015, 02:52 PM
  3. Wireshark crashing - Fedora 9/iwl 3945 driver
    By El_BrandO in forum Using Fedora
    Replies: 2
    Last Post: 10th July 2008, 06:15 PM
  4. /home unmounts automatically!
    By vasim98 in forum Using Fedora
    Replies: 3
    Last Post: 27th September 2006, 11:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •