FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Aug 2011
    Posts
    39

    Question Kernel 4.15.6+ Hans Early on Radeon 470/480/570/580 AMDGPU

    Does anyone else see this?

    I haven't been able to boot of any kernels since 4.15.3. I've had to remove all kernel updates for the past 4 weeks.

    Boot hangs after screen message: "switching to amdgpudrmfb from EFI vga". It doesn't even reach root fs, so, I'm not even sure how I could get more detailed logs. I'd be interested in how to do that, too, if anyone knows.

  2. #2
    Join Date
    Aug 2011
    Location
    ~
    Posts
    1,936

    Re: Kernel 4.15.6+ Hans Early on Radeon 470/480/570/580 AMDGPU

    Works for me.

    glxinfo -B | grep Device
    Device: AMD Radeon (TM) RX 480 Graphics (POLARIS10 / DRM 3.23.0 / 4.15.13-300.fc27.x86_64, LLVM 5.0.1) (0x67df)

    Sounds like you have a firmware issue.

  3. #3
    Join Date
    Feb 2009
    Location
    Florida
    Posts
    632

    Re: Kernel 4.15.6+ Hans Early on Radeon 470/480/570/580 AMDGPU

    What platform are you running?
    I was on an AMD 1100T CPU and Radeon GPU and having lockup issues at a similar point in the boot process in the 4.14.18 and onward kernels.
    I made several changes and corrected the issue.
    It's difficult to say exactly which change actually corrected my issue, but I believe disabling the AMD IOMMU in BIOS and accepting the default use of SWIOTLB is a leading candidate.

    YMMV
    Laptop: Toshiba / Intel B960 2.20Ghz x2/ 4GB/ 320GB SataII/ Intel HD/ fc28.x86_64
    Tower: GigaByte (970A) / AMD FX 8320 3.5Ghz x8/ 16GB/ 9TB Sata III/ AMD 6770HD/ fc28.x86_64
    Bookshelf: Shuttle DS61 (H61)/ i3-3225 3.3Ghz x2/ 16GB/ 320GB Sata II/ Intel HD 4000/ fc27.x86_64
    Embedded: BeagleBone Blk / ARM AM3358 1 GHz x1/ 512MB/ 2GB eMMC/ PowerVR SGX530/ fc27.armv7hl

  4. #4
    Join Date
    Aug 2011
    Posts
    39

    Re: Kernel 4.15.6+ Hans Early on Radeon 470/480/570/580 AMDGPU

    You can boot 4.15.13!? What the heck!?

    I have Ryzen 1800X on X370 mainboard.

    What do you mean by firmware? on my RX 480?

  5. #5
    Join Date
    Aug 2011
    Posts
    39

    Smile Re: Kernel 4.15.6+ Hans Early on Radeon 470/480/570/580 AMDGPU

    Okay, so turns out something got broken, best I can tell, with dracut. I'm trying to track it down with my bug. When I installed 4.15.6, dracut got broken. What I don't understand is why subsequent updates didn't fix it. Something has persisted on my system where dracut isn't building the right initramfs images. I fixed it, manually, but I don't know how it's supposed to work. initramfs was missing all the AMD GPU firmware.

    Does anyone know how dracut is *supposed* to know to add AMD firmware files to the images it makes? Looks to me like the mechanism changed and it's not working. But, maybe it's an old problem that just broke on 4.15.16.

    More generally, how does it know to add any firmware files. There are many and I don't think they are all in my initramfs....yeah, it's only amdgpu, which I manually added, and radeon firmware, which I didn't tell it to add. Oh, and the current kernel driver firmware.

  6. #6
    Join Date
    May 2006
    Location
    Porto, Portugal
    Age
    48
    Posts
    70

    Re: Kernel 4.15.6+ Hans Early on Radeon 470/480/570/580 AMDGPU

    Looks like I'm having a similar problem, but with the 4.16 series of kernels. I'm running and AMD FX 6300 with a AMD HD 5850, and most 4.16 series kernels will boot into a black screen unless I add the options "nomodeset" and "iommu=soft" into the boot options.I'm using the open source radeon driver.
    From my web searches, it looks like kernel 4.16 developers dropped the swiotlb symbols, and that's breaking graphics drivers everywhere. Here: https://github.com/torvalds/linux/co...07d420b0213bec

  7. #7
    Join Date
    Aug 2011
    Posts
    39

    Re: Kernel 4.15.6+ Hans Early on Radeon 470/480/570/580 AMDGPU

    Interesting, but that is not this problem.

    I think that is what Kobuck was talking about. Are you sure AMDGPU is still being use with 'nomodeset'? It may bypass it. Anyway, I'm using Polaris 10 and you are R9? I can't remember. I'm not surprised they have different problems.

    I see the patch you liked. I thought you were saying SWIOTLB was removed, globally, but that cannot be right; it looks really important. The patch says it is supposed to only affect some architectures and it wasn't all exports, from what I gather. I hear that it is to blame for video problems, too, but I don't understand how.

    Did you check your initramfs image? Just make sure your firmware is there. Hmm, what firmware is used for 5850? (I had 2 7870s for a while :-) .) If you have firmware files under amdgpu/ then your issue is completely different. If you are missing them, I can tell you how to fix it.

    At least you got your system booted; that's better than I was able to do for a long time.

Similar Threads

  1. Beware: Latest kernel breaks amdgpu-17.50
    By tkalfaoglu in forum Hardware & Laptops
    Replies: 6
    Last Post: 30th March 2018, 09:21 PM
  2. [SOLVED]
    Does Linux Kernel 4.11 will enable support for amdgpu/radeon ?
    By User808 in forum Hardware & Laptops
    Replies: 5
    Last Post: 7th November 2017, 08:59 AM
  3. Early interrupts bug in Kernel
    By MegaZoide in forum Using Fedora
    Replies: 0
    Last Post: 27th December 2006, 04:16 PM
  4. Hans Reiser's wife missing?
    By marko in forum Linux Chat
    Replies: 0
    Last Post: 24th September 2006, 05:56 AM
  5. Kernel panic early in install
    By RogerThat in forum Installation, Upgrades and Live Media
    Replies: 6
    Last Post: 30th September 2005, 11:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •