Firefox 59 and youtube CPU usage
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2004
    Location
    Australia
    Posts
    277

    Question Firefox 59 and youtube CPU usage

    Does anyone have a problem with Firefox using large CPU when watching youtube?

    I saw in a review of Firefox Quantum on youtube by quidsup, when he watched a 4K youtube video, Firefox only used 2% CPU. But when I watch a normal 1080p60 video, my CPU usage is much much higher (Web Content goes to 110% and Firefox goes to 20%). I've tried h264ify to force youtube to play H264 and its still the same problem. I have a GTX1050Ti and Ryzen 5 1600, so surely it can't be that bad.

    Is there some special setup that I am not aware of? Hardware-decoding setting somewhere?
    QuantumKnot - originator of the "Verne" release name (possibly the last 'normal' release name) :)

  2. #2
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,352

    Re: Firefox 59 and youtube CPU usage

    Quote Originally Posted by QuantumKnot
    Does anyone have a problem with Firefox using large CPU when watching youtube?

    I saw in a review of Firefox Quantum on youtube by quidsup, when he watched a 4K youtube video, Firefox only used 2% CPU. But when I watch a normal 1080p60 video, my CPU usage is much much higher (Web Content goes to 110% and Firefox goes to 20%). I've tried h264ify to force youtube to play H264 and its still the same problem. I have a GTX1050Ti and Ryzen 5 1600, so surely it can't be that bad.

    Is there some special setup that I am not aware of? Hardware-decoding setting somewhere?
    Maybe you are using nouveau and the person with low cpu used the closed nvidia driver

  3. #3
    Join Date
    Nov 2004
    Location
    Australia
    Posts
    277

    Re: Firefox 59 and youtube CPU usage

    Unfortunately I'm using the closed nvidia driver as well.
    QuantumKnot - originator of the "Verne" release name (possibly the last 'normal' release name) :)

  4. #4
    Join Date
    Oct 2013
    Location
    /home
    Posts
    17

    Re: Firefox 59 and youtube CPU usage

    I have the same problem but with Facebook. I just open Facebook then Web Content's cpu usage is suddenly high and laptop fan goes crazy. I'm using closed nvidia driver.

Similar Threads

  1. Youtube not working in Firefox
    By safulop in forum Using Fedora
    Replies: 7
    Last Post: 1st February 2018, 03:12 AM
  2. F21 + Firefox 30.0 - youtube not loading
    By sea in forum F21 Development Forum
    Replies: 6
    Last Post: 12th June 2014, 06:38 PM
  3. YouTube ads in Firefox
    By tech291083 in forum Using Fedora
    Replies: 4
    Last Post: 22nd January 2013, 04:36 AM
  4. YouTube not working on Firefox 3.5.2
    By ba55ist in forum Using Fedora
    Replies: 14
    Last Post: 8th November 2009, 10:44 PM
  5. Firefox and Youtube
    By teox78 in forum Alpha - Beta (Fedora 9 Only)
    Replies: 11
    Last Post: 14th May 2008, 10:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •