FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2018
    Location
    .
    Posts
    12

    USB not mounting

    newbie speaking.


    My USB is working fine on windows but stopped working on Fedora after Formatting. Actually at first i formatted it to NTFS (using a windows laptop). After a while i realized that it stopped working on Fedora. Then i came to know that it should be FAT32 to work with linux. Now even when i have formatted it to FAT32 (through a windows laptop), it still doesn't show up automatically.

    Every one else's USB is working fine on my Fedora but just not this one.
    have a look at the following too and please guide me.


    [root@localhost sanaankhan]# fdisk -l
    Device Boot Start End Sectors Size Id Type
    /dev/sdb1 2048 15240575 15238528 7.3G b W95 FAT32



    and this is what happens when i try to mount it manually

    [root@localhost sanaankhan]# mount /dev/sdb1 /mnt
    mount: /mnt: special device /dev/sdb1 does not exist.
    [root@localhost sanaankhan]# mount -t auto /dev/sdb1 /mnt
    mount: /mnt: special device /dev/sdb1 does not exist.


    .

  2. #2
    GallComp's Avatar
    GallComp is online now Nuke 'em Alfred! Administrator - Starring in Bill & Steve's Bogus Journey
    Join Date
    Mar 2004
    Location
    Fontana, CA
    Age
    42
    Posts
    2,496

    Re: USB not mounting

    Wrong section. Moving to "using Fedora".

    "Since when has the world of computer software design been about what people want? This is a simple question of evolution. The day is quickly coming when every knee will bow down to a silicon fist, and you will all beg your binary gods for mercy. "


    BILL GATES...

  3. #3
    Join Date
    Mar 2018
    Location
    .
    Posts
    12

    Re: USB not mounting

    .

    The format was FAT32.
    Format was not the problem.
    i installed gParted and it actually said that no PartitionTable existed on that usb.
    i decided to try formatting it through gParted.
    i moved data from my usb to a windows LapTop (because it was working fine with windows).
    As i had already formatted it (into FAT32) using a windows, but it didn't turn out useful with Fedora,
    so i attached the usb back to Fedora and i formatted it using gParted and it solved the problem.
    usb is again in FAT32 but now it's working with Fedora too.
    .

Similar Threads

  1. Mounting
    By Mr.Clean in forum Using Fedora
    Replies: 3
    Last Post: 17th March 2008, 11:09 PM
  2. NFS mounting issues, telent works, mounting doesn't
    By lionelfarr in forum Using Fedora
    Replies: 6
    Last Post: 24th August 2006, 11:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •