FedoraForum.org - Fedora Support Forums and Community
Page 2 of 2 FirstFirst 1 2
Results 16 to 18 of 18
  1. #16
    Join Date
    Feb 2009

    Re: Setting permissions for folder access

    My fstab entry for a NFS volume looks like:

    nassrvr:/nas/nas01 /home/<userid>/Nas/nas01 nfs4 _netdev,noatime,auto 0 0
    This approach requires that you have defined a "Nas/nas01" in your users /home directory
    The "nfs4" filetype helps mount the volume correctly
    The "_netdev" allows the client boot to proceed even if the nfs server volume is not available ( should help your boot finish even if you still have errors)
    The "noatime" reduces network/nfs server load at the expense of no "last access time" info maintained on server files

    P.S. If your NFS server has selinux "enforceing" you need enable nfs r/w as follows:
    # setsebool nfs_export_all_rw on
    Last edited by Kobuck; 16th April 2018 at 01:04 PM.
    Laptop: Toshiba / Intel B960 2.20Ghz x2/ 4GB/ 320GB SataII/ Intel HD/ fc28.x86_64
    Tower: GigaByte (970A) / AMD FX 8320 3.5Ghz x8/ 16GB/ 9TB Sata III/ AMD 6770HD/ fc28.x86_64
    Bookshelf: Shuttle DS61 (H61)/ i3-3225 3.3Ghz x2/ 16GB/ 320GB Sata II/ Intel HD 4000/ fc27.x86_64
    Embedded: BeagleBone Blk / ARM AM3358 1 GHz x1/ 512MB/ 2GB eMMC/ PowerVR SGX530/ fc27.armv7hl

  2. #17
    Join Date
    Jun 2005
    Montreal, Que, Canada

    Re: Setting permissions for folder access

    If you create a new mount point, have you created a place holder within the subdirectory to which the mount is going to be applied?

    For example. I have a temporary partition that I called backup
    In order to mount that partition as /backup I first must create a /backup within /
    Until I mount it, that /backup is just a place-holder.

    This is what I typically do to setup for /backup

    1) As root, I created a /backup (mkdir /backup)
    2) As root I made it not accessable using chmod 000 /backup Thus /backup is not rwx accessable until the mount is done.
    3) As root I created a new fstab entry (like this... UUID=5f26bcf1-354b-4e3e-a431-3040474005d2 /backup ext4 defaults,noauto,user 1 2 )

    If you want to know the UUID value, an easy way is with the blkid program.
    As root run blkid /dev/sd* and look for the partition in question. Here is the line of information from the blkid program that I used to create the fstab entry.
    dev/sda1: LABEL="backup" UUID="5f26bcf1-354b-4e3e-a431-3040474005d2" TYPE="ext4" PARTUUID="d2359c49-bf0b-4eb2-9c5e-eb6cbcb778a8"

    When you are ready to use the mounted drive, as a normal user, from the command line, I run

    mount /backup

    or umount /backup

    If using gnome, you could make a " backup.desktop" file with the appropriate entry to do the mount or unmount. That entry would go into ~/.local/share/applications If you have multiple users on the system, that "backup.desktop" would go into /usr/share/applications
    Last edited by lsatenstein; 16th April 2018 at 01:49 PM. Reason: Format error
    Leslie in Montreal

    Interesting web sites list

  3. #18
    Join Date
    Feb 2013

    Re: Setting permissions for folder access

    This seems to be working fine now, thanks all.

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. [SOLVED]
    Samba: Access Denied / Folder Permissions
    By Gradientpixel in forum Servers & Networking
    Replies: 3
    Last Post: 16th October 2012, 03:41 AM
  2. Replies: 8
    Last Post: 12th November 2010, 01:08 AM
  3. Replies: 4
    Last Post: 17th February 2009, 01:07 AM
  4. Replies: 9
    Last Post: 28th January 2009, 05:38 AM
  5. Cannot Access Folder/User Permissions
    By urimind in forum Using Fedora
    Replies: 8
    Last Post: 17th September 2008, 04:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts