[SOLVED] Cannot Mount Windows 10 Partition
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2018
    Vancouver Island

    Cannot Mount Windows 10 Partition

    Hey Guys,

    Thanks for having me!

    I'm taking my first crack at Fedora. So far I'm enjoying myself. I had some challenges getting it installed. I have 3 hard drives, 2 of which I wanted to retain for Windows. For whatever reason, Fedora didn't like the other 2 hard disks. I unplugged the hardware and installed Fedora 27 with ease, then shut 'er down and re-connected the other drives. Things boot fine both in Windows and Fedora. We're set!

    However, I can't mount my windows 10 drives while in fedora. I made darned sure to disable Window's 10 fast boot/hibernate mode.. Gnome just does nothing when I try to mount from disks.

    When I run a sudo mount /dev/sda2 /mnt I get this message:

    ntfs-3g-mount: mount failed: Device or resource busy

    So I do lsblk. I see this:

    sda               8:0    0 223.6G  0 disk   
    ├─sda1            8:1    0   500M  0 part   
    ├─sda2            8:2    0 223.1G  0 part   
    └─pdc_hcffai    253:2    0 222.6G  0 dmraid 
      └─pdc_hcffai1 253:3    0   500M  0 part   
    sdb               8:16   0 232.9G  0 disk   
    ├─sdb1            8:17   0     1G  0 part   /boot
    └─sdb2            8:18   0 231.9G  0 part   
      ├─fedora-root 253:0    0    50G  0 lvm    /
      ├─fedora-swap 253:1    0   7.9G  0 lvm    [SWAP]
      └─fedora-home 253:6    0   174G  0 lvm    /home
    sdc               8:32   0 232.9G  0 disk   
    ├─sdc1            8:33   0   450M  0 part   
    ├─sdc2            8:34   0   100M  0 part   
    ├─sdc3            8:35   0    16M  0 part   
    ├─sdc4            8:36   0 231.4G  0 part   
    └─pdc_hjbaef    253:4    0 231.9G  0 dmraid 
      ├─pdc_hjbaef1 253:5    0   450M  0 part   
      ├─pdc_hjbaef2 253:7    0   100M  0 part   
      ├─pdc_hjbaef3 253:8    0    16M  0 part   
      └─pdc_hjbaef4 253:9    0 231.4G  0 part
    Oook...things are in raid mode for some stupid Windows reason. I'm thinking my fstab might be messed up as Fedora never installed while being able to see these drives. Not sure how to fix it. Honestly, I'd rather Windows didn't do stupid stuff like this (whether it's causing my problem, or not). I can probably remove that raid config using dmraid, but I'm concerned about borking my Windows install. I wanna keep it just in case I really want to enjoy something that I just can't on Linux.

    Am I totally off base?

  2. #2
    Join Date
    Jul 2005

    Re: Cannot Mount Windows 10 Partition

    I think a dirty NTFS filesystem can prevent linux from mounting the partition. Best fix is to use chkdsk from within windows to verify/fix filesystem errors in NTFS.
    Doug G

  3. #3
    Join Date
    Mar 2018
    Vancouver Island

    Re: Cannot Mount Windows 10 Partition

    Solved by getting rid of windows. Sorry to anyone else having this problem and looking for an actual fix!

Similar Threads

  1. Replies: 9
    Last Post: 16th August 2012, 12:08 AM
  2. Cant mount windows partition
    By bjb_nyj101 in forum Using Fedora
    Replies: 5
    Last Post: 10th July 2008, 02:40 AM
  3. Windows partition full - cant mount or run xp
    By metalrobe in forum Using Fedora
    Replies: 1
    Last Post: 20th April 2007, 02:38 PM
  4. Mount windows partition
    By WetWired in forum Using Fedora
    Replies: 1
    Last Post: 9th November 2006, 07:56 AM
  5. mount windows partition
    By hedning in forum Using Fedora
    Replies: 2
    Last Post: 17th October 2005, 10:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts