FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2007
    Posts
    396

    ASUS GL702ZC : Brightness buttons stopped working

    After kernel update and a few struggles with amdgpu-pro drivers that refuse to dkms-compile under the newer kernels, I lost the ability to turn down the brightness. It's always at max, and makes my eyes teary.

    I tried most options in the grub kernel parameters, like acpi_backlight=vendor , acpi_osi
    here is what I have:
    1) I have /sys/class/backlight/acpi_video0/ but its values appear to be dummy, as changing the brightness with
    echo something > sys/class/backlight/acpi_video0/brightness does nothing.

    2) I have GNOME display the brightness down and up HUD when I hit Fn-F5/Fn-F6. The bar moves but brightness stays the same.

    3) acpi_listen shows
    video/brightnessdown BRTDN 00000087 00000000 K
    video/switchmode VMOD 00000080 00000000
    video/brightnessup BRTUP 00000086 00000000 K
    video/switchmode VMOD 00000080 00000000
    when I hit the brightness buttons.

    4) xbacklight does nothing - no matter what values I give it.

    Any ideas what else to try? This is kernel 4.15.8-300.fc27.x86_64 btw..

    Because this is a Ryzen 7 / rx 580 laptop, I can't use the "intel backlight" solutions, I'm guessing..

    Many thanks,
    -turgut


    Any pointers
    Last edited by tkalfaoglu; 14th March 2018 at 06:07 AM.

  2. #2
    Join Date
    Oct 2007
    Posts
    396

    Re: ASUS GL702ZC : Brightness buttons stopped working


  3. #3
    Join Date
    Oct 2007
    Posts
    396

    Re: ASUS GL702ZC : Brightness buttons stopped working

    SOLVED: I did several things. 1) Went back to the kernel 4.13.9-300 (the newest kernel that's still compatible with amdgpu 17.50)
    2) Installed amdgpu,
    3) Set the /etc/default/grub command line to
    GRUB_CMDLINE_LINUX="rd.shell amdgpu.vm_fragment_size=9 "

    (Having amdgpu.exp_hw_support on that line prevents the brightness from working)

Similar Threads

  1. ASUS GL702ZC and Fan Control
    By tkalfaoglu in forum Hardware & Laptops
    Replies: 1
    Last Post: 14th June 2018, 07:52 AM
  2. Thinkpad Edge Volume and Brightness buttons not working.
    By trelaan in forum Hardware & Laptops
    Replies: 1
    Last Post: 30th September 2012, 09:09 PM
  3. [SOLVED]
    Brightness control stopped working
    By PavedWave in forum Using Fedora
    Replies: 0
    Last Post: 16th November 2011, 11:44 PM
  4. [SOLVED]
    ASUS USB-N13 adapter stopped working after upgrade
    By Ahk1N2 in forum Servers & Networking
    Replies: 10
    Last Post: 13th April 2011, 09:42 PM
  5. ps/2 keyboard grey buttons stopped working
    By vsem in forum Hardware & Laptops
    Replies: 5
    Last Post: 22nd December 2008, 02:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •