Fedora 27 - Impossible to use Brother scanner
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2018

    Fedora 27 - Impossible to use Brother scanner

    Hello everyone,

    The device is a Brother DCP-L2560DW, printing works fine. I would like to use the scanner with a USB connection and not through the network.

    I have tried to fix the issue by reinstalling the drivers and changing the permissions as I saw in various posts online but it did not work.

    Here is the output of scanimage -L:
    scanimage -L
    device `v4l:/dev/video0' is a Noname USB2.0 HD UVC WebCam: USB2.0 HD virtual device
    Here is the ouput of sudo sane-find-scanner:

    found USB scanner (vendor=0x0bda [Generic], product=0x0139 [USB2.0-CRW]) at libusb:001:003
    found USB scanner (vendor=0x04f9 [Brother], product=0x0329 [DCP-L2560DW]) at libusb:003:010
    Xsane or Simple scan only detect the webcam of my computer.

    I am not an advanced user so I am not sure what other information would be needed to help me solve the problem, please tell me what more is needed.

    Thanks in advance

  2. #2
    Join Date
    Jan 2013
    Ventura, CA

    Re: Fedora 27 - Impossible to use Brother scanner

    Install xsane if you don't have it installed already (# dnf install xsane). Then go to this Brother website: http://support.brother.com/g/b/downl...50dw_us&os=127
    Scroll down to where it says "scanner drivers". Click on the second entry (. . .64 bit rpm) or the first entry (. . 32bit rpm) if you have an older 32 bit system.
    Agree to Brother's regulations. Click on "Save File" radio button. Then install the driver: "# dnf install /home/user-name (this is your name)/Downloads/brscan4-0.4.4-4.x86_64.rpm (or brscan4-0.4.4-4.i386.rpm if this is what you downloaded) "

    I cannot guarantee that this driver will work (it is the closest driver to what you have listed that the Brother website has). Restart your machine and then start up "xsane" ($ xsane) while your printer/scanner is on. If this driver does not work, remove it (# dnf remove brscan4). You can google your exact model to see if you can find that driver.

Similar Threads

  1. [SOLVED]
    F21: Brother printer/scanner: No scanner detected
    By MrNice in forum Hardware & Laptops
    Replies: 9
    Last Post: 17th September 2017, 08:39 PM
  2. Brother Scanner not detected by Fedora 14
    By PittsS1E in forum Hardware & Laptops
    Replies: 20
    Last Post: 4th March 2012, 11:20 PM
  3. Brother driver for Brother DCP385C scanner
    By Spats in forum Using Fedora
    Replies: 1
    Last Post: 23rd May 2011, 10:14 AM
  4. Brother Scanner wont work in Fedora 13
    By PittsS1E in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 3rd August 2010, 12:17 PM
  5. Replies: 3
    Last Post: 20th May 2008, 12:38 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts