[SOLVED] How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Sep 2013
    Location
    Europe/Berlin
    Posts
    34

    How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?

    Hello,

    Whenever I boot into graphical.target I get pestered by pop-ups that demand me to unlock my keyring.

    I know this is coming from Gnome, and I never wanted to install Gnome in the first place, since I don't use it but Xfce.

    I know that I should have installed F27 from the Xfce Spin ISO, which would have avoided the perforce installation of the Gnome stuff.
    But unfortunately, the Xfce Spin is a Live Image, and I read that only the F27 Server offered an e.g. Netinstall ISO.

    That was why I post-install issued a
    Code:
    # dnf group install Xfce\ Desktop
    which pulled in dozens of packages around X and Xfce,
    and which I expected was all that was required to give me a working Xfce Desktop.

    But still I wasn't able to run Xfce,
    neither by issuing startxfce4 as intended user from its login shell in multi-user.target,
    nor through xdm in graphical.target.

    Apparently, there were still a few prerequisite packages missing to get Xfce working.

    Because I wanted to avoid a fresh re-installation of F27, this time from the Live XFCE Spin ISO,
    I desperately simply installed the "Fedora Workstation" group, which eventually must have pulled in the unneeded Gnome stuff,
    along with its Gnome Keyring, for which I also have no need, because I know how to manage my SSH, GPG, SSL/TLS etc. keys on the command line through their respective tools.

    All I want, is to prevent auto-start of these processes, which get started whenever I login to Xfce:
    Code:
    [root@lenolap:~]
    # pgrep keyring|xargs ps -wwfp
    UID        PID  PPID  C STIME TTY      STAT   TIME CMD
    fiddle    2443     1  0 09:30 ?        Sl     0:00 /usr/bin/gnome-keyring-daemon --daemonize --login
    fiddle    3040  2427  0 09:30 ?        Sl     0:00 /usr/bin/gnome-keyring-daemon --start --foreground --components=secrets

  2. #2
    Join Date
    Oct 2011
    Posts
    1,907

    Re: How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?

    I believe removing gnome-keyring and unfortunately pulling gnome-shell with it will remove it. See the following for more: https://forums.fedoraforum.org/showt...03#post1803803

  3. #3
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,924

    Re: How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?

    Xfce is GDM based and is not entirely free of all Gnome components. I have used Xfce for several years now. After one release upgrade, I started getting those gnome-keyring unlock popups. It took me awhile to figure out how to make those go away. The answer was not to remove gnome-keyring, but to enable another service that it now depended on to work automatically without pestering you in the background on bootup.

    I've since forgotten all the details of that fix, but looking in my current Xfce "Sessions and Startup" app, I see that:

    Certificate and Key Storage (Gnome Keyring:PKCS#11 Component)
    Secrect Storage Service (Gnome Keyring: Secret Service)

    are both checked to autostart, and probably work in tandem with "XFCE Polkit (Policykit Authentication Agent)" which is also checked to autostart.

  4. #4
    Join Date
    Dec 2011
    Posts
    74

    Re: How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?

    I use Xfce, do not use GDM, but lightdm as logon manager. Lightdm opens the login keyring using the pam-module for this (gnome_keyring_pam). It took me some troubleshooting to get it to work and my notes are not 100% clear on what got it to work, but I think the key parts are that you need the following lines are in /etc/pam.d/lightdm:

    Code:
    auth       optional    pam_gnome_keyring.so
    session    optional    pam_gnome_keyring.so auto_start
    And that the 'login' keyring is your keyring (use Seahorse to check) and has same password as your logon password.

  5. #5
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,690

    Re: How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?

    If pindakoe's post does not help, check here ~/.config/autostart for a keyring message
    and if not there
    sudo find /usr -name "*desktop" -print.
    When you log into the system with gnome, it's usually autostarted, and the two locations are where logins result in desktop software being invoked.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  6. #6
    Join Date
    Sep 2013
    Location
    Europe/Berlin
    Posts
    34

    Re: How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?

    Quote Originally Posted by pindakoe
    I use Xfce, do not use GDM, but lightdm as logon manager. Lightdm opens the login keyring using the pam-module for this (gnome_keyring_pam). It took me some troubleshooting to get it to work and my notes are not 100% clear on what got it to work, but I think the key parts are that you need the following lines are in /etc/pam.d/lightdm:

    Code:
    auth       optional    pam_gnome_keyring.so
    session    optional    pam_gnome_keyring.so auto_start
    And that the 'login' keyring is your keyring (use Seahorse to check) and has same password as your logon password.

    Hello pidakoe,

    I have several files in /etc/pam.d/ that already contained lines with pam_gnome_keyring.so references without any ado by me.
    Code:
    [root@lenolap:~]
    # grep keyring /etc/pam.d/*|column -t
    /etc/pam.d/gdm-autologin:-auth     optional  pam_gnome_keyring.so  
    /etc/pam.d/gdm-autologin:session   optional  pam_gnome_keyring.so  auto_start
    /etc/pam.d/gdm-password:auth       optional  pam_gnome_keyring.so  
    /etc/pam.d/gdm-password:-password  optional  pam_gnome_keyring.so  use_authtok
    /etc/pam.d/gdm-password:session    optional  pam_gnome_keyring.so  auto_start
    /etc/pam.d/gdm-pin:auth            optional  pam_gnome_keyring.so  
    /etc/pam.d/gdm-pin:session         optional  pam_gnome_keyring.so  auto_start
    /etc/pam.d/lightdm:-auth           optional  pam_gnome_keyring.so  
    /etc/pam.d/lightdm:-session        optional  pam_gnome_keyring.so  auto_start
    /etc/pam.d/passwd:-password        optional  pam_gnome_keyring.so  use_authtok
    What do you mean by, that the [i]login[\i] keyring is your own? Ownership and mode bits? Is the keyring file's name 'login', or is it named something different.
    Where does it reside in ~ (i.e. full path)?

    What is Seahorse? Some GUI Tool to tinker with Xfce config files?
    Code:
    [root@lenolap:~]
    # rpm -q seahorse
    seahorse-3.20.0-6.fc27.x86_64
    [root@lenolap:~]
    # rpm -q --qf %{summary}\\n\\n%{description}\\n seahorse
    A GNOME application for managing encryption keys
    
    Seahorse is a graphical interface for managing and using encryption keys.
    It also integrates with nautilus, gedit and other places for encryption
    operations.  It is a keyring manager.
    [root@lenolap:~]
    # rpm -ql seahorse|grep bin/seahorse
    /usr/bin/seahorse
    Okay, let's see if I can invoke it directly, as I haven't found an entry in the Xfce Application drop down list...

  7. #7
    Join Date
    Sep 2013
    Location
    Europe/Berlin
    Posts
    34

    Re: How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?

    I'm not sure, if what I did in Seahorse made any sense.
    It looked to me, as if the keyring didn't yet exist.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	seahorse_window.2.jpg 
Views:	227 
Size:	61.7 KB 
ID:	29445   Click image for larger version. 

Name:	seahorse_window.1.jpg 
Views:	156 
Size:	31.2 KB 
ID:	29444   Click image for larger version. 

Name:	seahorse_window.3.jpg 
Views:	144 
Size:	37.8 KB 
ID:	29446  

  8. #8
    Join Date
    Sep 2013
    Location
    Europe/Berlin
    Posts
    34

    Lightbulb Re: How to get rid of Gnome "Unlock Keyring" pop-ups though I solely use Xfce?

    I would like to tag this thread as solved, but cannot find the icon or link anymore which provides such a label (I remember to have stumbled over it once).
    I therefore choose the lightbulb icon instead.

    I'd like to thank the repliers for their thoughts.
    The installation of the Seahorse tool enabled me to remove the default Gnome key ring, and ever since then the nagging pop-ups disappeared.

Similar Threads

  1. gnome-keyring does not unlock
    By pindakoe in forum Using Fedora
    Replies: 2
    Last Post: 16th September 2017, 10:13 AM
  2. Unlock the keyring
    By BenTrein in forum Using Fedora
    Replies: 2
    Last Post: 11th June 2012, 04:20 AM
  3. Replies: 0
    Last Post: 27th March 2012, 03:37 PM
  4. XFCE with gnome-keyring-manager and NetworkManager
    By PlateSpinner in forum Using Fedora
    Replies: 5
    Last Post: 18th August 2006, 05:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •