Disable touchscreen under wayland
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2018
    Location
    London
    Posts
    1

    Disable touchscreen under wayland

    I am running Fedora 27 with wayland on my XPS13. Unfortunately the touchscreen is registering many false inputs, enough to seriously impact usability. This is particularly significant after suspend, resume.

    How can I disable the touchscreen? I am aware of how to do this under Xorg but would rather not switch.

    Thanks for any help.

  2. #2
    Join Date
    Dec 2009
    Location
    Malibu, California
    Posts
    450

    Re: Disable touchscreen under wayland

    Not able to answer the question - but only offer my perspective though and will still try a touchscreen with linux.
    I think all these input problems are processor speed related . . . overwhelmed with hovering of mouse freezes up even non-touchscreen models of "surfplatas" (svenska)

  3. #3
    Join Date
    Mar 2018
    Location
    Brazil
    Posts
    1

    Re: Disable touchscreen under wayland

    Disable the module hid-multitouch
    Code:
    modprobe -r hid-multitouch
    Add the module to blacklist
    Code:
    echo "blacklist hid-multitouch" > /etc/modprobe.d/hid-multitouch.conf

Similar Threads

  1. Replies: 7
    Last Post: 7th July 2017, 09:27 PM
  2. [SOLVED]
    F25: how do I disable wayland
    By d3acon in forum Hardware & Laptops
    Replies: 20
    Last Post: 22nd December 2016, 07:39 AM
  3. Replies: 0
    Last Post: 8th October 2008, 11:03 PM
  4. touchscreen
    By ogoy in forum Hardware & Laptops
    Replies: 2
    Last Post: 21st February 2007, 06:39 AM
  5. 3m FPD Touchscreen
    By frederic in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 27th October 2004, 03:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •