FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2018

    Help to install wifi driver

    I am newbie in Linux OS, i installed fedora 27 and trying to setup the wifi driver Mt7630e. I tried to install the driver from https://github.com/neurobin/MT7630E but i am getting errors.

    System information

    [mrsarayra@Fedora-host ~]$ sudo inxi -Fxmz
    System:    Host: Fedora-host Kernel: 4.13.9-300.fc27.x86_64 x86_64 bits: 64 gcc: 7.2.1 Console: tty 0
               Distro: Fedora release 27 (Twenty Seven)
    Machine:   Device: laptop System: ASUSTeK product: X555LB v: 1.0 serial: <filter>
               Mobo: ASUSTeK model: X555LB v: 1.0 serial: <filter>
               UEFI: American Megatrends v: X555LB.603 date: 05/06/2016
    Battery    BAT0: charge: 11.7 Wh 61.7% condition: 19.0/37.3 Wh (51%) model: ASUSTeK ASUS status: Discharging
    CPU:       Dual core Intel Core i7-5500U (-MT-MCP-) arch: Broadwell rev.4 cache: 4096 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9585
               clock speeds: max: 3000 MHz 1: 2396 MHz 2: 2396 MHz 3: 2396 MHz 4: 2396 MHz
    Memory:    Array-1 capacity: 16 GB devices: 2 EC: None
               Device-1: ChannelA-DIMM0 size: 4 GB speed: 1600 MT/s type: DDR3 part: 8KTF51264HZ-1G6N1
               Device-2: ChannelB-DIMM0 size: 4 GB speed: 1600 MT/s type: DDR3 part: M471B5173EB0-YK0
    Graphics:  Card-1: Intel HD Graphics 5500 bus-ID: 00:02.0
               Card-2: NVIDIA GM108M [GeForce 940M] bus-ID: 04:00.0
               Display Server: X.org 1.19.5 drivers: i915,nouveau tty size: 175x24 Advanced Data: N/A for root
    Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
               Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
               Sound: Advanced Linux Sound Architecture v: k4.13.9-300.fc27.x86_64
    Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
               driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 02:00.0
               IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
               Card-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter bus-ID: 03:00.0
               IF: N/A state: N/A mac: N/A
    Drives:    HDD Total Size: 2250.5GB (1.0% used)
               ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB temp: 27C
               ID-2: /dev/sdb model: ST2000LM003_HN size: 2000.4GB temp: 24C
    Partition: ID-1: / size: 58G used: 4.3G (8%) fs: ext4 dev: /dev/sda7
               ID-2: /boot size: 976M used: 117M (13%) fs: ext4 dev: /dev/sda6
               ID-3: /home size: 462G used: 82M (1%) fs: ext4 dev: /dev/sdb3
               ID-4: /var size: 49G used: 1.1G (3%) fs: ext4 dev: /dev/sdb4
               ID-5: swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
    RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
    Sensors:   System Temperatures: cpu: 38.0C mobo: N/A
               Fan Speeds (in rpm): cpu: 2300
    Info:      Processes: 248 Uptime: 6 min Memory: 966.4/7664.0MB Init: systemd runlevel: 5 Gcc sys: N/A
               Client: Shell (sudo) inxi: 2.3.56
    Error code:
    [mrsarayra@Fedora-host MT7630E-release]$ chmod +x install test uninstall bpatch
    [mrsarayra@Fedora-host MT7630E-release]$ ./install
    -----Sorry! Run with root privilege (for example with 'sudo ./install')
    [mrsarayra@Fedora-host MT7630E-release]$ sudo ./install
    [sudo] password for mrsarayra: 
    make -C /lib/modules/4.13.9-300.fc27.x86_64/build M=/home/mrsarayra/Downloads/MT7630E-release/rt2x00 modules
    make[1]: *** /lib/modules/4.13.9-300.fc27.x86_64/build: No such file or directory.  Stop.
    make: *** [Makefile:9: all] Error 2
    [mrsarayra@Fedora-host MT7630E-release]$ sudo make dkms
    cp -v firmware/*/* /lib/firmware/
    'firmware/BT/mt76x0.bin' -> '/lib/firmware/mt76x0.bin'
    'firmware/Wi-FI/MT7650E234.bin' -> '/lib/firmware/MT7650E234.bin'
    cp -R . /usr/src/mt7630e-`sed -n 's/^[[:blank:]]*PACKAGE_VERSION=\([^[:blank:]]*\).*/\1/p' dkms.conf`
    dkms add -m mt7630e -v `sed -n 's/^[[:blank:]]*PACKAGE_VERSION=\([^[:blank:]]*\).*/\1/p' dkms.conf`
    /bin/sh: dkms: command not found
    make: *** [Makefile:31: dkms] Error 127
    [mrsarayra@Fedora-host MT7630E-release]$ sudo ./bpatch
    *** Stoping Bluetooth...
    Redirecting to /bin/systemctl stop bluetooth.service
    *** Installing kernel headers...
    ./bpatch: line 136: apt-get: command not found
    ./bpatch: line 137: apt-get: command not found
    [mrsarayra@Fedora-host MT7630E-release]$ ^C
    [mrsarayra@Fedora-host MT7630E-release]$ sudo ./install
    make -C /lib/modules/4.13.9-300.fc27.x86_64/build M=/home/mrsarayra/Downloads/MT7630E-release/rt2x00 modules
    make[1]: *** /lib/modules/4.13.9-300.fc27.x86_64/build: No such file or directory.  Stop.
    make: *** [Makefile:9: all] Error 2
    [mrsarayra@Fedora-host MT7630E-release]$ ^C
    [mrsarayra@Fedora-host MT7630E-release]$
    also i've installed this before getting above error
    sudo dnf group install "C Development Tools and Libraries"
    Appreciate any help.

  2. #2
    Join Date
    Dec 2013
    United Kingdom

    Re: Help to install wifi driver

    hi, i think you are missing some development packages still. it would be prudent to install the development tools group and kernel-devel. I can't recall if development tools brings in kernel-devel or not. but first if you have a LAN connection to use in the meantime synchronise your fedora 27 installation with the current packages on the updates servers.

    anyhow the following should help:

    sudo dnf distro-sync
    sudo dnf group install "Development Tools"
    sudo dnf install kernel-devel

  3. #3
    Join Date
    Feb 2018

    Re: Help to install wifi driver

    Thanks for replying @antikythera.
    After installing the packages mentioned above + this package (it was necessary) "elfutils-libelf-devel" with the command
    yum --enablerepo=u*g install elfutils-libelf-devel
    I re-installed the driver and it compiled and worked like a charm!

  4. #4
    Join Date
    Mar 2018

    Re: Help to install wifi driver

    Hi everybody,
    thanks for the previous discussion.

    I have exactly the same network adapter of MRSARAYRA, mean: RTL8111/8168/8411. I've exactly the same Fedora distro (27), I've done everything written above and all right... But MY WIFI STILL DOESN'T EXIST FOR FEDORA 27.

    I'm really new in LINUX, I'm trying to do my best, I feel I've learned so much in two weeks: I've studied, I installed myself, making partitions myself, etc... But now I'm already a week on the topic and no go. Despair.

    Does anybody have any suggestion for me?


  5. #5
    Join Date
    Mar 2018

    Re: Help to install wifi driver

    I SOLVED IT!!! i've made plenty of stuff, which might have been useful, but was was finally useful, is that:

    You may use the driver hosted at Larry Finger's rtlwifi_new git repository. Make sure you have linux-headers for the respective kernel(s) and build-essential packages installed. Then follow the steps below.

    Install git and dkms if they're not installed by running

    sudo apt install git dkms

    Clone the repository

    git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git

    Go to the rtlwifi_new directory by

    cd rtlwifi_new

    Run the following commands to install

    sudo make install

    OR alternatively use dkms

    sudo dkms add ../rtlwifi_new
    sudo dkms build rtlwifi-new/0.6
    sudo dkms install rtlwifi-new/0.6


    Note: If you get very weak signal try changing your antenna selection

    sudo /bin/sh -c 'echo "options rtl8723de ant_sel=2" >> /etc/modprobe.d/rtl8723de.conf'

    (or ant_sel=1 for the other one).


  6. #6
    Join Date
    Feb 2018

    Re: Help to install wifi driver

    Thanks for sharing @silvia.
    Sorry for late reply, happy that you solved wifi problem
    Last edited by mrsarayra; 31st March 2018 at 10:38 PM.

Similar Threads

  1. [SOLVED]
    Install wifi driver
    By fed84 in forum Servers & Networking
    Replies: 12
    Last Post: 10th August 2015, 03:42 AM
  2. [SOLVED]
    Need help with BCM4313 Wifi driver install
    By Falven in forum Using Fedora
    Replies: 24
    Last Post: 29th June 2013, 05:44 PM
  3. Wifi: cannot get driver to install 8192cu
    By Postprompt in forum Hardware & Laptops
    Replies: 3
    Last Post: 20th February 2013, 04:55 PM
  4. How to re-install wifi driver
    By jeshrel in forum Servers & Networking
    Replies: 1
    Last Post: 29th August 2012, 04:43 AM
  5. install wifi driver
    By linux44 in forum Using Fedora
    Replies: 2
    Last Post: 7th August 2011, 12:20 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts