Fedora 27 Updates Broke Samba Mounts
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2005
    Posts
    118

    Fedora 27 Updates Broke Samba Mounts

    Updates from 2/13/18 caused samba mounts to my office Netapp Appliances to break. Yes, I tried to undo, but still unable to get anything working.
    Been running this way reliably for a year or so, using nautilus to smb:// interface (command line mounting has been broken for years with glib errors overwriting files using nautilus).

    Updates included: kernel-4.14.18-300.fc27.x86_64, libipa_hbac-1.16.0-5.fc27.x86_64, samba-2:4.7.5-2.fc27.x86_64, libsss_autofs-1.16.0-6.fc27.x86_64

    Based on this link: https://bugzilla.redhat.com/show_bug.cgi?id=1474539#c29 , I modifed my smb.conf to:
    Code:
    [global]
      ...
      client min protocol = CORE
      client max protocol = NT1
      ...
    With these changes, I can actually mount again through nautilus smb://, but file I/O is flakey. Only certain file types are allowed to copy over. I played around with the min/max protocols trying to limit to the more secure SMB3, or even SMB2. But the above config is the only way the shares will mount.

    Thanks for any suggestions! Anyway to make logs more verbose?
    Fedora 27 x86_64 - Intel Ivybridge Desktop
    Fedora 27 X86_64 - Mobile Intel X58 Laptop
    Fedora 27 X86_64 - Mobile Intel QM87 Laptop

  2. #2
    Join Date
    Dec 2017
    Location
    USA
    Posts
    56

    Re: Fedora 27 Updates Broke Samba Mounts

    From smb.conf(5):
    Default: log level = 0
    You can also change the specific sub-section debug levels, such as:
    Example: log level = 3 passdb:5 auth:10 winbind:2

Similar Threads

  1. [SOLVED]
    Fedora 21 updates broke Cinnamon desktop
    By 1340nomad in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 9th June 2015, 04:05 PM
  2. Fedora 12 Updates Broke Wireless
    By blackburst in forum Hardware & Laptops
    Replies: 6
    Last Post: 26th December 2009, 09:47 PM
  3. Samba mounts fail after fc10 upgrade
    By MgFrobozz in forum Using Fedora
    Replies: 0
    Last Post: 28th July 2009, 06:30 PM
  4. Updates broke my Fedora (I think)
    By Torswin in forum Using Fedora
    Replies: 9
    Last Post: 8th January 2009, 11:11 PM
  5. samba only mounts users home directory
    By Kingtu in forum Servers & Networking
    Replies: 1
    Last Post: 18th October 2006, 01:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •