[SOLVED] EFI boot issues Lenovo AIO - Error 1962: No Operating System Found
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2018
    Location
    Phoenix, AZ
    Posts
    7

    EFI boot issues Lenovo AIO - Error 1962: No Operating System Found

    All. I'm hoping someone has some answers, racking my brain here and feel I've tried about everything out there short of reinstall.

    I've got a Fedora 20 setup, I want to eventually migrate to booting off if removable media, so I tested putting an install to an SD card and tried booting Fed27. I booted off a USB stick and tried an install to the SD card, on reboot, I got Error 1962: No Operating System Found.

    Since then all I've been doing is trying to get my Feed install to boot. Recovery mode can consistently find the old system, I can chroot the environment, load up "efibootmgr," but no method, settings I have found seem to "fix" the EFI boot. The only method I can use to avoid getting the boot error above at this point is to order the boot order in bios with the HAD as the 3rd item under both the USB stick and SD card. Any other combo at this point gets me the boot error. I'm stuck at this point. The docs I read say not to use grub2-install, so have not done that yet.

  2. #2
    Join Date
    Feb 2018
    Location
    Phoenix, AZ
    Posts
    7

    Re: EFI boot issues Lenovo AIO - Error 1962: No Operating System Found

    I may have fixed it. Appears the name of the EFI disk label is meaningful.

    Hasn't fully booted yet, restoring some SELinux contexts or something.

    https://unix.stackexchange.com/quest...g-system-found

    Yay, successful reboot!

  3. #3
    Join Date
    Feb 2018
    Location
    Phoenix, AZ
    Posts
    7

    Re: EFI boot issues Lenovo AIO - Error 1962: No Operating System Found

    Specifically to fix, appears I needed to label the EFI boot item as Windows:

    efibootmgr -c -L "Windows Boot Manager" -l "\EFI\fedora\grubx64.efi"

  4. #4
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,218

    Re: EFI boot issues Lenovo AIO - Error 1962: No Operating System Found

    flags boot and esp are required for EFI partitions to work for future reference.

  5. #5
    Join Date
    Feb 2018
    Location
    Phoenix, AZ
    Posts
    7

    Re: EFI boot issues Lenovo AIO - Error 1962: No Operating System Found

    I've not seen any documentation that indicates the boot partition actually needs to be made specifically bootable (nor do I believe mine is, I did have to fix the EFI label though to get it to boot). I never changed it's type from the original Fedora install, so I assume that's how it was setup prior by the Fedora 20 installer.

Similar Threads

  1. Replies: 8
    Last Post: 27th October 2010, 10:34 PM
  2. Scared to install - Operating System Not Found
    By tdsmapper in forum Hardware & Laptops
    Replies: 7
    Last Post: 25th August 2008, 03:34 AM
  3. Install Issues: CD and DVD not working; USB install: "error loading operating system"
    By jakeg in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 5th June 2007, 06:20 PM
  4. Error Loading Operating System on cold boot.
    By dman777 in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 2nd November 2006, 03:43 PM
  5. Missing Operating System Error
    By aBetterGamer in forum Installation, Upgrades and Live Media
    Replies: 6
    Last Post: 14th October 2006, 08:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •