Am I the only one unable to install Rawhide future F28
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 9 of 9
  1. #1
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,542

    Am I the only one unable to install Rawhide future F28

    For the past few posts by HappyAssassin, I have been trying to complete an installation with a "work in process Rawhide version". Unfortunately, almost immediately after anaconda completes the downloads, anaconda aborts. Looking through the brief listing, it appears to be an incompatibility with python and library versions causing malloc failures.

    What successful Rawhide have you succeeded in installing?
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  2. #2
    Join Date
    Mar 2004
    Location
    In your closet
    Posts
    15,739

    Re: Am I the only one unable to install Rawhide future F28

    I never bother with Rawhide but I'll try this one as a virtual machine. Lesse what happens.

    Fedora-LXDE-Live-x86_64-Rawhide-20180117.n.1.iso

    Installed OK. Powered off now. I'll get back to it later.
    Glenn
    The Bassinator

  3. #3
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,542

    Re: Am I the only one unable to install Rawhide future F28

    I was trying to install KDE. After the download, almost immediately after a few rpms were installed. --- MALLOC error. Reboot
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  4. #4
    Join Date
    Dec 2017
    Location
    Rochester
    Posts
    15

    Re: Am I the only one unable to install Rawhide future F28

    The kernel and rawhide seem to be in exceptional flux at the moment, yesterday I did an update to rawhide running in a VM and it was a greater that 650MB download. That on an image that is regularly updated. Mind you this is on a VM I've had zero success installing natively on my AMD based system. We may have to wait a good long time before Rawhide becomes trouble free again.

  5. #5
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,542

    Re: Am I the only one unable to install Rawhide future F28

    Using the same Flash copy of Rawhide, I was able to install Gnome. But when it comes to KDE, anaconda dies. What I believe is the problem is not anaconda, but one of the rpm's that does an malloc call that exceeds Malloc's upper limit.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  6. #6
    Join Date
    Oct 2010
    Location
    Canberra
    Posts
    3,016

    Re: Am I the only one unable to install Rawhide future F28

    Quote Originally Posted by lsatenstein
    Using the same Flash copy of Rawhide, I was able to install Gnome. But when it comes to KDE, anaconda dies. What I believe is the problem is not anaconda, but one of the rpm's that does an malloc call that exceeds Malloc's upper limit.
    Exceeding the malloc limits is usually caused by making a mess of the number holding the size of the required memory.
    Mixing pointers to int and pointers to size_t and then changing from 32bit to 64bit will do that quite nicely.

  7. #7
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,542

    Re: Am I the only one unable to install Rawhide future F28

    Quote Originally Posted by ocratato
    Exceeding the malloc limits is usually caused by making a mess of the number holding the size of the required memory.
    Mixing pointers to int and pointers to size_t and then changing from 32bit to 64bit will do that quite nicely.
    With the Rawhide iso, I chose KDE. There three groups of programs that can accompany KDE. I selected all three, and that crashed the installation. This morning I seleced none, and got a successful installation.

    I am going to redo the installation, omitting one of the three at a time, until I get a successful install. Thereafter, I will raise a bug report.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  8. #8
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,606

    Re: Am I the only one unable to install Rawhide future F28

    leslie have you looked at the KDE ISO test results for 17th January 2018? It's not surprising you can't get it working from network installer either

    Click image for larger version. 

Name:	Screenshot_20180119_200739.jpg 
Views:	29 
Size:	78.9 KB 
ID:	29356

  9. #9
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,542

    Re: Am I the only one unable to install Rawhide future F28

    Hi Antikythera

    I actually took Adam's https://www.happyassassin.net/nightlies.html list and choose the network install version that was in the "green" column.
    Its time to wait for a beta, instead of jumping the gun.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

Similar Threads

  1. Gnome for future as seen in Fedora 27 Rawhide
    By lsatenstein in forum Fedora Focus
    Replies: 6
    Last Post: 30th July 2017, 10:12 AM
  2. Gnome for future as seen in Fedora 27 Rawhide
    By lsatenstein in forum Fedora Spins & Remixes
    Replies: 1
    Last Post: 28th July 2017, 08:48 AM
  3. Replies: 4
    Last Post: 25th October 2005, 03:38 PM
  4. Replies: 1
    Last Post: 20th October 2005, 10:51 AM
  5. Replies: 1
    Last Post: 20th October 2005, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •