Xorg update causes segfault in F27
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 9 of 9
  1. #1
    Join Date
    Nov 2006
    Location
    Detroit
    Posts
    6,732

    Xorg update causes segfault in F27

    Yesterday when doing an update via dnf, the xorg-x11-server-Xorg-1.19.6-1.fc27.x86_64 package was installed. Upon rebooting today, my display manager (lxdm) would not start, and the console terminal kept looping through tons of errors like this:
    Code:
    Process 753 (Xorg) of user 0 dumped core.
    Stack trace of thread 753:
    0x00007fc1f663b66b raise (libc.so.6)
    0x00007fc1f663d381 abort (libc.so.6)
    0x00000000005a046a OsAbort (Xorg)
    0x0000000000479cac ddxGiveUp (Xorg)
    0x00000000005a5f12 AbortServer (Xorg)
    0x00000000005a6d55 FatalError (Xorg)
    0x000000000059d55e OsSigHandler (Xorg)
    0x00007fc1f69f9a80 __restore_rt (libpthread.so.0)
    0x00007fc1f663b66b raise (libc.so.6)
    0x00007fc1f663d381 abort (libc.so.6)
    0x00007fc1f66338fa __assert_fail_base (libc.so.6)
    0x00007fc1f6633972 __assert_fail (libc.so.6)
    0x0000000000421687 dixGetPrivateAddr.isra.3.part.4 (Xorg)
    0x00000000004c4fbf compIsAlternateVisual (Xorg)
    0x00007fc1f44aa877 __glXScreenInit (libglx.so)
    0x00007fc1f44b17b6 __glXDRIscreenProbe (libglx.so)
    0x00007fc1f44a9325 GlxExtensionInit (libglx.so)
    0x00000000004a897d InitExtensions (Xorg)
    0x000000000043971f dix_main (Xorg)
    0x00007fc1f662500a __libc_start_main (libc.so.6)
    0x00000000004235fa _start (Xorg)
    
    Stack trace of thread 766:
    0x00007fc1f69f4c4b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
    0x00007fc1f11a63cb util_queue_thread_func (r600_dri.so)
    0x00007fc1f11a62e7 impl_thrd_routine (r600_dri.so)
    0x00007fc1f69ee61b start_thread (libpthread.so.0)
    0x00007fc1f671b91f __clone (libc.so.6)
    
    lxdm.service: Main process exited, code=exited, status=1/FAILURE
    lxdm.service: Unit entered failed state.
    lxdm.service: Failed with result 'exit-code'.
    lxdm.service: Service hold-off time over, scheduling restart.
    Luckily, I was able to switch to another terminal screen (despite the main console taking over every few seconds), and I then logged in as root and downgraded that package:
    Code:
    dnf downgrade xorg-x11-server-Xorg
    Doing so took my F27 system back to the xorg-x11-server-Xorg-1.19.5-1.fc27.x86_64 package, and then after a few seconds lxdm started (without needing a reboot). All is well now. So downgrading the package fixed the problem.

    Has anyone else here had any problems with that Xorg package update? It's possible that it might just be a problem for lxdm, so I'd be interested in hearing if other display managers have this problem with that Xorg update.
    OS: Fedora 28 x86_64 | Machine: HP Pavilion a6130n | CPU: AMD 64 X2 Dual-Core 5000+ 2.6GHz | RAM: 7GB PC5300 DDR2 | Disk: 400GB SATA | Video: ATI Radeon HD 4350 512MB | Sound: Realtek ALC888S | Ethernet: Realtek RTL8201N

  2. #2
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    926

    Re: Xorg update causes segfault in F27

    I am running lxdm->Xfce with tcp_listen enabled, and xorg-x11-server-Xorg-1.19.6-1.fc27.x86_64
    and I don't see any problems yet. What video card u got ?

    earlier in the day I did have lxdm->LXDE running as well without errors.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  3. #3
    Join Date
    Nov 2006
    Location
    Detroit
    Posts
    6,732

    Re: Xorg update causes segfault in F27

    Quote Originally Posted by bobx001
    What video card u got ?
    ATI Radeon HD 4350. I'm using the free Radeon driver that comes with the xorg-x11-drv-ati package (radeon_drv.so). Never had a problem until that Xorg update the other day.

    Since you're also using lxdm and not having that problem, then it's probably either the video driver or the Mesa DRI driver (for 3D acceleration) for my video card. I'll file a bug report in Fedora's bugzilla.
    OS: Fedora 28 x86_64 | Machine: HP Pavilion a6130n | CPU: AMD 64 X2 Dual-Core 5000+ 2.6GHz | RAM: 7GB PC5300 DDR2 | Disk: 400GB SATA | Video: ATI Radeon HD 4350 512MB | Sound: Realtek ALC888S | Ethernet: Realtek RTL8201N

  4. #4
    Join Date
    Jun 2007
    Posts
    2

    Re: Xorg update causes segfault in F27

    My display manager (GNOME) will not start/fails with Xorg-x11-server-Xorg version 1.19.6 package --appears to have a bug. Using a GeForce GTX 970

  5. #5
    Join Date
    Nov 2006
    Location
    Detroit
    Posts
    6,732

    Re: Xorg update causes segfault in F27

    This problem continues in F28.

    Last month I upgraded to F28 on my machine at work, and everything worked fine. My home machine was still running F27, because I was worried about this bug. But I decided to take a chance and finally upgraded my home machine to F28. Sure enough, X would not start. The error logs are just as before.

    After some trial and error, I tracked it down to the /usr/lib64/xorg/modules/extensions/libglx.so library (part of the xorg-x11-server-Xorg-1.19.6-8.fc28.x86_64 package). Moving that file to a temporary location fixed the problem.

    So X (and LXDM) start now, and I have a working F28 system. However, I no longer have OpenGL/3D-rendering support. It's not a deal-breaker for me, since I'm not a gamer and don't really use any of the OpenGL stuff. But I'd like to get that working anyhow. I'll submit a bug report.
    OS: Fedora 28 x86_64 | Machine: HP Pavilion a6130n | CPU: AMD 64 X2 Dual-Core 5000+ 2.6GHz | RAM: 7GB PC5300 DDR2 | Disk: 400GB SATA | Video: ATI Radeon HD 4350 512MB | Sound: Realtek ALC888S | Ethernet: Realtek RTL8201N

  6. #6
    Join Date
    Nov 2006
    Location
    Detroit
    Posts
    6,732

    Re: Xorg update causes segfault in F27

    Quote Originally Posted by RupertPupkin
    I tracked it down to the /usr/lib64/xorg/modules/extensions/libglx.so library
    I found a temporary workaround to get OpenGL/3D support back: I copied the libglx.so file from the xorg-x11-server-Xorg-1.19.5-1.fc27.x86_64.rpm package (which I had saved) to the /usr/lib64/xorg/modules/extensions directory. So whenever dnf updates the xorg-x11-server-Xorg package I'll have to remember to copy over that one file again, but that's a small price to pay for getting everything to work properly until the bug in libglx.so is fixed.
    OS: Fedora 28 x86_64 | Machine: HP Pavilion a6130n | CPU: AMD 64 X2 Dual-Core 5000+ 2.6GHz | RAM: 7GB PC5300 DDR2 | Disk: 400GB SATA | Video: ATI Radeon HD 4350 512MB | Sound: Realtek ALC888S | Ethernet: Realtek RTL8201N

  7. #7
    Join Date
    Dec 2007
    Location
    Australia
    Posts
    1,856

    Re: Xorg update causes segfault in F27

    For what it's worth, my lxde machines have xorg-x11-server-Xorg-1.19.6-8 installed, and the file /usr/lib64/xorg/modules/extensions/libglx.so from that package in place, and X works normally but I don't use lxdm, but rather boot to a text prompt and then invoke X. That may implicate lxdm in the problem you describe if you can start X from the console.

  8. #8
    Join Date
    Nov 2006
    Location
    Detroit
    Posts
    6,732

    Re: Xorg update causes segfault in F27

    Quote Originally Posted by nsnbm
    That may implicate lxdm in the problem you describe if you can start X from the console.
    I can start X from either LXDM or the console, using the workaround for libglx.so. Neither method worked with the libglx.so from F28.

    It's not LXDM, and it's not even just my ATI card, since other users have reported similar problems with Nvidia cards and other display managers. Something changed in xorg-x11-server-Xorg with version 1.19.6 - that's when all the trouble started. I'm tempted to look at the Xorg source code, but I think I'm out of my element with OpenGL stuff.
    OS: Fedora 28 x86_64 | Machine: HP Pavilion a6130n | CPU: AMD 64 X2 Dual-Core 5000+ 2.6GHz | RAM: 7GB PC5300 DDR2 | Disk: 400GB SATA | Video: ATI Radeon HD 4350 512MB | Sound: Realtek ALC888S | Ethernet: Realtek RTL8201N

  9. #9
    Join Date
    Dec 2007
    Location
    Australia
    Posts
    1,856

    Re: Xorg update causes segfault in F27

    RupertPupkin wrote:
    Neither method worked with the libglx.so from F28.
    Thanks for that ... it makes it clear.

Similar Threads

  1. [SOLVED]
    Update xorg-x11-drv-amdgpu 1.3.0-1.fc25 forces Xorg to use ati module?
    By JohnnyB in forum Hardware & Laptops
    Replies: 3
    Last Post: 31st March 2017, 09:12 AM
  2. Xorg.bin Segfault in OsLookupColor
    By Bidski in forum Using Fedora
    Replies: 11
    Last Post: 5th September 2015, 12:15 AM
  3. [SOLVED]
    systemd segfault after yum update
    By chrismurphy in forum F17 Development Forum
    Replies: 4
    Last Post: 5th March 2012, 10:40 PM
  4. occasional Xorg segfault
    By pankajp in forum Using Fedora
    Replies: 1
    Last Post: 8th February 2011, 08:16 PM
  5. sshd segfault after yum update
    By dave_t in forum Using Fedora
    Replies: 9
    Last Post: 17th March 2006, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •