F27 Gnome smb.service fails to start
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Mar 2013

    F27 Gnome smb.service fails to start

    F27. 64 bit. Using Gnome default. New clean install of F27.

    I am trying to set up a Samba server.

    I followed the Samba Server" install as per Server World, Samba Server, (01) Fully Accessed Shared Folder for F27. Changing only the hosts allow, to my network and the path to my shared directory.

    At the end of the edit to the smb.conf file it was saved and as suggested in the smb.conf file I ran "Testprm". After installation of the appropriate file, via dnf, I was given a summary of the smb.conf file with no errors.

    Next I went to start and enable smb and nmb as indicated in the Server World information using

    systemctl start smb nmb

    The message I received was:
    Failed to start smb.service Unit smb.service not found.
    Failed to start nmb.service unit nmb.service not found.

    looking at the journal
    journalctl -b -S today
    I can see no entries in the log to do with samba

    Anything else I try like
    systemctl status smbd.socket
    systemctl status smbd.service gives Unit smbd.service could not be found

    Re booted the machine with no effect. Stll can not get smb or nmd to start let alone enable them.

    Any ideas please.

  2. #2
    Join Date
    Mar 2013

    Re: F27 Gnome smb.service fails to start

    Solved. For some reason the samba file had no installed but samba-clinet had.

    Now working

Similar Threads

  1. NFS-Server service fails to start
    By a21590 in forum F21 Development Forum
    Replies: 3
    Last Post: 2nd December 2014, 10:14 AM
  2. Replies: 1
    Last Post: 13th February 2014, 03:28 PM
  3. amavisd fails to start as a service. Can you help?
    By flypaper in forum Using Fedora
    Replies: 6
    Last Post: 7th June 2006, 01:33 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts