FedoraForum.org - Fedora Support Forums and Community
Results 1 to 12 of 12
  1. #1
    Join Date
    Feb 2008
    Location
    Portsmouth UK
    Posts
    49

    FC25 --> FC26 Blank Screen at Login.

    I have just tried a fedora 25 --> 26 upgrade that appeared to work apart from the fact that after entering my password the screen went black and the mouse didn't move. This result was the same for whatever mode I selected, GNOME, GNOME Classic or GNOME Xorg. I bit frustrating. I presumed it was an upgrade issue though searches on the Internet and the Forum failed to give me any clues. So having backed up my data I did a fresh install and the result was the same.

    I think now I have a Video issue. So at the boot menu I did an e and added nomodeset to the boot line. This did the trick and I was able to log in and get a GUI. I find this odd as I have never had to do that before. I then did an dnf update and installed the updates for 26 and installed a various few packages. This has no resolved the issue so I have added nomodeset so the system will boot up. I do need it to work.

    I have this card after doing a lspci. I have never installed the Nvidia drivers cause after several attempts I never got them to work. I have always used the nouveau driver that up till this upgrade worked just fine. I am not a gamer but I do like to have good graphics.

    01:00.0 VGA compatible controller: NVIDIA Corporation G73 [GeForce 7600 GS] (rev a1)

    Does anyone have an idea what has happened or how I can find out what is going wrong?

    Thanks..

  2. #2
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    734

    Re: FC25 --> FC26 Blank Screen at Login.

    I had to download the newest Nvidia driver, and fully reinstall it. Its not easy as disabling nouveau is almost impossible.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  3. #3
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,879

    Re: FC25 --> FC26 Blank Screen at Login.

    Quote Originally Posted by bobx001
    I had to download the newest Nvidia driver, and fully reinstall it. Its not easy as disabling nouveau is almost impossible.
    It's easy enough

    https://rpmfusion.org/Howto/NVIDIA?h...tegoryHowto%29

  4. #4
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    734

    Re: FC25 --> FC26 Blank Screen at Login.

    Quote Originally Posted by antikythera
    Well, I've been on Nvidia for the past 10-15 years, and on Fedora, and I have done it 1000000................ times. (using rpmfusion versions at least for 7 years)
    However, since FC26 it has become almost impossible to do it for me. Even following all of the instructions. Nouveau stays active, preventing any nvidia module from loading.
    Take into consideration that I run Xfce or LXDE spins only.

    In fact, I will grab a tripod, my camera, and record myself doing it, with a fresh install, and we shall see what we shall see !
    Last edited by bobx001; 11th January 2018 at 02:07 AM.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  5. #5
    Join Date
    Feb 2008
    Location
    Portsmouth UK
    Posts
    49

    Re: FC25 --> FC26 Blank Screen at Login.

    Am I to take the response that this happens because the Nouveau driver is broken and my only solution is to install the Nvidia proprietary drivers? I understand that adding nomodset on the kernel line actually disables the loading of the video driver and provides a VESA default. I am reluctant as despite several attempts I have never got the Nvidia drivers to work. It could be me but I followed the instructions in the link above and nothing works.

  6. #6
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    734

    Re: FC25 --> FC26 Blank Screen at Login.

    Quote Originally Posted by yakky58
    It could be me but I followed the instructions in the link above and nothing works.
    Exactly the same I see.
    What has worked for me is the following:
    GOAL: from the console type: "rmmod nouveau" , and then after upon [lsmod | grep nouveau] nothing should appear
    1. is to first disable graphical login (change symlinks in /etc/systemd/system/ from graphical.target to multi-user.target)
    2. take out "rhgb" and "quiet" from the /etc/default/grub file (my line reads: GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau")
    3. try to install the proprietary NVIDIA driver, even though this will most probably fail, it will create this file:
    Code:
    cat /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
    # generated by nvidia-installer
    blacklist nouveau
    options nouveau modeset=0
    That file seems to help too.
    4. keep rebooting, until you can successfully accomplish the GOAL above.
    5. Once you can successfully rmmod nouveau, THEN, you run the NVIDIA proprietary installer again,. and it will work.
    6. Make sure you download the latest NVIDIA driver, as the previous version does not work, it complains about dkms, etc.

    This is what worked for me.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  7. #7
    Join Date
    Feb 2008
    Location
    Portsmouth UK
    Posts
    49

    Re: FC25 --> FC26 Blank Screen at Login.

    Hi,

    Thanks for the feedback. Just so I am clear in my mind of the steps....

    1. Once the result of lsmod | grep nouveau is blank the GOAL is achieved and at that point I can install the Nvidia driver?
    2. I need to reset this link to multi-user.target. That's the only one I found in the directory.

    lrwxrwxrwx. 1 root root 36 Jan 10 19:12 default.target -> /lib/systemd/system/graphical.target
    [root@FC26-YEWS system]# pwd
    /etc/systemd/system
    [root@FC26-YEWS system]#

    3. The package to install should be...
    Legacy GeForce 6/7

    Supported on current stable Xorg server release.

    dnf install xorg-x11-drv-nvidia-304xx akmod-nvidia-304xx
    dnf update -y

    I have a GS7500 GeForce that seems to be the one. That's on the Fedora site. Or should I install the one from Nvdia? Every time I have used theirs I get horrendous errors.

    4. Presume once is installs. I undo the the symlink and reboot to load the Nvidia adapter. leave the Grub blacklist.
    5. Pray that the next kernel update doesn't break the whole process.

    Thanks and hope your not affected by the fires and mudslides.

    To be tested on my test service before I try on the one I work on. I am actually considering migrating back to FC25 it just worked. All my blue tooth has stopped. What a pain.

  8. #8
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    734

    Re: FC25 --> FC26 Blank Screen at Login.

    Quote Originally Posted by yakky58
    Hi,

    Thanks for the feedback. Just so I am clear in my mind of the steps....

    1. Once the result of lsmod | grep nouveau is blank the GOAL is achieved and at that point I can install the Nvidia driver?
    2. I need to reset this link to multi-user.target. That's the only one I found in the directory.

    lrwxrwxrwx. 1 root root 36 Jan 10 19:12 default.target -> /lib/systemd/system/graphical.target
    [root@FC26-YEWS system]# pwd
    /etc/systemd/system
    [root@FC26-YEWS system]#
    .
    #1. yeah, that's what I have seen which "needs to happen" before you can proceed with any other stuff.

    #2.
    Code:
    cd /etc/systemd/system
    rm -f default.target
    ln -s /lib/systemd/system/multi-user.target default.target
    (then reboot)

    once you have installed the Nvidia drivers, then proceed to undo that, by reversing it, i.e.:
    Code:
    cd /etc/systemd/system
    rm -f default.target
    ln -s /lib/systemd/system/graphical.target default.target
    (then reboot)

    I have tried the rpmfusion like they say in the link, but it's not working for me (since FC26). It always boots to nouveau again, so once I achieved the GOAL, I then proceeded to install the NVIDIA "proprietary" driver, from the Nvidia.com site.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  9. #9
    Join Date
    Feb 2008
    Location
    Portsmouth UK
    Posts
    49

    Re: FC25 --> FC26 Blank Screen at Login.

    Ok, I have resolved this issue after a lot of searching testing and reading on the Internet. I set nomodeset off rebooted and then captured the real errors out of the journal.

    Jan 11 14:48:25 FC26-YEWS gnome-shell[891]: Error looking up permission: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for geolocation
    Jan 11 14:48:25 FC26-YEWS kernel: nouveau 0000:01:00.0: gr: intr 00100000 [ERROR] nsource 00002000 [NOTIFY_IN_USE] nstatus 00800000 [STATE_IN_USE] ch 6 [001df1e0 Xwayland[1114]] subc 7 class 4097 mthd 0180 data 000111f0
    Jan 11 14:48:25 FC26-YEWS kernel: nouveau 0000:01:00.0: gr: intr 00100000 [ERROR] nsource 00002000 [NOTIFY_IN_USE] nstatus 00800000 [STATE_IN_USE] ch 6 [001df1e0 Xwayland[1114]] subc 2 class 0039 mthd 0180 data 000111f0

    So what I could not resolve was that this was looking for Xwayland when I had specifically requested X-org from the choices at sign in. I then looked at the levels of the nouveau drivers I had installed on FC25 to FC26.
    Xorg-x11-drv-nouveau-1.0.15-2.fc25.x86_64
    Xorg-x11-drv-nouveau-1.0.15-1.fc26.x86_64

    So it looked like the nouveau driver had been downgraded but this still didn't explain why Xwayland was being presented when I didn't want that. I happened upon a
    https://bugzilla.redhat.com/show_bug.cgi?id=1457626
    This defined the issue I had though not with my Nvidia card but with Nvdia cards per see. This was considered a FC26 blocker but as the results were random it was not made a blocker.
    I saw that a work around to fix this was to update the /etc/gdm/custom.conf file :

    # GDM configuration storage

    [daemon]
    # Uncoment the line below to force the login screen to use Xorg
    WaylandEnable=false <------------ Uncommented this line

    [security]

    [xdmcp]

    [chooser]

    [debug]
    # Uncomment the line below to turn on debugging
    #Enable=true

    I removed the comment on the line and removed the nomodeset on the boot line and hey presto I now get a decent screen format.

    Thanks to all who fed back. This can be set to SOLVED.

  10. #10
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    734

    Re: FC25 --> FC26 Blank Screen at Login.

    yakky
    check my last post here (#12):
    https://forums.fedoraforum.org/showt...on-proprietary
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  11. #11
    Join Date
    Feb 2008
    Location
    Portsmouth UK
    Posts
    49

    Re: FC25 --> FC26 Blank Screen at Login.

    Thanks. So it would appear there is an easy way to install the Nvidia drivers? I have never found one but willing to try again if you can point me to the HowTo by Leigh123linux has created.

    Or is it just you do ...

    dnf install xorg-x11-drv-nvidia akmod-nvidia
    dnf update -y

    Send me the youtube link ... I have a test machine I can try on. I have spent 4 days getting my normal work machine back to a usable condition. I don't want to do that again in a hurry.

    Thanks. Nik

  12. #12
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,879

    Re: FC25 --> FC26 Blank Screen at Login.


Similar Threads

  1. 4.11.5 skylake black screen, FC25, FC26 beta
    By beaver6675 in forum Using Fedora
    Replies: 19
    Last Post: 19th July 2017, 05:08 AM
  2. Live bare metal FC25 to FC26 upgrade
    By nobody in forum F26 Development Forum
    Replies: 18
    Last Post: 10th July 2017, 10:39 AM
  3. fedup FC25 -> FC26 not working (yet?)
    By bobx001 in forum F26 Development Forum
    Replies: 3
    Last Post: 29th April 2017, 11:00 PM
  4. Replies: 1
    Last Post: 18th April 2017, 01:59 AM
  5. Finishes booting then goes to blank screen before it gets to the login screen
    By cameraman_2 in forum Installation, Upgrades and Live Media
    Replies: 8
    Last Post: 17th July 2007, 02:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •