FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2010
    Location
    México City
    Age
    61
    Posts
    43

    Simple Scan shows webc am instead of scanner [SOLVED]

    Hi.
    Just installed Simple Scan on a recently updated Fedora 27 system.
    I have an Epson L565 printer and scanner.
    Simple Scan shows "Noname USB camera as scanning device.

    Before upgrading to Fedora 27, I had Image Scan installed.
    Though a bit more sophisticated, it did read the scanner.
    After the upgrade, it didn't show up anymore.

    Skanlite and Xsane are also detecting "Noname USB camera".

    I ran
    Code:
    [root@hy ahm]# sane-find-scanner
    
      # sane-find-scanner will now attempt to detect your scanner. If the
      # result is different from what you expected, first make sure your
      # scanner is powered up and properly connected to your computer.
    
      # No SCSI scanners found. If you expected something different, make sure that
      # you have loaded a kernel SCSI driver for your SCSI adapter.
    
    could not fetch string descriptor: Pipe error
    could not fetch string descriptor: Pipe error
    found USB scanner (vendor=0x04b8, product=0x08d3) at libusb:001:003
    could not fetch string descriptor: Pipe error
    found USB scanner (vendor=0x045e, product=0x00f7) at libusb:003:002
      # Your USB scanner was (probably) detected. It may or may not be supported by
      # SANE. Try scanimage -L and read the backend's manpage.
    
      # Not checking for parallel port scanners.
    
      # Most Scanners connected to the parallel port or other proprietary ports
      # can't be detected by this program.
    What can the problem be?
    Last edited by mackissack; 11th January 2018 at 12:05 AM. Reason: additional information, solved

  2. #2
    Join Date
    Aug 2010
    Location
    México City
    Age
    61
    Posts
    43

    Re: Simple Scan shows webcam instead of scanner

    I could find a solution, thanks to Tquilha in his thread
    https://forums.fedoraforum.org/showt...dora-24-64-bit

    He lead to the Epson site
    http://download.ebz.epson.net/dsc/se...h/searchModule
    When selecting to download Scanner Driver, this page opens
    http://support.epson.net/linux/en/im...version=1.3.23

    In my case, I downloaded the Fedora 27 drivers to a folder within the Downloads folder.
    Then I installed the drivers
    Code:
    [root@hy /]# rpm -ivh /home/ahm/Descargas/Epson-L565/Scanner/imagescan-bundle-fedora-27-1.3.23.x64.rpm/core/imagescan-3.33.0-1epson4fedora27.x86_64.rpm
    Preparando...                         ################################# [100%]
    Actualizando / instalando...
       1:imagescan-3.33.0-1epson4fedora27 ################################# [100%]
    In my case, instruction
    Code:
    [root@hy /]# sane-find-scanner
    showed no positive results.

    But Image Scan was installed.
    And Simple Scan detected the Epson-L565 scanner.
    Xsane detected it too showing the possibility to choose between the "Noname USB camera" and the Epson-L565 scanner.
    However, Xsane couldn't open the scanner.
    Last edited by mackissack; 11th January 2018 at 12:00 AM. Reason: Additional results found

  3. #3
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    590

    Re: Simple Scan shows webcam instead of scanner

    Quote Originally Posted by mackissack
    However, Xsane couldn't open the scanner.
    I have found that rebooting the actual scanner, after installing everything, sometimes works. At least in my HP MFP.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

Similar Threads

  1. Simple Scan; Fedora sees/controls scanner but no scan displayed
    By andrewf in forum Photography, Imaging and Graphics Software
    Replies: 3
    Last Post: 31st December 2017, 05:24 PM
  2. Simple Scan does not recognize scanner anymore
    By sprintcowboy in forum Using Fedora
    Replies: 4
    Last Post: 24th December 2017, 06:47 PM
  3. Scanner not recognized in Simple Scan
    By blaplante in forum Using Fedora
    Replies: 12
    Last Post: 3rd May 2017, 12:59 PM
  4. Scanner light goes off after each scan
    By Volans in forum Using Fedora
    Replies: 3
    Last Post: 3rd May 2011, 01:03 AM
  5. Fedora 13 - Simple Scan
    By dalponis in forum Hardware & Laptops
    Replies: 0
    Last Post: 11th October 2010, 06:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •