FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    Jan 2018
    Location
    California
    Posts
    10

    Bluetooth stuck in off

    I have checked other threads for this issue, and none of them have solved it.

    Like other issues, GNOME says bluetooth is always off no matter what.

    Output of dmesg:
    Code:
    [  256.116641] rfkill: input handler disabled
    [  262.782367] Bluetooth: hci0: urb 0000000004a09c85 failed to resubmit (113)
    [  262.782530] Bluetooth: hci0: urb 00000000ceab00eb failed to resubmit (113)
    [  262.782574] Bluetooth: hci0: urb 000000001903c393 failed to resubmit (113)
    Output of sudo hciconfig hci0 up:
    Code:
    Can't init device hci0: Connection timed out (110)
    uname -a if it helps:
    Code:
    Linux localhost.localdomain 4.15.0-0.rc6.git2.1.fc28.x86_64 #1 SMP Fri Jan 5 16:34:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
    Bluetooth works as expected on my Windows partition.

  2. #2
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,879

    Re: Bluetooth stuck in off

    what hardware are you using? https://forums.fedoraforum.org/showt...kmark-it-first

    also check for any physical hardware switch if you are posting about a notebook. sometimes they have them for use in flight check-in

  3. #3
    Join Date
    Jan 2018
    Location
    California
    Posts
    10

    Re: Bluetooth stuck in off

    I am not using a laptop. My inxi reveals:
    Code:
    System:    Host: localhost.localdomain Kernel: 4.15.0-0.rc6.git2.1.fc28.x86_64 x86_64 bits: 64 gcc: 7.2.1
               Console: tty 0 Distro: Fedora release 28 (Rawhide)
    Machine:   Device: desktop Mobo: ASUSTeK model: M32CD_A_F_K20CD_K31CD v: Rev 1.xx serial: <filter>
               UEFI: American Megatrends v: 0901 date: 01/28/2016
    CPU:       Quad core Intel Core i5-6400 (-MCP-) arch: Skylake-S rev.3 cache: 6144 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 21696
               clock speeds: max: 3300 MHz 1: 900 MHz 2: 900 MHz 3: 900 MHz 4: 900 MHz
    Memory:    Array-1 capacity: 32 GB devices: 2 EC: None
               Device-1: DIMM_A1 size: 8 GB speed: 2133 MT/s type: DDR4 part: HMA41GU6AFR8N-TF
               Device-2: DIMM_B1 size: No Module Installed type: N/A
    Graphics:  Card: Intel HD Graphics 530 bus-ID: 00:02.0
               Display Server: X.org 1.19.6 drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: 1920x1080@60.00hz, 1024x768@60.00hz
               OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
               version: 4.5 Mesa 17.3.0-rc3 Direct Render: Yes
    Audio:     Card-1 Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
               Card-2 Microsoft LifeCam VX-6000 (SN9C20x + OV9650) driver: USB Audio usb-ID: 003-003
               Sound: Advanced Linux Sound Architecture v: k4.15.0-0.rc6.git2.1.fc28.x86_64
    Network:   Card-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
               driver: rtl8821ae port: e000 bus-ID: 03:00.0
               IF: wlp3s0 state: up mac: <filter>
               Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
               driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 04:00.0
               IF: enp4s0 state: down mac: <filter>
    Drives:    HDD Total Size: 1000.2GB (16.8% used)
               ID-1: /dev/sda model: TOSHIBA_DT01ACA1 size: 1000.2GB temp: 32C
    Partition: ID-1: / size: 50G used: 34G (72%) fs: ext4 dev: /dev/dm-0
               ID-2: /home size: 302G used: 116G (41%) fs: ext4 dev: /dev/dm-2
               ID-3: /boot size: 976M used: 179M (20%) fs: ext4 dev: /dev/sda5
               ID-4: swap-1 size: 8.39GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
    RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
    Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
               Fan Speeds (in rpm): cpu: 0
    Info:      Processes: 244 Uptime: 7:54 Memory: 2884.1/7841.3MB Init: systemd runlevel: 5 Gcc sys: 7.2.1
               Client: Shell (sudo) inxi: 2.3.53

  4. #4
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,879

    Re: Bluetooth stuck in off

    so some kind of USB bluetooth adaptor? please post the output of

    Code:
    lsusb -v

  5. #5
    Join Date
    Jan 2018
    Location
    California
    Posts
    10

    Re: Bluetooth stuck in off

    Quote Originally Posted by antikythera
    so some kind of USB bluetooth adaptor? please post the output of

    Code:
    lsusb -v
    Code:
    #( 01/10/18@ 3:13PM )( TsundereBug@localhost ):~
       lsusb -v > lsusb.txt
    Couldn't open device, some information will be missing
    Couldn't open device, some information will be missing
    Couldn't open device, some information will be missing
    Couldn't open device, some information will be missing
    Couldn't open device, some information will be missing
    Couldn't open device, some information will be missing
    Couldn't open device, some information will be missing
    Couldn't open device, some information will be missing
    Couldn't open device, some information will be missing
    #( 01/10/18@ 3:13PM )( TsundereBug@localhost ):~
       sudo lsusb -v > rootlsusb.txt
    can't get debug descriptor: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get device qualifier: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get device qualifier: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    can't get device qualifier: Resource temporarily unavailable
    can't get debug descriptor: Resource temporarily unavailable
    My bluetooth isn't a USB dongle, as it came in my desktop.

    https://hastebin.com/darafaxowu.pas lsusb.txt (nonroot)
    https://hastebin.com/xometurafi.pas rootlsusb.txt (root)

  6. #6
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    734

    Re: Bluetooth stuck in off

    did you try running/installing blueberry ?
    I found it has solved all my bluetooth issues, mainly random disconnects, or failed to see devices, etc.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  7. #7
    Join Date
    Jan 2018
    Location
    California
    Posts
    10

    Re: Bluetooth stuck in off

    Blueberry is for Linux Mint.

    Also, the only problem I have with random disconnects is a 2nd controller device in Windows 10.

  8. #8
    Join Date
    Nov 2017
    Location
    Havant
    Posts
    178

    Re: Bluetooth stuck in off

    Quote Originally Posted by TsundereBug
    Blueberry is for Linux Mint.
    .
    What point are you trying to make?, blueberry is in fedora repos.

  9. #9
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,879

    Re: Bluetooth stuck in off

    I never mentioned anything about a dongle. your bluetooth device does run off USB bus though

    Code:
    Bus 001 Device 004: ID 13d3:3414 IMC Networks 
    Device Descriptor:
      bLength                18
      bDescriptorType         1
      bcdUSB               2.10
      bDeviceClass          224 Wireless
      bDeviceSubClass         1 Radio Frequency
      bDeviceProtocol         1 Bluetooth
      bMaxPacketSize0        64
      idVendor           0x13d3 IMC Networks
      idProduct          0x3414 
      bcdDevice            2.00
      iManufacturer           1 Realtek 
      iProduct                2 Bluetooth Radio 
      iSerial                 3 00e04c000001
    It's not a brand I've come across before but the realtek chip it contains is. the only information I can find on it relates to getting it working with Linux Mint and Ubuntu and are fairly outdated. I have Intel Bluetooth in my system which just works with the standard kernel modules. Realtek WLAN and bluetooth devices are always for some reason problematic with Linux.

  10. #10
    Join Date
    Jan 2018
    Location
    California
    Posts
    10

    Re: Bluetooth stuck in off

    Quote Originally Posted by leigh123linux
    What point are you trying to make?, blueberry is in fedora repos.
    Sorry, my fault, I couldn't see it last time I tried `sudo dnf install blue` and tab.

    I have installed blueberry like this and I have rebooted. Nothing has changed.

    dmesg outputs
    Code:
    [   83.908844] Bluetooth: RFCOMM TTY layer initialized
    [   83.908853] Bluetooth: RFCOMM socket layer initialized
    [   83.908912] Bluetooth: RFCOMM ver 1.11
    [   99.455062] rfkill: input handler disabled
    [  112.629558] Bluetooth: hci0: urb 000000004fde08cb failed to resubmit (113)
    Last edited by TsundereBug; 11th January 2018 at 03:17 PM.

  11. #11
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    734

    Re: Bluetooth stuck in off

    oofff, looks like incompatible hardware.
    what happens if you boot up with a knoppix live CD/USB-stick ? can you get it working ?
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  12. #12
    Join Date
    Jan 2018
    Location
    California
    Posts
    10

    Re: Bluetooth stuck in off

    That sucks, because in Fedora 26 bluetooth worked just fine. I'll test the live CD/USB thing over the weekend

  13. #13
    Join Date
    Oct 2013
    Location
    San Francisco
    Posts
    4

    Re: Bluetooth stuck in off

    Watching this thread, as I'm experiencing the same intensely frustrating problem...i have an older Dell One 2330. BT worked perfectly after the initial install of F27 in mid-December. Lately it started exhibiting this exact problem, and I haven't found a solution yet...

  14. #14
    Join Date
    Jan 2018
    Location
    California
    Posts
    10

    Re: Bluetooth stuck in off

    This leads me to believe it is a problem with some sort of update, maybe to the kernel or to bluez.

  15. #15
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    734

    Re: Bluetooth stuck in off

    Code:
    [root@nova ~]# lsusb
    Bus 005 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
    my Bluetooth dongle here, with blueberry, is working like a charmola.

    I will try my laptop's, and post my findings here.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 3
    Last Post: 7th March 2017, 10:46 PM
  2. Replies: 2
    Last Post: 11th September 2016, 02:38 PM
  3. bluetooth 3g access using bluetooth with fedora 14 X86_64
    By rpjogee in forum Servers & Networking
    Replies: 3
    Last Post: 2nd January 2011, 07:03 AM
  4. Replies: 2
    Last Post: 2nd November 2009, 07:28 PM
  5. Replies: 0
    Last Post: 15th April 2005, 03:25 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •