Unable to boot after upgrading to Kernel 4.14 on Fedora 27
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2017

    Question Unable to boot after upgrading to Kernel 4.14 on Fedora 27

    I ran sudo dnf update while I was following a guide to install VirtualBox, and one of the updates it received was a new kernel. Once the install finished, I stupidly rebooted right away instead of running grub2-mkconfig to rebuild the grub config. As such I was greeted by the grub shell, and began searching for a guide on how to boot Fedora so I could rebuild the grub config. I have a dual-boot setup with Windows 10, and the two partitions of interest are /dev/sda2 (hd0,gpt2) which contains a boot folder, and /dev/sda6 (hd0,gpt6) which contains the kernel and initramfs. So I used the following commands to try to boot into fedora:
    grub> set root(hd0,gpt6)
    grub> linuxefi /vmlinuz-4.14.11-300.fc27.x86_64 root=/dev/sda6
    grub> initrdefi /initramfs-4.14.11-300.fc27.x86_64.img
    grub> boot
    Here's an image including the contents of those partitions:
    Click image for larger version. 

Name:	IMG_20180108_191714918.jpg 
Views:	66 
Size:	96.4 KB 
ID:	29319

    This managed to boot into an emergency shell, which revealed that the system was failing at starting switch root, and that sysroot does not appear to be an OS tree. I've encountered this issue while upgrading from f26 to f27 so I used the same resource I used before to sort out the issue found here:
    mount -o remount,rw /sysroot
    rm -rf /sysroot/etc/os-release
    cp /usr/lib/os-release /sysroot/etc
    Issue here was that /sysroot/etc/os-release didn't exist at all! So I figured I would create the /sysroot/etc dir and then just copy os-release to that. Everything went well and I (hard) rebooted the system afterwards. After doing the same commands in the grub shell as I did before, it booted, but now it is stuck in an infinite cycle where it constantly does all the boot tasks, fails with [FAILED] Failed to start load Kernel Modules then just tries again and again and again with the same failure occurring, resulting in text flying down the screen constantly, and no way (I could find) to get into the emergency shell. The result is the same if I try loading the previous 4.13.12 kernel. I couldn't find anything relating to this issue online.

    Click image for larger version. 

Name:	IMG_20180108_191745120.jpg 
Views:	45 
Size:	194.2 KB 
ID:	29320

    Is there any way to fix this issue? I'm not too keen on a re-installation...

    On a side note
    I also tried just regenerating the grub config before the load Kernel Modules failure by booting into the live CD and mounting the partitions, however I could not manage to mount or chroot into those partitions.

    I also tried booting grub using the simlink found in /dev/sda2:
    grub> set root(hd0,gpt2)
    grub> linuxefi /vmlinuz-linux root=/dev/sda6
    grub> initrdefi /initramfs-linux.img
    grub> boot
    Click image for larger version. 

Name:	IMG_20180108_192034386.jpg 
Views:	21 
Size:	42.6 KB 
ID:	29321

    However, this booted into a shell as rootfs saying that the Root device mount successfully, but /sbin/init does not exist. I've never encountered this issue before and an hour of researching this issue didn't yield any success.

    Click image for larger version. 

Name:	IMG_20180108_192130866.jpg 
Views:	32 
Size:	179.6 KB 
ID:	29322

    Was the first way that I tried booting from the grub shell the correct way, or is the second way better? Hopefully the images can provide some context as to what each of those partitions contain.

    Thank you for your time!

  2. #2
    Join Date
    Nov 2017

    Re: Unable to boot after upgrading to Kernel 4.14 on Fedora 27

    Figured out the issue, it ended up being a rather dumb misunderstanding my my behalf...

    The install was set up with LVM so I had to set the /dev/mapper/fedora-root partition to root in the linuxefi command:
    grub> set root(hd0,gpt6)
    grub> linuxefi /vmlinuz-4.14.11-300.fc27.x86_64 root=/dev/mapper/fedora-root
    grub> initrdefi /initramfs-4.14.11-300.fc27.x86_64.img
    grub> boot
    After that everything booted up properly.

    I also went and undid the changes I made in my previous attempts to fix the issue.

    And for the record, the simlink I tried before was actually left over from an Arch install I previously had that I couldn't get to work, so I went and cleaned that up too!

Similar Threads

  1. Boot process hangs up after upgrading to 4.9.4-100.f24 kernel on Fedora 24
    By sherba800 in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 11th February 2017, 11:06 PM
  2. Replies: 3
    Last Post: 7th December 2011, 11:26 PM
  3. Unable to suspend after upgrading to fedora 16 - help!
    By harshad1 in forum Using Fedora
    Replies: 12
    Last Post: 20th November 2011, 08:29 PM
  4. [SOLVED]
    Can't boot after upgrading to kernel
    By Lo Zeno in forum Using Fedora
    Replies: 2
    Last Post: 29th December 2010, 10:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts