Unable to play videos in totem on newly installed f27 system.
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Sep 2012
    Location
    Toronto
    Posts
    26

    Unable to play videos in totem on newly installed f27 system.

    I have installed fedora 27 on a new system, and discovered that I am unable to play video filed (mp4, flash, avi).
    (I had access to another system which had been upgraded to 27 from 24-225-26, and experienced no such problem.)
    When I try to play an mp4 file, I get the message
    Unable to play the file
    MPEG-4 AAC decoder, H.264 (Main Profile) deccoder are required to play the file, but are not installed.
    If I then click on the "Find in Software" button in the message box, Software opens with three packages displayed:
    GStreamer Multimedia Codecs
    Multimedia playback for APE, AVI, DV, FLAC, FLX, Flash, MKV, MP4, Speex, VP8, VP9 and WAV

    GStreamer Multimedia Codecs - Extra
    Multimedia playback for AIFF, DVB, GSM, MIDI, MXF and Opus

    GStreamer Multimedia Codecs - H.264
    Multimedia playback for H.264
    I tried installing each of the three, but each one failed, giving me these messages:
    Unable to install GStreamer Multimedia Codecs
    gstreamer1-plugins-good-1.12.3-1.fc27.x86_64 is already installed

    Unable to install GStreamer Multimedia Codecs - Extra
    gstreamer1-plugins-bad-free-1.12.3-1.fc27.x86_64 is already installed

    Unable to install GStreamer Multimedia Codecs - H.264
    [system/package/fedora/codec/gstreamer-openh264/*] repo already enabled
    I checked gstreamer packages with "dnf list installed" and found
    gstreamer1(x86-64)
    gstreamer1-plugins-base(x86-64) >= 1.6.0
    gstreamer1-plugins-good(x86-64)
    gstreamer1-plugins-ugly-free(x86-64)
    I am not sure how to proceed. Can anyone suggest a solution, or additional diagnostic steps.

  2. #2
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    427

    Re: Unable to play videos in totem on newly installed f27 system.

    Install vlc and maybe even mplayer. See if either one of those works with your video files. If you don't have rpm-fusion repos installed you will have to install them (https://rpmfusion.org/Configuration/)

  3. #3
    Join Date
    Sep 2012
    Location
    Toronto
    Posts
    26

    Re: Unable to play videos in totem on newly installed f27 system.

    vlc works fine
    thank you

  4. #4
    Join Date
    Oct 2015
    Location
    northwest us
    Posts
    18

    Re: Unable to play videos in totem on newly installed f27 system.

    I followed the instructions, still can't play a dvd. The title menu will appear and that's about it. vlc is installed. Cannot find gstreamer multimedia h.264, but rpmfusion repo is present.

  5. #5
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    427

    Re: Unable to play videos in totem on newly installed f27 system.

    Install pavucontrol and make sure you are running pulseaudio. Open pavucontrol and make sure pulse is detecting the proper video card (in "Configuration"). Then check "Output Device" and look at drop-down menu to make sure it has found your speakers/earphones, etc. Make sure the "speaker" is not muted and the drop-down menu on the bottom should say "All Output Devices". Then go to "Playback" and change drop-down menu if necessary. Again make sure audio hasn't been muted. Look at bottom drop-down device. It should say "All Output Devices". If you see the audio line pulsate (either here or when you look at "Output Device"), then your audio is working. Keep playing with settings until audio gets to your speakers.

    If you have installed VLC, you probably have all codecs, etc that you need.

  6. #6
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    926

    Re: Unable to play videos in totem on newly installed f27 system.

    I would install rpmfusion first, then mplayer, mplayer-gui, a52dec, libdvdread, libdvdnav , and also kaffeine (I use kaffeine to watch DVDs on comp, and I use mplayer for everything else).
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  7. #7
    Join Date
    Nov 2012
    Location
    Canada
    Posts
    7
    Linux (Fedora) Firefox 61.0

    Re: Unable to play videos in totem on newly installed f27 system.

    VLC doesn't play BBC videos, and neither does Firefox, I've updated to the latest codecs and my FC27 is fully up-to-date, and still no joy on BBC videos. Some of the older ones (ie a month or more old) will play, but the most recent ones from about three weeks back on, do not. I can't get them to stream in VLC. FF won't play them with all of the addons shut off and neutralized. I've notified FF.

    EDIT: Installed the RPMFusion Free and non free for FC27, even rebooted, no difference. What happens is: video appears to load, can see first frame, and if one pulls the video tab at the bottom of the video window, it shows the frames, BUT there is no audio and it will not stream the way it is supposed to. I am running UblockOrigin 1.16.14 with heavy blocking, and Ghostery for Firefox version 8.2.1. Shutting these off either individually or collectively makes no difference to the above. I don't know what else I can do. Even running FF with addons disabled does not make a difference.
    Last edited by trennor; 2nd August 2018 at 03:33 PM.

  8. #8
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    427
    Linux (Fedora) Firefox 61.0

    Re: Unable to play videos in totem on newly installed f27 system.

    Have you tried to play BBC videos with mplayer? Also install Google Chrome to see if they can be played with that browser.

Similar Threads

  1. [SOLVED]
    Totem and Rhythmbox can't play music and videos after an update
    By jvroig in forum Using Fedora
    Replies: 4
    Last Post: 7th August 2013, 10:53 AM
  2. Can't update newly installed system
    By gizenshu in forum Using Fedora
    Replies: 0
    Last Post: 23rd May 2011, 12:30 AM
  3. newly installed system just went kaput..I think
    By salmichaels in forum Installation, Upgrades and Live Media
    Replies: 14
    Last Post: 22nd August 2010, 11:38 PM
  4. Totem doesn't play M4V videos
    By ricardo_13 in forum Using Fedora
    Replies: 3
    Last Post: 17th June 2010, 06:40 PM
  5. Program unable to compile on newly installed FC1
    By cranium2003 in forum Using Fedora
    Replies: 0
    Last Post: 27th March 2005, 06:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •