FedoraForum.org - Fedora Support Forums and Community
Results 1 to 15 of 15

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Dec 2017
    Location
    Australia
    Posts
    6

    New user - nvidia drivers

    I'm a new fedora linux user. I've been using it maybe 2 months.

    I installed Fedora 26 from DVD on my new laptop with a nvidia Geforce 960M card. I also have windows 10 so I use UEFI. I couldn't get the nouveau driver to work so I started with getting the intel onboard graphics working. I put an entry in my grub file to do that. It's been running well the past 2 months so I thought it was time to get the nvidia driver installed.

    That was harder because I had to figure out how to sign the kernel module. I made a pair of keys and ran a command to import a key and I put the key password in the UEFI window that popped up when I was first booting my computer.

    I thought my keys were all set so I ran the .run installer from the Nvidia web site. The installer asked for both my public and my private key.

    It finished without any errors so I thought the module was both installed and signed.

    When I try to turn on the module, I get this error:

    [root@localhost ~]# modprobe nvidia-drm
    modprobe: ERROR: could not insert 'nvidia_drm': Required key not available


    When I try to import my public key again, it tells me it's already imported:

    [root@localhost ~]# mokutil --import pubkey.der
    SKIP: pubkey.der is already enrolled


    I kind of understand the two key system. It works like PGP email. There's a public key and a private key and one signs my module and the other opens it once it's been signed.

    I tried running the nvidia run file again but now it doesn't ask for my keys to sign the module. I don't know how to manually sign it. I tried digging around in /usr/src/kernels but the modules aren't built there. I'm not sure how to find the compiled module to re-sign it.

    So now I'm stuck...what part did I mess up and how do I fix it? I tried looking for answers but most suggest turning off secure boot in the bios which breaks my windows 10 install.

    Note: Edited to try to make what I did and the question more clear.
    Last edited by SunshineSue; 7th December 2017 at 04:11 PM.

Similar Threads

  1. Can't switch user after installing nvidia drivers
    By radome in forum F21 Development Forum
    Replies: 1
    Last Post: 8th December 2014, 02:39 PM
  2. Replies: 3
    Last Post: 12th March 2010, 08:12 AM
  3. Nvidia native drivers or livna drivers
    By ramy.m in forum Hardware & Laptops
    Replies: 8
    Last Post: 19th June 2007, 08:30 PM
  4. Installing Nvidia Drivers: No Nvidia Graphics Driver Found!
    By unholy1 in forum Hardware & Laptops
    Replies: 9
    Last Post: 6th April 2005, 08:50 PM
  5. Help configuring NVIDIA drivers and Touchpad drivers
    By vikramjogi in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 11th November 2004, 07:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •