FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2017
    Location
    United Kingdom
    Posts
    3

    Unable to mount SMB shares after system-upgrade to F27 from F26.

    Hi.

    Since performaing a dnf system-upgrade to F27 (from F26) I'm unable to mount SMB shares, either using the Gnome File app or the gio mount command. E.g:

    gio mount smb://hostname/sharename/

    I'm prompted for User/Domain/Password but then the mount fails with an error :

    gio: smb://hostname/sharename: Failed to mount Windows share: Function not implemented

    I'm able to connect and browse the share using the same credentials and smbclient. And, after referting to a VM snapshot taken prior to the system-upgrade, I'm able to mount the share under F26.

    I haven't been able to find anything in the user or system journal and I can't really work out if it's a Samba client, GIO/GVFS or some other issue.

    Any help appreciated.

    Thanks in advance.

    Chris.

  2. #2
    Join Date
    Jun 2011
    Location
    Italy
    Posts
    395

    Re: Unable to mount SMB shares after system-upgrade to F27 from F26.

    Same problem here. Before the upgrade it used to work perfectly.

  3. #3
    Join Date
    Mar 2006
    Posts
    674

    Re: Unable to mount SMB shares after system-upgrade to F27 from F26.

    Try adding -o vers=1.0 to the end of your command line if your server is older samba version.

    gio mount smb://hostname/sharename/ -o vers=1.0

    If the server is newer try 2.0.

    I saw your thread and hadn't tested my mount since also upgrading to F27, and I could not mount my shares. So I searched the error message I was getting and found that Samba 4.0 servers now require mount requests using SMBV2.0 so newer clients on the upgraded machines are only useing that protocol.

    Hope this helps.
    jbkt23

  4. #4
    Join Date
    Dec 2017
    Location
    United Kingdom
    Posts
    3

    Re: Unable to mount SMB shares after system-upgrade to F27 from F26.

    Thanks for the reply jbkt23.

    It does look to be a SMB protocol version problem, I'm able to mount the share using:

    mount -t cifs //hostname/sharename /mnt -o user=user,password=password -o vers=1.0

    It's a share on a NetApp filer that, I'm guessing, hasn't been updated for a while. Now I just have to work out how to tell 'gio mount' to use a specific SMB protocol version.

    Cheers.

  5. #5
    Join Date
    Dec 2017
    Location
    United Kingdom
    Posts
    3

    Re: Unable to mount SMB shares after system-upgrade to F27 from F26.

    I've managed to work around the 'gio mount' issued by adding the following to [global] section of /etc/samba/smb.conf:

    client max protocol = NT1

    Setting the 'client min protocol' paramter doesn't seem to help, only restricting the max worked for me.

    This is probably not going to work for anyone looking to mount protocol version 2 or 3 shares as well as earlier versions. For those people maybe keep an eye on this bug report : https://bugzilla.redhat.com/show_bug.cgi?id=1474539

Similar Threads

  1. Replies: 0
    Last Post: 10th January 2012, 05:02 PM
  2. Replies: 5
    Last Post: 9th August 2011, 07:38 PM
  3. Upgrade to fedora 12 failed: VFS: unable to mount root fs
    By d0cd0c in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 21st November 2009, 12:16 AM
  4. Upgrade F9 => F10 : Unable to mount /dev/dev/VolGroup00/LogVol00
    By Grui in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 4th December 2008, 12:44 PM
  5. Kernel Unable to mount file system, once AHCI disabled
    By deathhex in forum Using Fedora
    Replies: 2
    Last Post: 16th February 2008, 01:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •