FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2004
    Location
    Odense, Denmark
    Age
    35
    Posts
    592

    Red face Running GNOME 3 on a 4k monitor

    4k monitors on Linux isn't exactly perfect. Out of the box, its pretty awful actually. Most of the guides I've found haven't helped a whole lot, but thankfully, GNOME 3 still has some old GNOME 2 code (I assume) around that actually deals with odd stuff like DPI (bah!).

    If you're running GNOME 3, make sure you're running it under X, not wayland. Once you've logged in, you can get a lot of the stuff to look right by simply executing xrandr --dpi 1 (or any other integer -- it won't matter what you pick). This will fix a lot of issues on its own. No need to mess around with text scaling or any of that stuff. This will also fix a lot of non-gnome stuff, like Eclipse; not perfect, but pretty close.

    You should also run 'gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gdk/WindowScalingFactor': <2>}"', to make some UI elements scale nicer (not X dependent).

    I'm sure there's some trick to get GNOME 3 to do the same under wayland, but I don't know what it is.

    Enjoy a beautiful desktop with crisp, clean text.
    I am not a lawyer.
    Fedora: Intel Core i7-4790 @ 4x3.6 GHz

  2. #2
    Join Date
    Nov 2017
    Location
    Havant
    Posts
    100

    Re: Running GNOME 3 on a 4k monitor

    Quote Originally Posted by clearer
    4k monitors on Linux isn't exactly perfect. Out of the box, its pretty awful actually. Most of the guides I've found haven't helped a whole lot, but thankfully, GNOME 3 still has some old GNOME 2 code (I assume) around that actually deals with odd stuff like DPI (bah!).

    You should also run 'gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gdk/WindowScalingFactor': <2>}"', to make some UI elements scale nicer (not X dependent).

    What wrong with using?

    Code:
    gsettings set org.gnome.desktop.interface scaling-factor 2
    0 = automatic (does **** all here)
    1 = normal
    2 = double

    Code:
    System:    Host: localhost Kernel: 4.15.0-0.rc0.git7.2.fc28.x86_64 x86_64 bits: 64 Desktop: Cinnamon 3.6.6
               Distro: Fedora release 28 (Rawhide)
    Graphics:  Card: NVIDIA GK106 [GeForce GTX 660]
               Display Server: x11 (X.org 119.5 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
               Resolution: 3840x2160@60.00hz
               OpenGL: renderer: GeForce GTX 660/PCIe/SSE2 version: 4.6.0 NVIDIA 387.34
    Double works well in cinnamon as I don't bother with obsolete gtk2 apps.
    https://src.fedoraproject.org/user/leigh123linux
    https://github.com/leigh123linux
    https://admin.rpmfusion.org/pkgdb/packager/leigh123linux/

  3. #3
    Join Date
    Jan 2010
    Location
    behind that screen...
    Posts
    941

    Re: Running GNOME 3 on a 4k monitor

    What's wrong with just letting Gnome select the DPI on it's own... I haven't experienced any issues.

  4. #4
    Join Date
    Sep 2004
    Location
    Odense, Denmark
    Age
    35
    Posts
    592

    Re: Running GNOME 3 on a 4k monitor

    Obviously, it didn't do what it's supposed to do on my setup.

    Scaling the UI elements scales UI elements, but not text, meaning you'll have tiny text. I noticed that when I ran xrandr --dpi 1 (or 2, 200, 5000) all of the text popped into a nice legible size.
    I am not a lawyer.
    Fedora: Intel Core i7-4790 @ 4x3.6 GHz

  5. #5
    Join Date
    Nov 2017
    Location
    USA
    Posts
    20

    Re: Running GNOME 3 on a 4k monitor

    gnome-tweak-tool has a lot of nice DPI stuff

    to check/set your GNOME dpi via cmdline:
    Code:
    $ gsettings list-recursively org.gnome.desktop.interface
    
    or
    
    $ gsettings set org.gnome.desktop.interface scaling-factor 1
    $ gsettings set org.gnome.desktop.interface text-scaling-factor 1

    if you want to change your GDM dpi:
    Code:
    $ sudo su - gdm -s /bin/sh -c 'export `dbus-launch`; gsettings set org.gnome.desktop.interface scaling-factor 1; kill $DBUS_SESSION_BUS_PID'

    or to check gdm settings:
    Code:
    $ sudo su - gdm -s /bin/sh -c 'gsettings list-recursively org.gnome.desktop.interface'
    Last edited by kabeero; 4th December 2017 at 06:43 AM.

Similar Threads

  1. Replies: 2
    Last Post: 20th July 2015, 10:45 PM
  2. [SOLVED] How to get external monitor running
    By Doug Hutcheson in forum Hardware & Laptops
    Replies: 2
    Last Post: 23rd June 2012, 05:51 AM
  3. Running without KB,Mouse,Monitor
    By griffinmt in forum Using Fedora
    Replies: 0
    Last Post: 17th November 2011, 11:16 PM
  4. KDE4 not running in second monitor? (Dual monitor problem)
    By thylacine222 in forum Using Fedora
    Replies: 1
    Last Post: 27th December 2008, 05:30 PM
  5. running dual head monitor
    By snazyevey in forum Using Fedora
    Replies: 7
    Last Post: 12th May 2008, 09:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •