FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2017
    Location
    Germany
    Posts
    5

    F27 dnf not working with authenticating proxies

    I freshly installed F27 into a virtualbox guest.
    Installation process work well so far (from installation media).

    Now I want to update the distribution using dnf/yum.
    As I'm behind a corporate authenticating proxy I edited

    Code:
    /etc/dnf/dnf.conf
    
    [main]
    proxy=http://<fqd_proxy_host>:3128
    proxy_user=<my_username>
    proxy_password=<my_password>
    I get "407 from proxy after CONNECT".



    Is there something I'm missing?

    Thanks
    syracus






    Click image for larger version. 

Name:	ss_proxy.JPG 
Views:	9 
Size:	85.5 KB 
ID:	29219

  2. #2
    Join Date
    Nov 2017
    Location
    Germany
    Posts
    5

    Re: F27 dnf not working with authenticating proxies

    OK, found that this is still an existing bug reported since F25+.
    https://bugzilla.redhat.com/show_bug.cgi?id=1387622

    Seems this is related to dnf not supporting NTLM proxy auth protocol.
    This also contains a working solution by editing the dnf/repo.py file.

  3. #3
    Join Date
    Mar 2007
    Posts
    85

    Re: F27 dnf not working with authenticating proxies

    You can use also cntlm service. It is simple and powerful.

Similar Threads

  1. bloc proxies !
    By hermouche in forum Security and Privacy
    Replies: 15
    Last Post: 22nd October 2011, 11:13 AM
  2. [SOLVED] Yet another post about yum and proxies
    By paulj_j in forum Using Fedora
    Replies: 1
    Last Post: 13th May 2010, 11:59 AM
  3. proxies
    By iamroot in forum Wibble
    Replies: 5
    Last Post: 23rd November 2005, 11:31 PM
  4. setting proxies
    By creative in forum Using Fedora
    Replies: 0
    Last Post: 2nd December 2004, 05:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •