FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Oct 2017
    Location
    San Diego
    Posts
    2

    How to Opt-Out of NetworkManager for USB NICs

    Hi

    My system has two built-in NICs. I am able to control which is controlled by Network Manager using the
    NM_CONTROLLED="no"
    setting inside the "ifcfg" file for the NIC in the /etc/sysconfig/network-scripts directory.

    What I want to solve is being able to also set NM_CONTROLLED="no" for a connected USB NIC.

    Can I do this without turning off Network Manager on the system?

    For example it is still nice to have Network Manager for the built-in wireless.

    Also curious, why doesn't the USB NIC show up in the /dev like a USB to serial adapter does?

    I found some files related to the USB NIC, but don't think this is going to help me:

    [root@fzxc0 dev]# updatedb
    [root@fzxc0 dev]# locate enp0s21f0u5
    /var/lib/NetworkManager/dhclient-2a4fa2b2-7091-31ca-a4fa-34985afd4aec-enp0s21f0u5.lease
    /var/lib/NetworkManager/dhclient-enp0s21f0u5.conf
    [root@fzxc0 dev]# ip link
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 00:01:2e:78:9c:2c brd ff:ff:ff:ff:ff:ff
    3: enp3s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:01:2e:78:9c:2d brd ff:ff:ff:ff:ff:ff
    4: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether 70:1c:e7:05:a0:ff brd ff:ff:ff:ff:ff:ff
    5: enp0s21f0u5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 8c:ae:4c:fd:a7:bd brd ff:ff:ff:ff:ff:ff
    [root@fzxc0 dev]# more /var/lib/NetworkManager/dhclient-enp0s21f0u5.conf
    # Created by NetworkManager

    send host-name "fzxc0"; # added by NetworkManager

    option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;
    option ms-classless-static-routes code 249 = array of unsigned integer 8;
    option wpad code 252 = string;

    also request rfc3442-classless-static-routes;
    also request ms-classless-static-routes;
    also request static-routes;
    also request wpad;
    also request ntp-servers;

    [root@fzxc0 dev]#

    Thanks!
    Greg

  2. #2
    Join Date
    Oct 2017
    Location
    San Diego
    Posts
    2

    Re: How to Opt-Out of NetworkManager for USB NICs

    Hi Guys,

    Was hoping someone might share me some insight/exerience into how USB NICs are handled in linux/fedora and how I might control their use or not use by Network manager.

    No responses?

    Maybe this is where I need to start?
    http://www.linux-usb.org/usbnet/

    Thanks,
    Greg

Similar Threads

  1. multiple nics
    By Kingtu in forum Servers & Networking
    Replies: 7
    Last Post: 3rd February 2012, 01:57 AM
  2. Use 2 NICs
    By brenden1096 in forum Servers & Networking
    Replies: 1
    Last Post: 17th August 2011, 06:24 PM
  3. 2 nics
    By vonedaddy in forum Servers & Networking
    Replies: 12
    Last Post: 6th January 2008, 12:06 AM
  4. NetworkManager / NetworkManager Display Problem
    By Malachai in forum Hardware & Laptops
    Replies: 0
    Last Post: 25th December 2007, 11:52 PM
  5. Two NICs ?
    By Xavior in forum Servers & Networking
    Replies: 1
    Last Post: 30th November 2006, 05:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •