FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Aug 2017
    Location
    Earth
    Posts
    11

    Terrible QoS... Searching for updates blocks the Internet for a long time every day.

    I set Fedora up to do updates once a day. The problem is that when it starts searching for updates in the background (without a warning or anything), my Internet becomes completely unusable for a long time. It's not just that it's really slow during that time, I actually have trouble sending receiving any packets at all while the update search happens.

    But the issue is not just with updates. Actually when I have a download running in Firefox, I can't update anymore and get issues like:

    Code:
    Error: Error downloading packages:
      Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f26&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]
    Also, I can't browse the Internet anymore during that time, not even in the same browser.

    All this just didn't happen when I used Windows 8 and not Fedora.

    I assume this is because Windows has some sort of QoS packet prioritization built-in which Fedora lacks, at least by default.

    Is there a way to get proper QoS, so that I can use my whole bandwidth, but do multiple things at a time properly?
    If not, is there a way to limit the update download speeds?

    My Internet is pretty slow btw. Around 450KiB/s.
    Also, I have a pfSense router. I think it can do packet prioritization, but I have no clue what I would have to change in order to do downloads/updates and browsing, streaming videos etc at the same time.

  2. #2
    Join Date
    Oct 2011
    Posts
    1,630

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    QoS filters out traffic based on ports. Traffic that you want to filter uses the same http port. While in theory it could be possible to filter such traffic if sniffing it, there is no way to filter https since it is encrypted. It is possible however to limit the bandwidth for dnf, to lets say 200kb/s, should leave plenty of bandwidth for browsing. I think this option works for dnf-makecache service as well.

    /etc/dnf/dnf.conf
    Code:
    throttle=200k
    Don't forget to disable Gnome Software.

    Code:
    $ gsettings set org.gnome.software download-updates false

  3. #3
    Join Date
    Jun 2004
    Location
    Laurel, MD USA
    Posts
    7,174

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    Some other tips:

    if you don't use IPv6, then

    1) in your desktop network widget set ipv6 to "ignored" or "disabled"

    2) in /etc/dnf/dnf.conf set:

    ip_resolve=4

    3) in Firefox's "about:config" page set:

    network.dns.disableIPv6 true

    These together will help Fedora, dnf, and Firefox not waste time on ipv6 connections that don't work.

  4. #4
    Join Date
    Aug 2017
    Location
    Earth
    Posts
    11

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    I should mention, I'm using KDE, not Gnome.
    I disabled IPv6 and set the throttle as suggested.

    So I will at least be able to browse the Internet while the system checks for new updates or downloads them.

    But there is still the problem, that while I have an active file download in Firefox, dnf fails and I can't browse the Internet.

  5. #5
    Join Date
    Oct 2007
    Location
    Freedonia
    Age
    68
    Posts
    3,037

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    I don't know how to solve your issue, but I do know how to get rid of it: don't allow your system to check for updates and/or download them automatically. If this is a home machine, have dnf update your system while you're getting dressed, eating dinner or otherwise not using the computer. If it's a work box, and you control it, have it update while you're getting lunch or otherwise engaged away from your desk, such as in a meeting. That way, you never even see this issue, and it's no longer a problem for you.
    Registered Linux user #470359 and permanently recovered BOFH.

    Any advice in this post is worth exactly what you paid for it.

  6. #6
    Join Date
    Aug 2017
    Location
    Earth
    Posts
    11

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    I just installed updates and it's still pretty terrible. I was able to browse the Internet without constantly getting "Server not found" errors, but it was extremely slow. A simple Google search took almost 30 seconds even though the updates didn't use the full bandwidth. ... The problem is that the updates now take twice as long because of the throttle. So it's 60 minutes of barely usable Internet vs 30 minutes no Internet. Not really an improvement imo.

    Also, when I started a download in Firefox in the middle of the update process, dnf failed again.

    @sidebrnz
    The problem is that I keep forgetting it, if it doesn't happen automatically and I can almost never find a time where I can really say that I won't need the Internet for the next 30 minutes.

  7. #7
    Join Date
    Nov 2015
    Location
    Gothenburg, Sweden
    Posts
    36

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    Not sure if any of these are applicable to your situation but these are some of the things that's happened to me over the years that has resulted in a similar experience (not limited to dnf though).

    * ISP problems (DNS and connection drops etc). I started monitoring and could provide more accurate stats than they had. Seemed to help after a while.
    * Modem problem (on either side) - have the ISP measure the quality (they can do it remotely).
    * A router reached max number of connections (when the kids started with torrents). QoS settings in the router helped for awhile but in the end I bought a newer router.
    * A misconfigured webserver opened my server up as an open proxy. Had half China using my ADSL line to watch funny Youtube videos.

    Br,
    Ted
    Last edited by Ted Lyngmo; 13th October 2017 at 08:32 AM. Reason: typo

  8. #8
    Join Date
    Aug 2017
    Location
    Earth
    Posts
    11

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    But as I said, I only experience this problem on Fedora. On Windows it worked just fine.

  9. #9
    Join Date
    Nov 2015
    Location
    Gothenburg, Sweden
    Posts
    36

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    Quote Originally Posted by forivin
    But as I said, I only experience this problem on Fedora. On Windows it worked just fine.
    I see - so you can run Windows without problems on another machine at the same time as dnf is running on your Linux box? If so, disregard my ideas :-)

    Br,
    Ted

  10. #10
    Join Date
    Jun 2004
    Location
    Laurel, MD USA
    Posts
    7,174

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    I ran Fedora on much slower DSL (3 Mbit) before I got FIOS at 150 Mbit, and it didn't have this QoS problem.

    One thing you might try is,

    1) set up the daily dnf updates for a time you're not using it like 3am (cron job or dnf-automatic)
    https://fedoraproject.org/wiki/AutoUpdates

    that won't be practical if it's a laptop or PC that's off at night

    2) do what I do, I disable periodic background updates of the metadata by setting
    Code:
    metadata_timer_sync = 0
    in /etc/dnf/dnf.conf

    then I just manually run dnf check-update occasionally. That way the dnf only runs when I run it.
    This way any bad network affects of dnf is mostly a moot issue. Sometimes I need to
    add --refresh to the command to force an update of package data.
    Last edited by marko; 17th October 2017 at 07:24 AM.

  11. #11
    Join Date
    Jan 2015
    Location
    Al Ain, UAE
    Posts
    736

    Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

    Hmm, the age old automatic screw-up debate...

    I seldom do updates (only when I have to install a new software package).

    Once a year at Christmas time when I feel bored, I completely re-install the system.
    --
    Have fun!
    http://www.aeronetworks.ca

Similar Threads

  1. Boot time very long after updates and kmods
    By George Ion in forum Using Fedora
    Replies: 22
    Last Post: 8th May 2017, 06:56 AM
  2. tar -czf taking long long time
    By shariqnitt in forum EOL (End Of Life) Versions
    Replies: 3
    Last Post: 31st January 2011, 01:17 PM
  3. having terrible time getting IP address for eth0
    By D_bot in forum Servers & Networking
    Replies: 5
    Last Post: 24th December 2009, 06:47 PM
  4. Long Time - No Updates
    By Trapper in forum Using Fedora
    Replies: 4
    Last Post: 5th September 2008, 06:03 PM
  5. Replies: 4
    Last Post: 12th November 2007, 01:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •