FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2017
    Location
    delhi
    Posts
    5

    Thumbs up fedora 17 failing to select mobilebroadband in Network manager

    iam trying to connect gemalto cinterion 3g module to internet through fedora 17, my 3g module enumerates fine and Network Manager able to display Mobile broadband services but iam not able to select it (turning off always)
    but i can still get the respones of AT commands through serial port of my module.

    how can i correct the modem manager to respond for 3g module can anyone please help me out...
    please find the attachment of logs

    regards,
    jagadeesh
    Attached Files Attached Files
    Last edited by jagadeesh123; 9th October 2017 at 12:45 PM. Reason: attachment of logs

  2. #2
    bob's Avatar
    bob is offline Administrator (yeah, back again)
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    72
    Posts
    23,359

    Re: fedora 17 failing to select mobilebroadband in Network manager

    moved to EOL
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  3. #3
    Join Date
    Oct 2017
    Location
    delhi
    Posts
    5

    Re: fedora 17 failing to select mobilebroadband in Network manager

    sorry, i didnt get you sir

  4. #4
    bob's Avatar
    bob is offline Administrator (yeah, back again)
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    72
    Posts
    23,359

    Re: fedora 17 failing to select mobilebroadband in Network manager

    F17 is an obsolete version of Fedora, so I moved the post over to "End Of Life" sub-Forum, where people who might still be using older versions will notice it. Frankly, you should consider upgrading to F26 if possible.
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  5. #5
    Join Date
    Oct 2017
    Location
    delhi
    Posts
    5

    Re: fedora 17 failing to select mobilebroadband in Network manager

    finally it was solved , in fedora modemmanager is not able to respond to to my 3g module so there way many ways to solve this either we can manually run a script or with using wvdial utility
    here i have used wvdial, and these are the steps i have fallowed

    sudo yum install pppd
    sudo yum install usb_modeswitch

    sudo gedit /etc/usb_modeswitch.conf

    #add these 5 lines containing vendor id and product id of our 3g module
    DefaultVendor = 0x1e2d
    DefaultProduct = 0x0058
    TargetVendor = 0x1e2d
    TargetProduct = 0x0058
    MessageEndpoint = 0x00

    #now run this usb_modeswitch

    sudo usb_modeswitch -C /etc/usb_modeswitch.conf

    (result will be as shown below)

    [administrator@administrator ~]$ sudo usb_modeswitch -c /etc/usb_modeswitch.conf
    [sudo] password for administrator:
    Looking for target devices ...
    found matching product ID
    adding device
    Found devices in target mode or class (1)
    Looking for default devices ...
    found matching product ID
    adding device
    Found device in default mode, class or configuration (1)
    Accessing device 008 on bus 001 ...
    Getting the current device configuration ...
    OK, got current device configuration (1)
    Using interface number 0
    Error: message endpoint not given or found. Aborting.



    #And then install wvdial

    sudo yum install wvdial

    #then run wvdialconf file so that it will update the configuratins of modem

    sudo wvdialconf
    # edit these configuration file
    sudo gedit /etc/wvdial.conf

    add parameters as per ISP
    (example mtnl service provider)

    [Dialer Defaults]
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    Modem Type = Analog Modem
    Phone = *99#
    ISDN = 0
    Password = mtnl123
    Username = mtnl
    Modem = /dev/ttyACM0
    Baud = 460800
    APN = mtnl.net
    use APN = 1
    obtain APN = 0
    Dial Command = ATDT


    #and then run wvdial

    sudo wvdial

    end result after wvdial will be as fallows

    [administrator@administrator ~]$ sudo wvdial
    [sudo] password for administrator:
    --> WvDial: Internet dialer version 1.61
    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATDT*99#
    --> Waiting for carrier.
    ATDT*99#
    CONNECT
    --> Carrier detected. Waiting for prompt.
    ~[7f]}#@!}!}!} }4}"}&} } } } }%}&[16]"J$}'}"}(}"*"~
    --> PPP negotiation detected.
    --> Starting pppd at Wed Oct 11 10:31:25 2017
    --> Pid of pppd: 1232
    --> pppd: 8[06]c[08]P[04]c[08]
    --> Using interface ppp0
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> local IP address 120.58.87.92
    --> pppd: 8[06]c[08]P[04]c[08]
    --> remote IP address 120.58.87.92
    --> pppd: 8[06]c[08]P[04]c[08]
    --> primary DNS address 10.160.231.116
    --> pppd: 8[06]c[08]P[04]c[08]
    --> secondary DNS address 10.160.231.124
    --> pppd: 8[06]c[08]P[04]c[08]
    --> pppd: 8[06]c[08]P[04]c[08]
    --> Script /etc/ppp/ip-up run successful
    --> Default route Ok.
    --> Nameserver (DNS) Ok.
    --> Connected... Press Ctrl-C to disconnect
    --> pppd: 8[06]c[08]P[04]c[08]


    then check ifconfig

    for any suggestions/queries please contact me jagadeesh067@gmail.com

  6. #6
    Join Date
    Aug 2011
    Location
    India
    Age
    32
    Posts
    401

    Re: fedora 17 failing to select mobilebroadband in Network manager

    As far as i know newer versions of fedora it is easier and possible from GUI via mobile manager.

  7. #7
    Join Date
    Oct 2017
    Location
    delhi
    Posts
    5

    Re: fedora 17 failing to select mobilebroadband in Network manager

    yes, in newer version of fedora its working fine.

Similar Threads

  1. fedora,realtek wireless network card and network manager
    By lodore in forum Servers & Networking
    Replies: 4
    Last Post: 5th January 2009, 01:39 AM
  2. system-config-network failing under Fedora 2.6.23.17-88.fc7
    By clivelong in forum Servers & Networking
    Replies: 1
    Last Post: 8th July 2008, 09:36 AM
  3. Setting Up wifi network using Network Manager in Fedora 9
    By techman2006 in forum Hardware & Laptops
    Replies: 16
    Last Post: 15th June 2008, 10:14 AM
  4. Fedora and Network Manager
    By RahulSundaram in forum News
    Replies: 0
    Last Post: 25th February 2008, 11:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •