F27 + nvidia driver + gnome
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 12 of 12
  1. #1
    Join Date
    May 2009
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    F27 + nvidia driver + gnome

    Hi,

    I'm actually use the negativo17 driver on fc27. (worked very well on fc26).

    I encounter an issue because at startup I have a "Oh no! Something has gone wrong" GDM on gnome 3.26.

    However, if I start with run level 3 and launch with a startx, gnome starts up like a charm...

    have you encountered the same problem?

    Thanks

  2. #2
    Join Date
    Dec 2009
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    I do not have same problem, but just a question: When you try to lgoin via GDM, did you specifically choose "Gnome with Xorg" (because I think default is to run it under Wayland)?

  3. #3
    Join Date
    May 2009
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    unfortunately i can't login via GDM. I have directly "oh no! something has gone wrong". Then i do alt + F2 , and my login and startx and it's ok...
    WaylandEnable=false is uncommented.
    Last edited by farika; 3rd October 2017 at 07:05 PM.

  4. #4
    Join Date
    Dec 2009
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    Hmm, I have really no idea. You may search for hints in Xorg log file ( ~/.local/share/xorg/Xorg.0.log ) or from journal (journalctl ...)

    I got new Nvidia driver update today, hopefully that fixes it for you.

    UPDATE: I installed the updates for me, and the gnome started failing for me... After digging something, I found following from /var/cache/akmods/nvidia/387.12-1-for-4.13.4-300.fc27.x86_64.failed.log :

    It is recommended to set the CC environment variable
    to the compiler that was used to compile the kernel.

    The compiler version check can be disabled by setting
    the IGNORE_CC_MISMATCH environment variable to "1".
    However, mixing compiler versions between the kernel
    and kernel modules can result in subtle bugs that are
    difficult to diagnose.

    *** Failed CC version check. Bailing out! ***
    I then manually build nvidia module with
    IGNORE_CC_MISMATCH=1 akmods --force

    rebooted my laptop, and everything is now again fine
    Last edited by GoingDown; 6th October 2017 at 06:52 AM.

  5. #5
    Join Date
    Mar 2006
    Location
    Silesia, Poland, EU
    Posts
    81
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    I had exactly the same problem after installing nvidia driver, first the gcc version mismatch (kernel 4.13.5 works now) and then the "Oops something went wrong".

    I fixed it with: ctrl+alt+f2
    login as root, then:
    ausearch -c 'gnome-session-c' --raw | audit2allow -M mygnomesession.c
    semodule -X 300 -i mygnomesession.c.pp
    then ctrl+alt+f1 and try logout, you should see GDM and login then
    this is clearly selinux policy problem blocking GDM from using nvidia proprietary driver

    but then another problem came out, after reboot i couldn't login with GDM anymore, it was freezing whole system after typing password so i ended up doing:
    dnf install lightdm lightdm-gtk
    systemctl disable gdm
    systemctl enable lightdm
    reboot

  6. #6
    Join Date
    May 2009
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    Same issue with 387 one. GDM can't start ("Oops something went wrong".), but i can do startx to start gnome.
    Last edited by farika; 7th October 2017 at 12:01 PM.

  7. #7
    Join Date
    Mar 2006
    Location
    Silesia, Poland, EU
    Posts
    81
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    yep, that message comes out because selinux blocks access to nvidia device for GDM, this should fix it:
    ausearch -c 'gnome-session-c' --raw | audit2allow -M mygnomesession.c
    semodule -X 300 -i mygnomesession.c.pp

  8. #8
    Join Date
    May 2009
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    Quote Originally Posted by beer_hunter
    yep, that message comes out because selinux blocks access to nvidia device for GDM, this should fix it:
    Working ! Negativo should fix this.

  9. #9
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,922
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    There are some problems with gnome-shell extension processing and F27.
    Bugzilla has at least the following


    BUG 1390198 crash on first login.
    BUG 1390198 Gnome Shell dies. Still open problem
    Bug 1458505 root logon system-tray users icon crashes system-tray
    BUG 1464294 btrfs solved -- false alarm.
    BUG 1469129 btrfs full lockup
    BUG 1496283 gnome bugzilla btrfs
    BUG 1499383 GnomeShell Crashing
    ~
    Coming soon, many updates to fix bugs, hopefully before go-live at End of Month
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  10. #10
    Join Date
    May 2009
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    Can anyone explain me what does exactly the selinux policy created with this command ?
    ausearch -c 'gnome-session-c' --raw | audit2allow -M mygnomesession.c
    semodule -X 300 -i mygnomesession.c.pp

    Simone Caronni from negativo ask me this for bug correction.

    Thanks

  11. #11
    Join Date
    Mar 2006
    Location
    Silesia, Poland, EU
    Posts
    81
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    It searches any logs for gnome-session-c and then creates allow rule for each denied operation.
    If you want to know what rules are being created run ausearch -c 'gnome-session-c' --raw | audit2allow -a

    remember that this command needs to be issued on a system where selinux policy wasnt modified

  12. #12
    Join Date
    May 2009
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F27 + nvidia driver + gnome

    Thanks i have this :
    #============= xdm_t ==============

    #!!!! This avc is allowed in the current policy
    allow xdm_t xserver_misc_device_t:chr_file map;


    When the bug will be fixed, how to remove this rule ?

Similar Threads

  1. Replies: 14
    Last Post: 3rd March 2013, 06:58 AM
  2. Gnome hangs with NVidia driver in F18
    By ghborrmann in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 29th January 2013, 05:49 PM
  3. Bug in gnome after install nvidia driver
    By brunobbn in forum Using Fedora
    Replies: 0
    Last Post: 6th January 2013, 08:43 PM
  4. [SOLVED]
    GNOME 3 Nvidia driver
    By Pitfall in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 10th November 2011, 07:46 PM
  5. Replies: 5
    Last Post: 26th June 2011, 10:23 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •