FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2016

    nemo, mpv and samba

    ever since i upgraded to fedora26 (fresh install from 25), mpv has not been able to stream via my smb share.

    initially it was the RPMFusion mpv version not being compiled, but since the release that had smb complied into the build, i'm still having issues.

    i'm using the cinnamon spin, so nemo for file manager. access to the smb share is done from within a network location from within nemo (rather than fstab). from here, i simply double click the media file.
    mpv plays local files fine. it will only play smb files via commandline. seemingly no action when you try to open it from nemo.

    vlc does work fine from nemo and the smb location, so seems something specific to nemo & mpv.

    since i went with a fresh install of fedora26, it's possible i've missed some package thats required for this to work.

    anyone have any idea what i've missed?

  2. #2
    Join Date
    Aug 2017

    Re: nemo, mpv and samba

    How do you mount the shared folders? Can you access the folder with terminal? What's the output when you try to open a file with mpv?

  3. #3
    Join Date
    Jun 2016

    Re: nemo, mpv and samba

    sorry for the delay - been hectic here over the last few weeks.

    mount method: via nemo > file > connect to server with the smb/windows share option. remember password is ticked.
    terminal: unauthenticated fails (as expected). using credentials works (smb://userass@server/share/file.avi)
    if i run mpv via terminal, unauthenticated, then it simply complains about credentials used - which is what you'd expect. I dont know of a way to see what mpv is doing under double-click scenarios via nemo...

    like i say, worked fine on FC25, but has never worked since FC26 fresh install. its possible something on the file server was updated at the same time, but client side was the only known change at the time.

Similar Threads

  1. Cinnamon Spin, Nemo, and gpg
    By jfucci in forum Fedora Spins & Remixes
    Replies: 2
    Last Post: 11th November 2015, 01:19 AM
  2. [SOLVED] Replace Nautilus with Nemo - F22 Workstation
    By antikythera in forum Using Fedora
    Replies: 1
    Last Post: 28th May 2015, 04:48 AM
  3. replace nautilus to nemo
    By jupiter2005 in forum Using Fedora
    Replies: 3
    Last Post: 23rd April 2014, 08:09 AM
  4. Compiling nemo-dropbox for Fedora 20
    By HMSS013 in forum Using Fedora
    Replies: 3
    Last Post: 18th January 2014, 04:24 AM
  5. nemo & cinnamon problem
    By strummer in forum Using Fedora
    Replies: 4
    Last Post: 2nd January 2014, 12:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts