Thanks to Wolfgang (raveit65) for packaging MATE for RHEL 7 and CentOS usage. RHEL was recently rebased to 7.4 and EPEL quite rightly followed that upstream schedule. CentOS 7.4 is a couple of weeks behind, should be finalised this week, so there was a slight issue with a presented lightdm update in yumex for my non-CR install requiring a newer build of glib2. Easily resolved by enabling CR repo for one transaction

Code:
yum --enablerepo=cr update glib2