FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2015
    Location
    -
    Posts
    4

    UEFI entries dissapeared from boot options

    I am dual-booting Windows 10 and Fedora 26, both using uefi.

    After I reset my bios/uefi however both previously available boot options, "windows boot manager" (which started windows) and Fedora (which started grub, allowing the choice between windows and fedora), disappeared from my mainboard's boot options. The drives themselves are still selectable, but selecting one gives me nothing but a black screen.

    A quick double-check with the live cd confirmed the data on hdds remains the same, the single efi partition contains a boot, a fedora and a windows folder.

    I needed fast access to my Windows system and tried the Windows repair option from the Windows installation cd. It said it didn't work, but it did. The Windows entry reappeared in my boot options and it starts up fine, got my work done, alas Fedora remains inaccessible.

    Here is how my partitions are set up, if it helps:
    Disk 0:
    Windows Recovery, EFI (created by windows, mounted as /boot/efi in fedora), Windows, Boot (mounted as /boot), Swap, Home (mounted as /home)
    Disk 1:
    root (mounted as /)

    UEFI is enabled in the mainboard, it does not support secure boot. Overall I have not even the slightest idea what is going on, I tried basically every single boot setting in the bios without success.

    I am sure I could just reinstall fedora, but I would be happy avoiding that as well as understanding what is going on. Thanks for your help.

    edit: I was able to recreate the missing entry with the help of the live-cd and efibootmgr
    Code:
    # efibootmgr --create --disk /dev/sdc2 --part 3 --label "Grub" --loader \\EFI\\Boot\\bootx64.efi
    did the trick for me.
    Last edited by Bittler; 7th September 2017 at 05:01 PM.

  2. #2
    Join Date
    Sep 2017
    Location
    Anchorage, Alaska
    Age
    42
    Posts
    10

    Re: UEFI entries dissapeared from boot options

    When you want to get into Fedora, maybe… Disable "UEFI", put your machine into "Legacy Mode"…

    And when you want to get back into Windows, reenable it?
    ASUS ROG G75VX 17.3" Notebook i7-3630QM 2.40Ghz
    SAMSUNG 850 EVO 2.5" 1TB SATA III, 5400 RPM 1TB HDD
    G.SKILL Ripjaws Series 24GB (3 x 8G) 204-Pin DDR3 SO-DIMM
    Nvidia GeForce GTX 670MX 3gb dedicated card
    LXDE,WINE,Dragon NaturallySpeaking 12.5

  3. #3
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,270

    Re: UEFI entries dissapeared from boot options

    no, don't start switching between UEFI and legacy mode it is not necessary and will cause further issues

Similar Threads

  1. Unable to Boot Fedora 19 Installation Media: UEFI + Secure Boot
    By Steinmeister in forum Installation, Upgrades and Live Media
    Replies: 9
    Last Post: 8th December 2013, 12:59 AM
  2. Install F19 in UEFI mode no F19 options
    By dashesy in forum Installation, Upgrades and Live Media
    Replies: 6
    Last Post: 25th August 2013, 02:36 AM
  3. OS boot entry not created in UEFI boot manager
    By iamlinux in forum EOL (End Of Life) Versions
    Replies: 2
    Last Post: 30th May 2013, 12:06 AM
  4. How to make grub on F17 (uefi w/ grub 1) boot windows 7 (uefi)?
    By premudriy in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 21st August 2012, 06:58 PM
  5. Replies: 1
    Last Post: 3rd July 2012, 06:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •