FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 22
  1. #1
    Join Date
    Apr 2017
    Location
    UK
    Posts
    2

    Question MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    Hi

    Since upgrading my F26 workstation to kernel 4.12 I see the following errors displayed during boot:

    Couldn't get size: 0x800000000000000e
    MODSIGN: Couldn't get UEFI db list
    Couldn't get size: 0x800000000000000e

    If I boot back into the 4.11 kernel then these errors disappear. The problem is reliably reproducible.

    In case this is secureboot related, I'm running on a Thinkpad X220 which does not have secureboot in the BIOS.

    Anyone got any idea what might cause this and how to fix?

    Thanks

  2. #2
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,274

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    if it wasn't you that reported this bug, sign up to it and add your feedback please.

    it's something to do with kernel signing keys by the looks of it. ignore the kdump references. later in the thread they are discussing the behaviour your system exhibits.

  3. #3
    Join Date
    Apr 2017
    Location
    UK
    Posts
    2

    Cool Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    Thanks I'll check it out. I've just updated another laptop which has secureboot enabled and I do not see the error either on the boot screen nor in dmesg with the 4.12 kernel.

    ---------- Post added at 12:00 PM ---------- Previous post was at 11:55 AM ----------

    ...and just updated a desktop which also has secureboot enabled and I DO see this issue. Alright, let's see what turns out from the bug report.

  4. #4
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,274

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    interesting, i'll check my own notebook's dmesg output. i don't recall seeing anything last night though.

    EDIT - no such error logged by dmesg with my Fujitsu LIFEBOOK A512. secureboot is enabled. I can't actually see messages during boot as I have encryption enabled which brings up a password prompt, boot from a reasonably fast USB 3 Sandisk Ultra Fit 64GB flash drive so the output disappears to fast to read.

  5. #5
    Join Date
    Aug 2017
    Location
    Odesa
    Posts
    1

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    Have same issue. But there is one more problem. This update maybe broke graphics. Sometimes i see graphic artifacts in GTK3 applications, in Wine hardware cursor stopped working. Now when the mouse moves, the game slows down. In 4.11 kernel all works fine, but in 4.12 not. Please, help me to fix...

  6. #6
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    5,274

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    please open a separate thread for your GPU issue and include the following information:
    -GPU make and model
    -GTK3 applications affected
    -Game affected
    -Mouse make and model

  7. #7
    Join Date
    Aug 2017
    Location
    Germany
    Posts
    2

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    Same problem here, not sure if it is related to this issue. I get the same message "MODSIGN: Couldn't get UEFI db list" and when I login I get a black screen with the mouse cursor moving, but nothing ever happens. Using propietary nvidia drivers version 375.66.

    With Kernel 4.11 everything works just fine. Good thing I can switch with grub.

  8. #8
    Join Date
    Aug 2017
    Location
    Germany
    Posts
    2

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    Quote Originally Posted by gerstrong
    Same problem here, not sure if it is related to this issue. I get the same message "MODSIGN: Couldn't get UEFI db list" and when I login I get a black screen with the mouse cursor moving, but nothing ever happens. Using propietary nvidia drivers version 375.66.

    With Kernel 4.11 everything works just fine. Good thing I can switch with grub.
    I have to take it back. After reinstalling the akmod package (remove and then install) it started everything is fine with the graphics. I still get that MODSIGN message though.

  9. #9
    Join Date
    Oct 2015
    Location
    Sheffield UK
    Posts
    85

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    Also started getting this message recently, I've even updated my boards bios to the latest version which was only released a month ago - still getting this message though.

  10. #10
    Join Date
    Dec 2011
    Posts
    57
    Same error here (modsign that is). No real issues with f26 though

    Sent from my ONE E1003 using Tapatalk

  11. #11
    Join Date
    Sep 2009
    Posts
    2,120

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    Same issue on fc25 once 4.12 kernels landed. I added to the bug Anti linked.

    dd_wizard

  12. #12
    Join Date
    Oct 2015
    Location
    Sheffield UK
    Posts
    85

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    Don't know if it's related but I've been experiencing lockups since 4.12 landed, not kernel panic complete lockups.

  13. #13
    Join Date
    Oct 2016
    Location
    Texas
    Posts
    3

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    I've had the same issue for the current and previous kernel. I do not have Secure Boot enabled in my BIOS, as I am running unsigned kernel modules. I've tried rebuilding the initramfs/initrd with 'dracut' and it still occurs.

  14. #14
    Join Date
    Jun 2014
    Location
    Colorado
    Posts
    58

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    I'm getting the same issue. I recently freshly installed f26 on my desktop and did a dnf update after the install. Now often, maybe every boot, I get the error "couldn't get size ; modsign: couldn't get UEFI db list ; couldn't get size". Often the system hangs. Have to reboot several times before it eventually correctly boots. I do have the output of journalctl.

    I've got nvidia drivers installed using the instructions from https://rpmfusion.org/Howto/NVIDIA. I think I've got a GForce 760, or something like that.

    Thanks,
    Nick

  15. #15
    Join Date
    Apr 2016
    Location
    Kota Tinggi, Johor, Malaysia
    Age
    21
    Posts
    163

    Re: MODSIGN: Couldn't get UEFI db list after 4.12 upgrade

    really doubt it got to do with nvidia drivers...

    a pure liveboot from usb and you can get this as well...

    something must have changed in whatever the process to the kernel...
    Laptop Specs
    https://forums.fedoraforum.org/showpost.php?p=1760122&postcount=528

Page 1 of 2 1 2 LastLast

Similar Threads

  1. GRUB failure after Apper F22 kernel upgrade, dual boot Win8 UEFI
    By itpwrusr in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 7th March 2016, 09:55 PM
  2. Install non-UEFI onto existing UEFI?
    By BuckleSwasher in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 13th October 2015, 10:13 AM
  3. How to make grub on F17 (uefi w/ grub 1) boot windows 7 (uefi)?
    By premudriy in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 21st August 2012, 06:58 PM
  4. Replies: 1
    Last Post: 3rd July 2012, 06:59 PM
  5. Why patch modsign disappeared ?
    By Jeremy38 in forum Security and Privacy
    Replies: 0
    Last Post: 11th September 2009, 09:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •