Using Fedora 26.
When I switch on my laptop runs very slowly for a while until a pop-up called "dnfdragora" tells me I have "x" updates available. I want to stop this.
I live remotely, so I'm forced to use satellite internet. The cost is 70 for 50Gb download per month; 10 per Gb after the allowance is exceeded. Aside from the inconvenience, this "service" is potentially going to cost significant cash by downloading data to update a cache that I don't need. Internet use is unmetered from 11:00pm to 7:00am so all I need do is input "DNF Upgrade" between those times.

I've spent several hours on trying to understand how to stop this service and so far drawn a blank...

Nothing appears in the system tray when this is running.

DNF-automatic isn't installed.

These timers running:
systemctl list-timers --all
mlocate-updatedb.timer
unbound-anchor.timer
systemd-tmpfiles-clean.timer

These DNF Services...
systemctl list-unit-files
dnf-makecache.service: static
dnf-system-upgrade.service: disabled
dnfdaemon.service: static

Dnf.conf...
[main]
gpgcheck=1
installonly_limit=3
clean_requirements_on_remove=True
metadata_timer_sync=0

Can anyone help with this?

Why on earth is this "enabled" by default anyway? (rhetorical)