FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2017
    Location
    Turkey
    Posts
    7

    GUI login problem - GNOME lightdm

    Hi all,

    I am new to gnu-linux environment so i would be grateful if you guys would help me

    I use GNOME desktop (Fedora 25 workstation). Recently i had to change my desktop manager from gdm to lightdm with following commands : sudo dnf install lightdm lightdm-gtk, sudo systemctl disable gdm.service, sudo systemctl enable lightdm.service

    After reboot, system hangs after login to gnome shell. i can see my gnome desktop(only wallpaper appears), mouse is displayed and i am able to move the mouse.But i can not click on anything and ctrl alt f() doesn't work.

    However before gui login, ctrl alt f() works and If i use terminal login then gui login everything works fine but i would like to login with 1 try while using gui

    Best regards,

    -Emre
    Last edited by deuemre; 10th August 2017 at 09:58 AM. Reason: typo

  2. #2
    Join Date
    Jun 2007
    Location
    Lytham St Annes, Lancashire, UK
    Posts
    687

    Re: GUI login problem - GNOME lightdm

    What display manager is Systemd trying to start by default at bootup? Mine is configured as follows
    Code:
    ls -l /etc/systemd/system/display-manager.service 
    lrwxrwxrwx. 1 root root 39 Jul 11 18:03 /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/lightdm.service
    If your link still points to gdm.service, Systemd will be trying to start GDM as well as LightDM on boot.

    If this is the case, the easiest way to fix this is to manually replace the link (as root user), pointing it to the lightdm.service file. (Don't type the leading '#' - this just represents the root user command prompt.)
    Code:
    # rm -f /etc/systemd/system/display-manager.service
    # ln -s /usr/lib/systemd/system/lightdm.service /etc/systemd/system/display-manager.service
    # ls -l /etc/systemd/system/display-manager.service 
    lrwxrwxrwx. 1 root root 39 Aug 10 17:48 /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/lightdm.service

  3. #3
    Join Date
    Aug 2017
    Location
    Turkey
    Posts
    7

    Re: GUI login problem - GNOME lightdm

    Hi Steve,

    I have got the same configuration

    Code:
    /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/lightdm.service
    I guess this is not the case.

  4. #4
    Join Date
    Aug 2017
    Location
    Turkey
    Posts
    7

    Re: GUI login problem - GNOME lightdm

    Hey all,

    Apparently nouveau causes the problem (i use nvidia gtx 960m).

    I added
    Code:
    nouveau.modeset=0
    as a kernel parameter and everything works fine now.

    Best regards,

    -Emre

Similar Threads

  1. How can I change the login screen resolution: lightdm
    By mobsta in forum Fedora Spins & Remixes
    Replies: 2
    Last Post: 2nd March 2014, 07:07 AM
  2. F18 lightdm login banner user list suppress
    By bbmfedora in forum Using Fedora
    Replies: 17
    Last Post: 22nd February 2014, 11:05 PM
  3. Problem with gnome/login
    By Tobb1 in forum Using Fedora
    Replies: 0
    Last Post: 26th January 2010, 07:35 PM
  4. Gnome Login Problem
    By LinuxLuvr in forum Using Fedora
    Replies: 5
    Last Post: 13th December 2009, 07:24 AM
  5. Problem with Gnome login themes
    By GRMrGecko in forum Using Fedora
    Replies: 1
    Last Post: 25th January 2008, 01:17 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •