[SOLVED] H.264 Support (for Vivaldi?)
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    496

    H.264 Support (for Vivaldi?)

    I've been using the Vivaldi browser for two months, and am fairly impressed. But I have one unresolved issue: some videos play in Firefox, but not in Vivaldi. (see https://www.youtube.com/watch?v=hNDYhANgWcQ for an example (and plz disregard the content)).

    In Vivaldi, I get the message indicating my browser does not support "any" of the available video formats, and on clicking the link there about HTML5 video, Youtube sends me to a page that indicates H.264 is not supported. Further down the page, I see the statement
    H.264 playback depends on hardware and operating system support.
    I used FEDY to installed the codecs, and, like I said, Firefox plays the video just fine, so it seems Fedora and my Dell laptop support it. The Vivaldi community site says that H.264 support was implemented months (yea and verily, YEARS) ago.

    I'm not sure where the problem is here, so I'm asking if anyone else has seen and resolved this issue. Is there a setting or extension I'm missing in Vivaldi? Is there a magic codec for H.264? Has my browser been taken over by evil spirits???
    Thanks.

  2. #2
    Join Date
    Jun 2005
    Location
    UK
    Posts
    4,426

    Re: H.264 Support (for Vivaldi?)

    It's not just Fedora/Vivaldi where that problem arises. Mageia/Vivaldi and OpenSuse/Vivaldi exhibit the same behaviour.

  3. #3
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,594

    Re: H.264 Support (for Vivaldi?)

    Quote Originally Posted by jbuckley2004
    I've been using the Vivaldi browser for two months, and am fairly impressed. But I have one unresolved issue: some videos play in Firefox, but not in Vivaldi. (see https://www.youtube.com/watch?v=hNDYhANgWcQ for an example (and plz disregard the content)).

    In Vivaldi, I get the message indicating my browser does not support "any" of the available video formats, and on clicking the link there about HTML5 video, Youtube sends me to a page that indicates H.264 is not supported. Further down the page, I see the statement

    I used FEDY to installed the codecs, and, like I said, Firefox plays the video just fine, so it seems Fedora and my Dell laptop support it. The Vivaldi community site says that H.264 support was implemented months (yea and verily, YEARS) ago.

    I'm not sure where the problem is here, so I'm asking if anyone else has seen and resolved this issue. Is there a setting or extension I'm missing in Vivaldi? Is there a magic codec for H.264? Has my browser been taken over by evil spirits???
    Thanks.
    you could try chromium-libs-media-freeworld from russian fedora's fixes repository. I don't know for sure it would work but it does contain the missing codec and vivaldi is built from chromium code.

  4. #4
    Join Date
    Oct 2017
    Location
    Australia
    Posts
    1

    Re: H.264 Support (for Vivaldi?)

    After trying a few different methods suggested within various guides/posts without much success, I got H.264 working (https://www.youtube.com/html5 with six blue ticks) in Vivaldi 1.12.955.42 on Fedora 26.

    I ended up going for the pinch libffmpeg.so technique - in this instance, from a Manjaro i3 virtualbox installation (after installing it from the herecura unofficial repository).

  5. #5
    Join Date
    Dec 2008
    Location
    Maryland
    Posts
    496

    Re: H.264 Support (for Vivaldi?)

    Wow! I had forgotten about this. The problem was resolved quite some time ago (you may want to see the short discussion on in Vivaldi forums here ->https://forum.vivaldi.net/topic/1989...with-vivaldi/2 ).

    In essence, instructions to install the correct video codecs can be found at
    https://gist.github.com/ruario/bec42d156d30affef655 at
    https://gist.github.com/ruario/3c873...14bd4d29fe37f1

    Since the browser has been working for me since, I'll mark this "solved".

  6. #6
    Join Date
    Jul 2018
    Location
    Slovakia
    Posts
    1
    Linux Chrome 65.0.3325.183

    Re: H.264 Support (for Vivaldi?)

    My way to solve this problem on FEDORA 27 was:
    1/ install chromium-freeworld-libs-media
    dnf install chromium-freeworld-libs-media
    2/ copy new ffmpeg library in vivialdi directory
    rpm -ql chromium-freeworld-libs-media
    /usr/lib64/chromium/libffmpeg.so
    cp /usr/lib64/chromium/libffmpeg.so /opt/vivaldi/lib/
    3/ after any vivaldi upgrade STEP#2 should be done again
    Last edited by thebeno; 8th July 2018 at 09:54 AM.

Similar Threads

  1. installing flash for Vivaldi browser
    By vinoman in forum Using Fedora
    Replies: 1
    Last Post: 11th April 2017, 03:55 AM
  2. Bye bye Opera, hello Vivaldi
    By lsatenstein in forum Wibble
    Replies: 3
    Last Post: 29th January 2015, 01:16 AM
  3. FC3 & Sony DRU-530A support & Canon Photo iP8500 support
    By BMillikan in forum Hardware & Laptops
    Replies: 6
    Last Post: 14th April 2006, 05:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •