FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2017
    Location
    Home
    Posts
    2

    [SOLVED] F25 - NTFS Partition not mounting in read/write

    Hi,

    I have an NTFS partition that i want mounted automatically and in read/write, i tried many options but without success so i'm turning to you guys

    Here is my fstab:

    ( /dev/sda4 is the concerned partition )

    Code:
    #
    # /etc/fstab
    # Created by anaconda on Tue Jun 13 19:33:27 2017
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    UUID=631253ab-cf94-493d-9a4f-606e2c29f306 /                       ext4    defaults        1 1
    UUID=5e15c6f6-4bba-4603-9ea6-7fcad1923f85 /boot                   ext4    defaults        1 2
    UUID=b23f18ce-42e9-4048-9913-29ca31cbb12b swap                    swap    defaults        0 0
    /dev/sda4 /mnt/data ntfs-3g users,gid=users,umask=0 0 0
    Thanks !
    Last edited by Frusciante; 27th July 2017 at 07:44 PM.

  2. #2
    Join Date
    Feb 2011
    Posts
    172

    Re: F25 - NTFS Partition not mounting in read/write

    i want mounted automatically and in read/write, i tried many options but without success
    What do you get ?

    Try remounting manually (as root) with no option, and post the output :

    Code:
    umount /mnt/data
    ntfs-3g /dev/sda4 /mnt/data

  3. #3
    Join Date
    Sep 2009
    Posts
    2,127

    Re: F25 - NTFS Partition not mounting in read/write

    Make sure you've set the power button to do a full shutdown in Windows. Google will show you how. By default, when you shutdown a newer Windows system, the Windows partition is not cleanly unmounted, and linux will refuse to mount it R/W.

    dd_wizard

  4. #4
    Join Date
    Jul 2017
    Location
    Home
    Posts
    2

    Re: F25 - NTFS Partition not mounting in read/write

    Quote Originally Posted by Jean Pierre
    What do you get ?

    Try remounting manually (as root) with no option, and post the output :

    Code:
    umount /mnt/data
    ntfs-3g /dev/sda4 /mnt/data
    I had a message telling me that there were filesystem errors so it was mounted with read only permissions, I rebooted under MS Windows and scanned and shut down properly but it didn't solve the problem until I tried dd_wizard's solution.

    Quote Originally Posted by dd_wizard
    Make sure you've set the power button to do a full shutdown in Windows. Google will show you how. By default, when you shutdown a newer Windows system, the Windows partition is not cleanly unmounted, and linux will refuse to mount it R/W.

    dd_wizard

    That was the issue ! I disabled the " Turn on fast startup " option in Windows's power settings and after booting on Fedora25 the partition is properly mounted with the writing permissions.


    Thanks for your help

Similar Threads

  1. Replies: 1
    Last Post: 24th July 2009, 04:19 PM
  2. Mounting externale HDD NTFS in read - write
    By tombol in forum Hardware & Laptops
    Replies: 3
    Last Post: 20th June 2005, 03:36 PM
  3. NTFS partition --> read-write
    By jort in forum Using Fedora
    Replies: 8
    Last Post: 8th March 2005, 03:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •