PgAdmin4 installation problem
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 10 of 10
  1. #1
    Join Date
    Jun 2009
    Location
    Queensland
    Posts
    292

    PgAdmin4 installation problem

    I have just upgraded to F26, which upgraded PostgreSQL to 9.6 from 9.5

    I use PgAdminIII frequently, but now it warns it only covers versions up to 9.5.

    PgAdmin4 is compatible with 9.6, but installation fails as follows:
    Code:
    [root@womble Flask-Babel-0.11.2]# dnf search pgadmin4
    Last metadata expiration check: 2:54:41 ago on Tue 18 Jul 2017 14:32:29 AEST.
    ============================================================== Summary & Name Matched: pgadmin4 ==============================================================
    pgadmin4-v1-web.noarch : pgAdmin4 web package
    pgadmin4-v1-docs.noarch : pgAdmin4 documentation
    pgadmin4-v1-debuginfo.x86_64 : Debug information for package pgadmin4-v1
    pgadmin4-python3-pyrsistent-debuginfo.x86_64 : Debug information for package pgadmin4-python3-pyrsistent
    =================================================================== Name Matched: pgadmin4 ===================================================================
    pgadmin4-v1.x86_64 : Management tool for PostgreSQL
    pgadmin4-python3-flask.noarch : A micro-framework for Python based on Werkzeug, Jinja 2 and good intentions
    pgadmin4-python3-wtforms.noarch : Forms validation and rendering library for python
    pgadmin4-python3-fixtures.noarch : Fixtures, reusable state for writing clean tests and more
    pgadmin4-python3-html5lib.noarch : A python based HTML parser/tokenizer
    pgadmin4-python3-flask-wtf.noarch : Simple integration of Flask and WTForms
    pgadmin4-python3-mimeparse.noarch : Python module for parsing mime-type names
    pgadmin4-python3-Flask-Mail.noarch : A Flask extension for sending email messages
    pgadmin4-python3-pyrsistent.x86_64 : Persistent/Functional/Immutable data structures
    pgadmin4-python3-flask-babel.noarch : Adds i18n/l10n support to Flask applications
    pgadmin4-python3-flask-login.noarch : User session management for Flask
    pgadmin4-python3-flask-htmlmin.noarch : Flask html response minifier
    pgadmin4-python3-flask-gravatar.noarch : Small extension for Flask to make usage of Gravatar service easy
    pgadmin4-python3-flask-security.noarch : Simple security for Flask apps
    pgadmin4-python3-flask-principal.noarch : Identity management for Flask applications
    [root@womble Flask-Babel-0.11.2]# dnf install pgadmin4*
    Last metadata expiration check: 2:55:21 ago on Tue 18 Jul 2017 14:32:29 AEST.
    Package pgadmin4-python3-flask-1:0.11.1-7.f26.noarch is already installed, skipping.
    Error: 
     Problem 1: conflicting requests
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-1.f26.noarch
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-2.f26.noarch
     Problem 2: conflicting requests
      - package pgadmin4-v1-1.6-1.f26.x86_64 requires pgadmin4-v1-web, but none of the providers can be installed
      - package pgadmin4-v1-1.6-2.f26.x86_64 requires pgadmin4-v1-web, but none of the providers can be installed
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-1.f26.noarch
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-2.f26.noarch
    
    [root@womble data]# dnf install pgadmin4-python3-flask-babel
    Last metadata expiration check: 0:12:53 ago on Wed 19 Jul 2017 12:16:38 AEST.
    Dependencies resolved.
    ==============================================================================================================================================================
     Package                                             Arch                          Version                                Repository                     Size
    ==============================================================================================================================================================
    Installing:
     pgadmin4-python3-flask-babel                        noarch                        0.11.1-3.f26                           pgdg96                         53 k
    
    Transaction Summary
    ==============================================================================================================================================================
    Install  1 Package
    
    Total download size: 53 k
    Installed size: 115 k
    Is this ok [y/N]: y
    Downloading Packages:
    pgadmin4-python3-flask-babel-0.11.1-3.f26.noarch.rpm                                                                           19 kB/s |  53 kB     00:02    
    --------------------------------------------------------------------------------------------------------------------------------------------------------------
    Total                                                                                                                          19 kB/s |  53 kB     00:02     
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    Transaction test succeeded.
    Running transaction
      Preparing        :                                                                                                                                      1/1 
      Installing       : pgadmin4-python3-flask-babel-0.11.1-3.f26.noarch                                                                                     1/1 
      Verifying        : pgadmin4-python3-flask-babel-0.11.1-3.f26.noarch                                                                                     1/1 
    
    Installed:
      pgadmin4-python3-flask-babel.noarch 0.11.1-3.f26                                                                                                            
    
    Complete!
    
    [root@womble data]# dnf install pgadmin4*
    Last metadata expiration check: 0:13:53 ago on Wed 19 Jul 2017 12:16:38 AEST.
    Package pgadmin4-python3-flask-1:0.11.1-7.f26.noarch is already installed, skipping.
    Package pgadmin4-python3-flask-babel-0.11.1-3.f26.noarch is already installed, skipping.
    Error: 
     Problem 1: conflicting requests
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-1.f26.noarch
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-2.f26.noarch
     Problem 2: conflicting requests
      - package pgadmin4-v1-1.6-1.f26.x86_64 requires pgadmin4-v1-web, but none of the providers can be installed
      - package pgadmin4-v1-1.6-2.f26.x86_64 requires pgadmin4-v1-web, but none of the providers can be installed
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-1.f26.noarch
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-2.f26.noarch
    I had hoped installing pgadmin4-python3-flask-1:0.11.1-7.f26.noarch would have satisfied the requirement for python3-flask >= 1.0.11, but no such luck.

    Any suggestions would be appreciated.

    Kind regards,
    Doug

  2. #2
    Join Date
    Jul 2013
    Location
    Brazil
    Posts
    14

    Re: PgAdmin4 installation problem

    Try this...:

    $ curl -o pgdg-fedora96-9.6-3.noarch.rpm https://download.postgresql.org/pub/...6-3.noarch.rpm

    $ sudo rpm -ivh pgdg-fedora96-9.6-3.noarch.rpm
    $ sudo rpm -qi pgdg-fedora96-9.6-3
    $ sudo dnf -y install pgadmin4-v1

  3. #3
    Join Date
    Jun 2009
    Location
    Queensland
    Posts
    292

    Re: PgAdmin4 installation problem

    Thank you for replying, tyuatsu.

    The result is slightly better, but still failing:
    Code:
    [root@womble data]# curl -o pgdg-fedora96-9.6-3.noarch.rpm https://download.postgresql.org/pub/repos/yum/9.6/fedora/fedora-25-x86_64/pgdg-fedora96-9.6-3.noarch.rpm
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100  8690  100  8690    0     0   3952      0  0:00:02  0:00:02 --:--:--  3953
    [root@womble data]# sudo rpm -ivh pgdg-fedora96-9.6-3.noarch.rpm
    Preparing...                          ################################# [100%]
    	package pgdg-fedora96-9.6-3.noarch is already installed
    [root@womble data]# sudo rpm -qi pgdg-fedora96-9.6-3
    Name        : pgdg-fedora96
    Version     : 9.6
    Release     : 3
    Architecture: noarch
    Install Date: Mon 17 Jul 2017 17:33:47 AEST
    Group       : System Environment/Base
    Size        : 2772
    License     : BSD
    Signature   : DSA/SHA1, Thu 13 Jul 2017 19:36:03 AEST, Key ID 1f16d2e1442df0f8
    Source RPM  : pgdg-fedora96-9.6-3.src.rpm
    Build Date  : Thu 13 Jul 2017 19:36:03 AEST
    Build Host  : koji-fedora26-x86-64-pgbuild
    Relocations : (not relocatable)
    URL         : https://yum.postgresql.org
    Summary     : PostgreSQL 9.6.X PGDG RPMs for Fedora - Yum Repository Configuration
    Description :
    This package contains yum configuration for Fedora, and also the GPG
    key for PGDG RPMs.
    [root@womble data]# sudo dnf -y install pgadmin4-v1
    Last metadata expiration check: 1:28:28 ago on Thu 20 Jul 2017 09:15:08 AEST.
    Error: 
     Problem: conflicting requests
      - package pgadmin4-v1-1.6-1.f26.x86_64 requires pgadmin4-v1-web, but none of the providers can be installed
      - package pgadmin4-v1-1.6-2.f26.x86_64 requires pgadmin4-v1-web, but none of the providers can be installed
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-1.f26.noarch
      - nothing provides python3-flask-babel >= 0.11.1 needed by pgadmin4-v1-web-1.6-2.f26.noarch
    It looks as though python3-flask-babel >= 0.11.1 is still the problem.

    Can you think of any other approaches?

  4. #4
    Join Date
    Jul 2013
    Location
    Brazil
    Posts
    14

    Re: PgAdmin4 installation problem

    broken deps... before install pgadmin4 try reinstall pgadmin3.

    Add this repo too:

    curl -o pgdg-fedora95-9.5-4.noarch.rpm https://download.postgresql.org/pub/...5-4.noarch.rpm

    sudo rpm -ivh pgdg-fedora95-9.5-4.noarch.rpm

    sudo dnf update
    sudo dnf -y reinstall pgadmin3 --allowerasing

    Now try install again pgAdmin4:

    sudo dnf -y install pgadmin4-v1 --allowerasing

    good luck!

  5. #5
    Join Date
    Jun 2009
    Location
    Queensland
    Posts
    292

    Re: PgAdmin4 installation problem

    Quote Originally Posted by tyuatsu
    broken deps...
    Thank you very much for the helpful advice.

    pgAdmin4 installed correctly after I followed your instructions, but it throws an error: "Fatal Error - The application server could not be contacted".

    pgAdmin3 still runs correctly.

    Is there some configuration file I need to edit?

    --------------

    Later ...

    Forget the above. I tried pgAdmin4 three more times and it finally woke up. I still have to get it configured, but it seems to be working.
    Again, many thanks
    Doug.

  6. #6
    Join Date
    Jul 2017
    Location
    Ukraine
    Posts
    1

    Re: PgAdmin4 installation problem

    Thank you. Helped too. Have had the same issue after upgrading Fedora from 25 to 26.

  7. #7
    Join Date
    Aug 2013
    Location
    California
    Posts
    3

    Re: PgAdmin4 installation problem

    After the latest pgadmin4-v4 update I ran into this same problem. I uninstalled and installed fresh. It appears something was reverted as the dependency python3-flask-babelex is still not being picked up by Fedora 27. This was fine a couple weeks ago but got broken again.

    Fedora 27
    4.15.15-300.fc27.x86_64 #1 SMP Mon Apr 2 23:14:02 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

  8. #8
    Join Date
    Apr 2018
    Location
    California
    Posts
    2

    Re: PgAdmin4 installation problem

    To add to this, I have been running pgadmin4 in desktop mode on Fedora 27 without issue for the past 3-4 months. Just yesterday I could no longer open pgadmin4 with the error: "Fatal Error - The application server could not be contacted". After a system update, I then got "An error occurred initialising the tray icon." I uninstalled pgadmin4 hoping a fresh install would fix it, but now I can't even install it. I followed the instructions here with no luck.

  9. #9
    Join Date
    Aug 2013
    Location
    California
    Posts
    3

    Re: PgAdmin4 installation problem

    Quote Originally Posted by carlps
    To add to this, I have been running pgadmin4 in desktop mode on Fedora 27 without issue for the past 3-4 months. Just yesterday I could no longer open pgadmin4 with the error: "Fatal Error - The application server could not be contacted". After a system update, I then got "An error occurred initialising the tray icon." I uninstalled pgadmin4 hoping a fresh install would fix it, but now I can't even install it. I followed the instructions here with no luck.
    Did you try to run
    Code:
    sudo dnf install python3-flask-babelex
    ?

    If you install from scratch this dependency is not being picked up and you'll see the error you're seeing.

    You may also not have the process started:

    Code:
    sudo service pgadmin4-v2 start
    sudo systemctl enable pgadmin4-v2
    I just did another update and it looks like pgadmin4-v2 was replaced by pgadmin4. So the above is not valid unless you're still running pgadmin4-v2.

    Now you can go to a web browser via http://127.0.0.1:38063/browser/
    Last edited by ndurbin; 17th April 2018 at 06:34 PM.

  10. #10
    Join Date
    Apr 2018
    Location
    California
    Posts
    2

    Re: PgAdmin4 installation problem

    So I installed python3-flask-babelex, but couldn't start the service. It seems pgadmin4 and pgadmin4-v2 were being mixed up in my dnf. When trying to reinstall pgadmin4-v2, I was getting the following error:
    Code:
    Error: 
     Problem: conflicting requests
      - package pgadmin4-v2-2.0-1.f27.x86_64 requires pgadmin4-v2-web, but none of the providers can be installed
      - package pgadmin4-v2-2.1-1.f27.x86_64 requires pgadmin4-v2-web, but none of the providers can be installed
      - installed package pgadmin4-web-3.0-3.f27.noarch obsoletes pgadmin4-v2-web provided by pgadmin4-v2-web-2.0-1.f27.noarch
      - installed package pgadmin4-web-3.0-3.f27.noarch obsoletes pgadmin4-v2-web provided by pgadmin4-v2-web-2.1-1.f27.noarch
      - problem with installed package pgadmin4-web-3.0-3.f27.noarch
    What ended up working was:
    Code:
    $ sudo dnf remove pgadmin4-web
    $ sudo dnf remove pgadmin4-docs
    $ sudo dnf install pgadmin4-v2-web
    $ sudo dnf install pgadmin4-v2
    Now I can run desktop pgadmin4 again. Thanks for the help!

Similar Threads

  1. problem during installation "which type of installation would you like?"
    By rob2468 in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 17th June 2011, 08:09 AM
  2. F14 does not boot after installation.(problem after problem)
    By piopio in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 31st December 2010, 10:06 AM
  3. Replies: 1
    Last Post: 30th July 2010, 11:01 AM
  4. Installation problem. Installation keeps asking for driver.
    By dutchmanjay in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 1st June 2007, 06:54 PM
  5. Add/Remove problem and software installation problem
    By elirfan in forum Using Fedora
    Replies: 0
    Last Post: 2nd February 2007, 11:33 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •