Hello everyone -

This problem has been bugging me for several months. I have not found any way to make it work. Even Google does not have an answer!

I want to create a menu item in KDE to launch ssh and connect to a specific server. The command line looks like this:

Code:
ssh -4 -l bgee server.mynetwork.net
This command works perfectly from a bash shell. When I use kmenuedit to create an item, no error is produced. However, the item does not launch. I get an icon in the plasma bar for about 2 seconds - then nothing. PS does not show any running ssh process. No error message is produced.

On the Advanced page of kmenuedit I have tried both checking and unchecking the "run in a terminal" box. It makes no difference.

I created a bash shell script to launch ssh. The script runs correctly when run from bash, but fails when run from a KDE menu item. I even tried launching it as a parameter to bash. No happiness.

What the heck is going on? How can I create a KDE menu item that runs ssh?

Thanks - Bill Gee